You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Mike Sokolov (JIRA)" <ji...@apache.org> on 2018/04/11 14:28:00 UTC

[jira] [Commented] (LUCENE-8248) Rename MergePolicyWrapper to FilterMergePolicy and override all of MergePolicy

    [ https://issues.apache.org/jira/browse/LUCENE-8248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16433994#comment-16433994 ] 

Mike Sokolov commented on LUCENE-8248:
--------------------------------------

Oh yes that makes sense. Then we are enforcing this Filter pattern in the right place. I also changed the name of the issue to reflect what this is about now.

> Rename MergePolicyWrapper to FilterMergePolicy and override all of MergePolicy
> ------------------------------------------------------------------------------
>
>                 Key: LUCENE-8248
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8248
>             Project: Lucene - Core
>          Issue Type: Wish
>          Components: core/index
>            Reporter: Mike Sokolov
>            Priority: Minor
>         Attachments: LUCENE-8248.patch, MergePolicy.patch
>
>
> MergePolicy.getMaxCFSSegmentSizeMB is final, but the corresponding setter is not, which means that overriding it with anything other than a trivial delegation can only lead to confusion.
> The patch makes the method final and removes the trivial implementations from MergePolicyWrapper and NoMergePolicy.
> [~mikemccand] also pointed out that the class name is nonstandard for similar adapter classes in Lucene, which are usually Filter*.java. Personally I was looking for MergePolicyAdapter, but if there is a prevailing convention here around Filter, does it make sense to change this class's name to FilterMergePolicy?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org