You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@oozie.apache.org by Azrael Park <az...@nexr.com> on 2015/02/26 05:50:09 UTC

Re: Review Request 23301: OOZIE-1918 ActionXCommand refactoring

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23301/
-----------------------------------------------------------

(Updated Feb. 26, 2015, 4:50 a.m.)


Review request for oozie.


Changes
-------

Rebased on the latest branch.
* Add testcase to test event generation when ActionExecutorException.ErrorType.FAILED occurs.


Bugs: OOZIE-1918
    https://issues.apache.org/jira/browse/OOZIE-1918


Repository: oozie-git


Description
-------

Subclasses of ActionXCommand have some duplicated code. Refactoring make it more neat.
This patch contain:
* Renaming CompletedActionXCommand to ActionCompletedXCommand and extending ActionXCommand
* Moving some variables and methods to ActionXCommand and making it protected
* More meaningful log message : On exeucte(), actionId is duplicated so removed
* Adding handleExecutionFail() to handle ActionExcutionException during execute()


Diffs (updated)
-----

  core/src/main/java/org/apache/oozie/DagEngine.java ac2e7b1 
  core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java e9488d4 
  core/src/main/java/org/apache/oozie/command/wf/ActionCompletedXCommand.java PRE-CREATION 
  core/src/main/java/org/apache/oozie/command/wf/ActionEndXCommand.java 4006441 
  core/src/main/java/org/apache/oozie/command/wf/ActionKillXCommand.java 33498bf 
  core/src/main/java/org/apache/oozie/command/wf/ActionStartXCommand.java d4048a1 
  core/src/main/java/org/apache/oozie/command/wf/ActionXCommand.java 69a363b 
  core/src/main/java/org/apache/oozie/command/wf/CompletedActionXCommand.java b1226cc 
  core/src/test/java/org/apache/oozie/ForTestingActionExecutor.java a70dc02 
  core/src/test/java/org/apache/oozie/event/TestEventGeneration.java 14f5294 

Diff: https://reviews.apache.org/r/23301/diff/


Testing
-------

No added new testcase.
Done manual test.


Thanks,

Azrael Park


Re: Review Request 23301: OOZIE-1918 ActionXCommand refactoring

Posted by Azrael Seoeun Park <se...@gmail.com>.

> On June 17, 2015, 1:08 p.m., Jaydeep Vishwakarma wrote:
> > core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java, line 168
> > <https://reviews.apache.org/r/23301/diff/3/?file=877400#file877400line168>
> >
> >     Action id is missing in all loging

I removed actionId because the log prefix contain the action Id.

{quote}
015-07-05 00:21:07,814 DEBUG ActionStartXCommand:526 [pool-5-thread-9] - USER[seoeun] GROUP[staff] TOKEN[] APP[test] JOB[0000000-150705001901308-oozie-seoe-W] ACTION[0000000-150705001901308-oozie-seoe-W@shell-2] .......
{quote}

Though, we need actionId for the text search on logfilter (OOZIE-1802), so I revert it.


- Azrael Seoeun


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23301/#review74731
-----------------------------------------------------------


On July 6, 2015, 3:36 a.m., Azrael Seoeun Park wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/23301/
> -----------------------------------------------------------
> 
> (Updated July 6, 2015, 3:36 a.m.)
> 
> 
> Review request for oozie.
> 
> 
> Bugs: OOZIE-1918
>     https://issues.apache.org/jira/browse/OOZIE-1918
> 
> 
> Repository: oozie-git
> 
> 
> Description
> -------
> 
> Subclasses of ActionXCommand have some duplicated code. Refactoring make it more neat.
> This patch contain:
> * Renaming CompletedActionXCommand to ActionCompletedXCommand and extending ActionXCommand
> * Moving some variables and methods to ActionXCommand and making it protected
> * More meaningful log message : On exeucte(), actionId is duplicated so removed
> * Adding handleExecutionFail() to handle ActionExcutionException during execute()
> 
> 
> Diffs
> -----
> 
>   core/src/main/java/org/apache/oozie/DagEngine.java 9061d17 
>   core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java 5827387 
>   core/src/main/java/org/apache/oozie/command/wf/ActionCompletedXCommand.java PRE-CREATION 
>   core/src/main/java/org/apache/oozie/command/wf/ActionEndXCommand.java 4006441 
>   core/src/main/java/org/apache/oozie/command/wf/ActionKillXCommand.java 33498bf 
>   core/src/main/java/org/apache/oozie/command/wf/ActionStartXCommand.java e06649c 
>   core/src/main/java/org/apache/oozie/command/wf/ActionXCommand.java 2616d32 
>   core/src/main/java/org/apache/oozie/command/wf/CompletedActionXCommand.java bc39bce 
>   core/src/test/java/org/apache/oozie/ForTestingActionExecutor.java a70dc02 
>   core/src/test/java/org/apache/oozie/command/wf/TestCompletedActionXCommand.java a4f0e83 
>   core/src/test/java/org/apache/oozie/event/TestEventGeneration.java 14f5294 
> 
> Diff: https://reviews.apache.org/r/23301/diff/
> 
> 
> Testing
> -------
> 
> No added new testcase.
> Done manual test.
> 
> 
> Thanks,
> 
> Azrael Seoeun Park
> 
>


Re: Review Request 23301: OOZIE-1918 ActionXCommand refactoring

Posted by Jaydeep Vishwakarma <ja...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23301/#review74731
-----------------------------------------------------------



core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java (line 130)
<https://reviews.apache.org/r/23301/#comment140619>

    Action id is missing in all loging



core/src/main/java/org/apache/oozie/command/wf/ActionEndXCommand.java (line 108)
<https://reviews.apache.org/r/23301/#comment121433>

    keeping the status alone without the id does not make any sense, It might be your restructuring bug?


- Jaydeep Vishwakarma


On Feb. 26, 2015, 4:50 a.m., Azrael Park wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/23301/
> -----------------------------------------------------------
> 
> (Updated Feb. 26, 2015, 4:50 a.m.)
> 
> 
> Review request for oozie.
> 
> 
> Bugs: OOZIE-1918
>     https://issues.apache.org/jira/browse/OOZIE-1918
> 
> 
> Repository: oozie-git
> 
> 
> Description
> -------
> 
> Subclasses of ActionXCommand have some duplicated code. Refactoring make it more neat.
> This patch contain:
> * Renaming CompletedActionXCommand to ActionCompletedXCommand and extending ActionXCommand
> * Moving some variables and methods to ActionXCommand and making it protected
> * More meaningful log message : On exeucte(), actionId is duplicated so removed
> * Adding handleExecutionFail() to handle ActionExcutionException during execute()
> 
> 
> Diffs
> -----
> 
>   core/src/main/java/org/apache/oozie/DagEngine.java ac2e7b1 
>   core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java e9488d4 
>   core/src/main/java/org/apache/oozie/command/wf/ActionCompletedXCommand.java PRE-CREATION 
>   core/src/main/java/org/apache/oozie/command/wf/ActionEndXCommand.java 4006441 
>   core/src/main/java/org/apache/oozie/command/wf/ActionKillXCommand.java 33498bf 
>   core/src/main/java/org/apache/oozie/command/wf/ActionStartXCommand.java d4048a1 
>   core/src/main/java/org/apache/oozie/command/wf/ActionXCommand.java 69a363b 
>   core/src/main/java/org/apache/oozie/command/wf/CompletedActionXCommand.java b1226cc 
>   core/src/test/java/org/apache/oozie/ForTestingActionExecutor.java a70dc02 
>   core/src/test/java/org/apache/oozie/event/TestEventGeneration.java 14f5294 
> 
> Diff: https://reviews.apache.org/r/23301/diff/
> 
> 
> Testing
> -------
> 
> No added new testcase.
> Done manual test.
> 
> 
> Thanks,
> 
> Azrael Park
> 
>


Re: Review Request 23301: OOZIE-1918 ActionXCommand refactoring

Posted by Jaydeep Vishwakarma <ja...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23301/#review94678
-----------------------------------------------------------



core/src/main/java/org/apache/oozie/DagEngine.java (line 332)
<https://reviews.apache.org/r/23301/#comment149283>

    Priority is not being used, use other contructor



core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java (line 82)
<https://reviews.apache.org/r/23301/#comment149284>

    Can you rename it to loadWorkflowAndActionBean. loadActionbean is missleading.



core/src/main/java/org/apache/oozie/command/wf/ActionCompletedXCommand.java (line 51)
<https://reviews.apache.org/r/23301/#comment149282>

    pririty is not being used anywhere over here, It will also misslead. We dont need it.


- Jaydeep Vishwakarma


On July 6, 2015, 3:36 a.m., Azrael Seoeun Park wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/23301/
> -----------------------------------------------------------
> 
> (Updated July 6, 2015, 3:36 a.m.)
> 
> 
> Review request for oozie.
> 
> 
> Bugs: OOZIE-1918
>     https://issues.apache.org/jira/browse/OOZIE-1918
> 
> 
> Repository: oozie-git
> 
> 
> Description
> -------
> 
> Subclasses of ActionXCommand have some duplicated code. Refactoring make it more neat.
> This patch contain:
> * Renaming CompletedActionXCommand to ActionCompletedXCommand and extending ActionXCommand
> * Moving some variables and methods to ActionXCommand and making it protected
> * More meaningful log message : On exeucte(), actionId is duplicated so removed
> * Adding handleExecutionFail() to handle ActionExcutionException during execute()
> 
> 
> Diffs
> -----
> 
>   core/src/main/java/org/apache/oozie/DagEngine.java 9061d17 
>   core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java 5827387 
>   core/src/main/java/org/apache/oozie/command/wf/ActionCompletedXCommand.java PRE-CREATION 
>   core/src/main/java/org/apache/oozie/command/wf/ActionEndXCommand.java 4006441 
>   core/src/main/java/org/apache/oozie/command/wf/ActionKillXCommand.java 33498bf 
>   core/src/main/java/org/apache/oozie/command/wf/ActionStartXCommand.java e06649c 
>   core/src/main/java/org/apache/oozie/command/wf/ActionXCommand.java 2616d32 
>   core/src/main/java/org/apache/oozie/command/wf/CompletedActionXCommand.java bc39bce 
>   core/src/test/java/org/apache/oozie/ForTestingActionExecutor.java a70dc02 
>   core/src/test/java/org/apache/oozie/command/wf/TestCompletedActionXCommand.java a4f0e83 
>   core/src/test/java/org/apache/oozie/event/TestEventGeneration.java 14f5294 
> 
> Diff: https://reviews.apache.org/r/23301/diff/
> 
> 
> Testing
> -------
> 
> No added new testcase.
> Done manual test.
> 
> 
> Thanks,
> 
> Azrael Seoeun Park
> 
>


Re: Review Request 23301: OOZIE-1918 ActionXCommand refactoring

Posted by Azrael Seoeun Park <se...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/23301/
-----------------------------------------------------------

(Updated July 6, 2015, 3:36 a.m.)


Review request for oozie.


Changes
-------

Addressed comments.
Rebased on the lates branch.


Bugs: OOZIE-1918
    https://issues.apache.org/jira/browse/OOZIE-1918


Repository: oozie-git


Description
-------

Subclasses of ActionXCommand have some duplicated code. Refactoring make it more neat.
This patch contain:
* Renaming CompletedActionXCommand to ActionCompletedXCommand and extending ActionXCommand
* Moving some variables and methods to ActionXCommand and making it protected
* More meaningful log message : On exeucte(), actionId is duplicated so removed
* Adding handleExecutionFail() to handle ActionExcutionException during execute()


Diffs (updated)
-----

  core/src/main/java/org/apache/oozie/DagEngine.java 9061d17 
  core/src/main/java/org/apache/oozie/command/wf/ActionCheckXCommand.java 5827387 
  core/src/main/java/org/apache/oozie/command/wf/ActionCompletedXCommand.java PRE-CREATION 
  core/src/main/java/org/apache/oozie/command/wf/ActionEndXCommand.java 4006441 
  core/src/main/java/org/apache/oozie/command/wf/ActionKillXCommand.java 33498bf 
  core/src/main/java/org/apache/oozie/command/wf/ActionStartXCommand.java e06649c 
  core/src/main/java/org/apache/oozie/command/wf/ActionXCommand.java 2616d32 
  core/src/main/java/org/apache/oozie/command/wf/CompletedActionXCommand.java bc39bce 
  core/src/test/java/org/apache/oozie/ForTestingActionExecutor.java a70dc02 
  core/src/test/java/org/apache/oozie/command/wf/TestCompletedActionXCommand.java a4f0e83 
  core/src/test/java/org/apache/oozie/event/TestEventGeneration.java 14f5294 

Diff: https://reviews.apache.org/r/23301/diff/


Testing
-------

No added new testcase.
Done manual test.


Thanks,

Azrael Seoeun Park