You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hive.apache.org by "Fei Hui (JIRA)" <ji...@apache.org> on 2017/02/27 04:40:45 UTC

[jira] [Commented] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name

    [ https://issues.apache.org/jira/browse/HIVE-16043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15885124#comment-15885124 ] 

Fei Hui commented on HIVE-16043:
--------------------------------

CC [~sershe] .I see HIVE-16010 , and find that maybe it is better like this for consistent usage.
How do you think, could you please give any suggestions?

> TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
> ---------------------------------------------------------
>
>                 Key: HIVE-16043
>                 URL: https://issues.apache.org/jira/browse/HIVE-16043
>             Project: Hive
>          Issue Type: Bug
>          Components: Tez
>    Affects Versions: 2.2.0
>            Reporter: Fei Hui
>            Assignee: Fei Hui
>         Attachments: HIVE-16043.1.patch
>
>
> I see the following source in hive
> {code:title=TezSessionPoolManager.java|borderStyle=solid}
>    private TezSessionState getSession(HiveConf conf, boolean doOpen)
>        throws Exception {
>      String queueName = conf.get("tez.queue.name");
>      ...
>    }
>   private TezSessionState getNewSessionState(HiveConf conf,
>       String queueName, boolean doOpen) throws Exception {
>     TezSessionPoolSession retTezSessionState = createAndInitSession(queueName, false);
>     if (queueName != null) {
>       conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
>     }
>   ...
>   }
> {code}
> TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we should consistently use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)