You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@oodt.apache.org by "Ross Laidlaw (JIRA)" <ji...@apache.org> on 2013/03/14 15:12:13 UTC

[jira] [Closed] (OODT-571) Assignments in the setWorkflowInst and setWaitforConditionSatisfy methods need 'this' keyword

     [ https://issues.apache.org/jira/browse/OODT-571?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ross Laidlaw closed OODT-571.
-----------------------------

    
> Assignments in the setWorkflowInst and setWaitforConditionSatisfy methods need 'this' keyword
> ---------------------------------------------------------------------------------------------
>
>                 Key: OODT-571
>                 URL: https://issues.apache.org/jira/browse/OODT-571
>             Project: OODT
>          Issue Type: Bug
>          Components: workflow manager
>    Affects Versions: 0.5
>            Reporter: Ross Laidlaw
>            Assignee: Ross Laidlaw
>            Priority: Minor
>             Fix For: 0.6
>
>         Attachments: OODT-571.rlaidlaw.2013-03-07.txt
>
>
> I found minor bugs in two setter methods in the org.apache.oodt.cas.workflow.engine.IterativeWorkflowProcessorThread class:
> {code:title=IterativeWorkflowProcessorThread.java|borderStyle=solid}
> public void setWorkflowInst(WorkflowInstance workflowInst)
> {
>   workflowInst = workflowInst;
> }
> public void setWaitforConditionSatisfy(long waitforConditionSatisfy)
> {
>   waitForConditionSatisfy = waitforConditionSatisfy;
> }
> {code}
> They should be changed to the following so that values from the parameters are assigned to member variables:
> {code:title=IterativeWorkflowProcessorThread.java|borderStyle=solid}
> public void setWorkflowInst(WorkflowInstance workflowInst)
> {
>   this.workflowInst = workflowInst;
> }
> public void setWaitforConditionSatisfy(long waitforConditionSatisfy)
> {
>   this.waitForConditionSatisfy = waitforConditionSatisfy;
> }
> {code}
> I've attached a patch for reference.  Although this should be a trivial change I wanted to post this issue and patch to make sure that the change would be ok.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira