You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@geode.apache.org by "Alberto Bustamante Reyes (Jira)" <ji...@apache.org> on 2021/06/24 14:30:00 UTC

[jira] [Resolved] (GEODE-2842) Remove unnecessary @CliOption arguments

     [ https://issues.apache.org/jira/browse/GEODE-2842?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Alberto Bustamante Reyes resolved GEODE-2842.
---------------------------------------------
    Resolution: Fixed

Closing this ticket as currently there are no "@CliOption" annotations with "mandatory = false" or using "CliMetaData.ANNOTATION_NULL_VALUE"

> Remove unnecessary @CliOption arguments
> ---------------------------------------
>
>                 Key: GEODE-2842
>                 URL: https://issues.apache.org/jira/browse/GEODE-2842
>             Project: Geode
>          Issue Type: Bug
>          Components: gfsh
>            Reporter: Jared Stewart
>            Assignee: Jared Stewart
>            Priority: Major
>
> The {{@CliOption}} annotation specifies default values for some of its fields (like {{mandatory}} and {{unspecifiedDefaultValue}}).  Yet, we often explicitly set those fields to the default value.  For example,
> {noformat}      @CliOption(key = CliStrings.START_LOCATOR__MEMBER_NAME, mandatory = false,
>           unspecifiedDefaultValue = CliMetaData.ANNOTATION_NULL_VALUE,
>           help = CliStrings.START_LOCATOR__MEMBER_NAME__HELP) String memberName {noformat}
> could simply read   
> {noformat}      @CliOption(key = CliStrings.START_LOCATOR__MEMBER_NAME,
>           help = CliStrings.START_LOCATOR__MEMBER_NAME__HELP) String memberName {noformat}
> Removing these redundant/unnecessary arguments will make the code a lot more readable.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)