You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Michael McCandless (JIRA)" <ji...@apache.org> on 2016/03/18 19:49:33 UTC
[jira] [Commented] (LUCENE-7118) Remove multidimensional arrays
from PointRangeQuery
[ https://issues.apache.org/jira/browse/LUCENE-7118?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15201958#comment-15201958 ]
Michael McCandless commented on LUCENE-7118:
--------------------------------------------
+1
byte[][] is deadly :)
> Remove multidimensional arrays from PointRangeQuery
> ---------------------------------------------------
>
> Key: LUCENE-7118
> URL: https://issues.apache.org/jira/browse/LUCENE-7118
> Project: Lucene - Core
> Issue Type: Bug
> Reporter: Robert Muir
> Attachments: LUCENE-7118.patch
>
>
> This use of byte[][] has caused two bugs: LUCENE-7085 and LUCENE-7117.
> It is not necessary, and causes code duplication in most Point classes because they have to have a {{pack()}} that encodes to byte[] for the indexer but a {{encode()}} or similar that makes multi-D byte[][] for just this query.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org