You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@harmony.apache.org by Geir Magnusson Jr <ge...@pobox.com> on 2005/12/30 17:34:31 UTC

Re: repo layout again


Tim Ellison wrote:
> Geir Magnusson Jr wrote:
> 
>>does this follow from the convo re layout we had last week?
> 
> 
> yes, plus me trying to follow along with an Eclipse set-up to do
> development.

Ah - that's key for you.  Please help us Eclipse journeymen when you get 
it figured out...

> 
> 
>>We'd
>>prollie want to rename java-src to something else being it's more like a
>>module than just java...
> 
> 
> Well today it _is_ just java (and a bit of metadata) in there, but I
> agree that thoughts of making them a bit more than that is goodness.
> 

I thought we'd given some serious thought and had some kind of agreement 
that it's worth putting the natives for a given module in that module (I 
won't use the term 'component' there)

That would mean :

modules/
    luni/
       java-src/
           ... your tree for luni java
       native-src/
           ... your tree for luni natives


geir

> Regards,
> Tim
> 
> 
>>Tim Ellison wrote:
>>
>>
>>>beats me :-)
>>>
>>>I was following along with the Maven standard directory structure [1] as
>>>much as possible, since we might as well do that rather than invent
>>>something gratuitously different.  (I know nothing about maven, and I'm
>>>open to changing the structure to suit the majority.)
>>>
>>>This is where I was heading:
>>>
>>>.../classlib/trunk/
>>>  java-src/                 <- poor name, easily changed later
>>>    <component_name>/
>>>      make/               <- component-level build script
>>>      src/
>>>        main/
>>>          java/
>>>            org/apache/harmony/...  <- impl types
>>>            java/<whatever>/...     <- Java API types
>>>          resources/
>>>        test/
>>>          java/
>>>            org/apache/harmony/...  <- unit tests
>>>          resources/
>>>      META-INF/MANIFEST.MF         <- OSGi manifest
>>>    <component_name_2>/
>>>      ...
>>>  make/                 <- 'bootstrap'/global build script
>>>  target/               <- results of builds
>>>
>>>  native-src/   <- I'm going to leave the natives structure
>>>                   alone for the moment
>>>
>>>I guess the main omission at the moment is a location for
>>>platform-specific code, I didn't see anything on the maven site about
>>>that.
>>>
>>>[1]
>>>http://maven.apache.org/guides/introduction/introduction-to-the-standard-directory-layout.html
>>>
>>>
>>>Regards,
>>>Tim
>>>
>>>Geir Magnusson Jr. wrote:
>>>
>>>
>>>>what does "main" mean?
>>>>
>>>>
>>>>On Dec 29, 2005, at 8:31 AM, tellison@apache.org wrote:
>>>>
>>>>
>>>>
>>>>>Author: tellison
>>>>>Date: Thu Dec 29 05:31:44 2005
>>>>>New Revision: 359782
>>>>>
>>>>>URL: http://svn.apache.org/viewcvs?rev=359782&view=rev
>>>>>Log:
>>>>>Restructuring NIO component layout to allow main and test co-location
>>>>>
>>>>>Added:
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/main/
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/test/
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/test/
>>>>>java/
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/test/
>>>>>resources/
>>>>>Removed:
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/com/
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/java/
>>>>>
>>>>
> 

Re: repo layout again

Posted by Mark Wielaard <ma...@klomp.org>.
On Fri, 2005-12-30 at 11:34 -0500, Geir Magnusson Jr wrote:
> Tim Ellison wrote:
> > yes, plus me trying to follow along with an Eclipse set-up to do
> > development.
> 
> Ah - that's key for you.  Please help us Eclipse journeymen when you get 
> it figured out...

Take a look at
http://developer.classpath.org/mediation/ClasspathHackingWithEclipse
that describes (with some screenshots) how to setup a pretty complex
project like GNU Classpath with Cacao or JamVM in Eclipse and how to use
it to hack and bootstrap a complete free stack (using nothing except
Free Software of course!). The cool thing is that you can then use the
result again to run Eclipse itself :) It also shows why it is cool to
have all tests in Mauve since then it is easy to run them against the
different setups/runtimes you made inside Eclipse.

Cheers,

Mark
-- 
Escape the Java Trap with GNU Classpath!
http://www.gnu.org/philosophy/java-trap.html

Join the community at http://planet.classpath.org/

Re: repo layout again

Posted by George Harley1 <GH...@uk.ibm.com>.
Hi, 

How does this sound for the layout of a given module/component/thing (in 
this case "luni") ...

classlib/trunk
           |
           +--java-src
                |
                +--luni
                   |
                   |
                   +---src
                   |    |
                   |    +--main
                   |    |   |
                   |    |   +--<platform>
                   |    |          |
                   |    |          +--native
                   |    |          |
                   |    |          +--java
                   |    |          |
                   |    |          +--resources
                   |    |
                   |    +--test
                   |        |
                   |        +--java
                   |        |
                   |        +--resources
                   | 
                   | 
                   +--doc



where the value of <platform> comes from the set of agreed identifiers for 
all operating systems we build/run on that have platform-specific code 
together with the "common" identifier for all platform-neutral code. There 
would be multiple <platform> subdirectories under the "main" folder like 
this  ...


                   +---src
                   |    |
                   |    +--main
                   |    |   |
                   |    |   +--common
                   |    |   |    |
                   |    |   |    +--native
                   |    |   |    |
                   |    |   |    +--java
                   |    |   |    |
                   |    |   |    +--resources
                            |
                            |
                            +--win32.x86
                            |    |
                            |    +--native
                            |    |
                            |    +--java
                            |    |
                            |    +--resources
                            |
                            |
                            +--linux32.x86
                            |    |
                            |    +--native
                            |    |
                            |    +--java
                            |    |
                            |    +--resources
                            |
                            ...etc...
 


I'm keeping my fingers crossed that my mail client doesn't completely mess 
up the above formatting. 

Best regards, 
George
________________________________________
George C. Harley





Geir Magnusson Jr <ge...@pobox.com> 
30/12/2005 16:34
Please respond to
harmony-dev@incubator.apache.org


To
harmony-dev@incubator.apache.org
cc

Subject
Re: repo layout again








Tim Ellison wrote:
> Geir Magnusson Jr wrote:
> 
>>does this follow from the convo re layout we had last week?
> 
> 
> yes, plus me trying to follow along with an Eclipse set-up to do
> development.

Ah - that's key for you.  Please help us Eclipse journeymen when you get 
it figured out...

> 
> 
>>We'd
>>prollie want to rename java-src to something else being it's more like a
>>module than just java...
> 
> 
> Well today it _is_ just java (and a bit of metadata) in there, but I
> agree that thoughts of making them a bit more than that is goodness.
> 

I thought we'd given some serious thought and had some kind of agreement 
that it's worth putting the natives for a given module in that module (I 
won't use the term 'component' there)

That would mean :

modules/
    luni/
       java-src/
           ... your tree for luni java
       native-src/
           ... your tree for luni natives


geir

> Regards,
> Tim
> 
> 
>>Tim Ellison wrote:
>>
>>
>>>beats me :-)
>>>
>>>I was following along with the Maven standard directory structure [1] 
as
>>>much as possible, since we might as well do that rather than invent
>>>something gratuitously different.  (I know nothing about maven, and I'm
>>>open to changing the structure to suit the majority.)
>>>
>>>This is where I was heading:
>>>
>>>.../classlib/trunk/
>>>  java-src/                 <- poor name, easily changed later
>>>    <component_name>/
>>>      make/               <- component-level build script
>>>      src/
>>>        main/
>>>          java/
>>>            org/apache/harmony/...  <- impl types
>>>            java/<whatever>/...     <- Java API types
>>>          resources/
>>>        test/
>>>          java/
>>>            org/apache/harmony/...  <- unit tests
>>>          resources/
>>>      META-INF/MANIFEST.MF         <- OSGi manifest
>>>    <component_name_2>/
>>>      ...
>>>  make/                 <- 'bootstrap'/global build script
>>>  target/               <- results of builds
>>>
>>>  native-src/   <- I'm going to leave the natives structure
>>>                   alone for the moment
>>>
>>>I guess the main omission at the moment is a location for
>>>platform-specific code, I didn't see anything on the maven site about
>>>that.
>>>
>>>[1]
>>>http://maven.apache.org/guides/introduction/introduction-to-the-standard-directory-layout.html
>>>
>>>
>>>Regards,
>>>Tim
>>>
>>>Geir Magnusson Jr. wrote:
>>>
>>>
>>>>what does "main" mean?
>>>>
>>>>
>>>>On Dec 29, 2005, at 8:31 AM, tellison@apache.org wrote:
>>>>
>>>>
>>>>
>>>>>Author: tellison
>>>>>Date: Thu Dec 29 05:31:44 2005
>>>>>New Revision: 359782
>>>>>
>>>>>URL: http://svn.apache.org/viewcvs?rev=359782&view=rev
>>>>>Log:
>>>>>Restructuring NIO component layout to allow main and test co-location
>>>>>
>>>>>Added:
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/main/
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/test/
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/test/
>>>>>java/
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/test/
>>>>>resources/
>>>>>Removed:
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/com/
>>>>>   incubator/harmony/enhanced/classlib/trunk/java-src/nio/src/java/
>>>>>
>>>>
>