You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tomcat.apache.org by ma...@apache.org on 2026/06/03 10:36:28 UTC
(tomcat) branch main updated: Improve readability
This is an automated email from the ASF dual-hosted git repository.
markt-asf pushed a commit to branch main
in repository https://gitbox.apache.org/repos/asf/tomcat.git
The following commit(s) were added to refs/heads/main by this push:
new 2465d4468f Improve readability
2465d4468f is described below
commit 2465d4468fd0a6b15a8051a7004d1f822546d1ac
Author: Mark Thomas <ma...@apache.org>
AuthorDate: Wed Jun 3 11:36:21 2026 +0100
Improve readability
---
.../util/net/openssl/ciphers/OpenSSLCipherConfigurationParser.java | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/java/org/apache/tomcat/util/net/openssl/ciphers/OpenSSLCipherConfigurationParser.java b/java/org/apache/tomcat/util/net/openssl/ciphers/OpenSSLCipherConfigurationParser.java
index b39ff4599a..adc72ec4bf 100644
--- a/java/org/apache/tomcat/util/net/openssl/ciphers/OpenSSLCipherConfigurationParser.java
+++ b/java/org/apache/tomcat/util/net/openssl/ciphers/OpenSSLCipherConfigurationParser.java
@@ -493,7 +493,6 @@ public class OpenSSLCipherConfigurationParser {
addListAlias(aSRP, filterByAuthentication(allCiphers, Collections.singleton(Authentication.SRP)));
addListAlias(kSRP, filterByKeyExchange(allCiphers, Collections.singleton(KeyExchange.SRP)));
addListAlias(SRP, filterByKeyExchange(allCiphers, Collections.singleton(KeyExchange.SRP)));
- initialized = true;
addListAlias(DEFAULT, parse("ALL:!eNULL:!aNULL:!DES:!RC2:!RC4:!DSS:!SEED:!IDEA:!CAMELLIA:!AESCCM:!3DES:!ARIA"));
// COMPLEMENTOFDEFAULT is also not exactly as defined by the docs
LinkedHashSet<Cipher> complementOfDefault =
@@ -512,6 +511,8 @@ public class OpenSSLCipherConfigurationParser {
complementOfDefault.addAll(aliases.get(ARIA));
defaultSort(complementOfDefault);
addListAlias(COMPLEMENTOFDEFAULT, complementOfDefault);
+
+ initialized = true;
}
static void addListAlias(String alias, Set<Cipher> ciphers) {
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org
Re: (tomcat) branch main updated: Improve readability
Posted by Mark Thomas <ma...@apache.org>.
On 03/06/2026 11:39, Rémy Maucherat wrote:
> On Wed, Jun 3, 2026 at 12:36 PM <ma...@apache.org> wrote:
>>
>> This is an automated email from the ASF dual-hosted git repository.
>>
>> markt-asf pushed a commit to branch main
>> in repository https://gitbox.apache.org/repos/asf/tomcat.git
>>
>>
>> The following commit(s) were added to refs/heads/main by this push:
>> new 2465d4468f Improve readability
>> 2465d4468f is described below
>>
>> commit 2465d4468fd0a6b15a8051a7004d1f822546d1ac
>> Author: Mark Thomas <ma...@apache.org>
>> AuthorDate: Wed Jun 3 11:36:21 2026 +0100
>>
>> Improve readability
>
> Ok but actually this does not work. I tried it before obviously since
> the LLM complained. parse() is called on the next line, that's the
> reason (it will check initialized).
I've reverted this for now (see else-thread). But I think I have an idea
for a minor refactoring could address the initialized set too early concern.
Mark
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org
Re: (tomcat) branch main updated: Improve readability
Posted by Rémy Maucherat <re...@apache.org>.
On Wed, Jun 3, 2026 at 12:36 PM <ma...@apache.org> wrote:
>
> This is an automated email from the ASF dual-hosted git repository.
>
> markt-asf pushed a commit to branch main
> in repository https://gitbox.apache.org/repos/asf/tomcat.git
>
>
> The following commit(s) were added to refs/heads/main by this push:
> new 2465d4468f Improve readability
> 2465d4468f is described below
>
> commit 2465d4468fd0a6b15a8051a7004d1f822546d1ac
> Author: Mark Thomas <ma...@apache.org>
> AuthorDate: Wed Jun 3 11:36:21 2026 +0100
>
> Improve readability
Ok but actually this does not work. I tried it before obviously since
the LLM complained. parse() is called on the next line, that's the
reason (it will check initialized).
Rémy
> ---
> .../util/net/openssl/ciphers/OpenSSLCipherConfigurationParser.java | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/java/org/apache/tomcat/util/net/openssl/ciphers/OpenSSLCipherConfigurationParser.java b/java/org/apache/tomcat/util/net/openssl/ciphers/OpenSSLCipherConfigurationParser.java
> index b39ff4599a..adc72ec4bf 100644
> --- a/java/org/apache/tomcat/util/net/openssl/ciphers/OpenSSLCipherConfigurationParser.java
> +++ b/java/org/apache/tomcat/util/net/openssl/ciphers/OpenSSLCipherConfigurationParser.java
> @@ -493,7 +493,6 @@ public class OpenSSLCipherConfigurationParser {
> addListAlias(aSRP, filterByAuthentication(allCiphers, Collections.singleton(Authentication.SRP)));
> addListAlias(kSRP, filterByKeyExchange(allCiphers, Collections.singleton(KeyExchange.SRP)));
> addListAlias(SRP, filterByKeyExchange(allCiphers, Collections.singleton(KeyExchange.SRP)));
> - initialized = true;
> addListAlias(DEFAULT, parse("ALL:!eNULL:!aNULL:!DES:!RC2:!RC4:!DSS:!SEED:!IDEA:!CAMELLIA:!AESCCM:!3DES:!ARIA"));
> // COMPLEMENTOFDEFAULT is also not exactly as defined by the docs
> LinkedHashSet<Cipher> complementOfDefault =
> @@ -512,6 +511,8 @@ public class OpenSSLCipherConfigurationParser {
> complementOfDefault.addAll(aliases.get(ARIA));
> defaultSort(complementOfDefault);
> addListAlias(COMPLEMENTOFDEFAULT, complementOfDefault);
> +
> + initialized = true;
> }
>
> static void addListAlias(String alias, Set<Cipher> ciphers) {
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org
>
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org