You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Slawomir Jaranowski (Jira)" <ji...@apache.org> on 2022/02/28 20:23:00 UTC

[jira] [Created] (MSHARED-1041) Refactor: remove duplicate code, use addArg internally

Slawomir Jaranowski created MSHARED-1041:
--------------------------------------------

             Summary: Refactor: remove duplicate code, use addArg internally
                 Key: MSHARED-1041
                 URL: https://issues.apache.org/jira/browse/MSHARED-1041
             Project: Maven Shared Components
          Issue Type: Task
          Components: maven-invoker
            Reporter: Slawomir Jaranowski


We can replace methods like:

{code}
public InvocationRequest setDebug( boolean debug )
{
      this.debug = debug;
      return this;
}
{code}

by

{code}
public InvocationRequest setDebug( boolean debug )
{
      addArg( "-X" );
      return this;
} 
{code}

and simplify {{MavenCommandLineBuilder}}



--
This message was sent by Atlassian Jira
(v8.20.1#820001)