You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@clerezza.apache.org by "Hasan Hasan (Jira)" <ji...@apache.org> on 2022/02/08 18:15:00 UTC
[jira] [Closed] (CLEREZZA-164) blank node labels not indicating identity in resultset
[ https://issues.apache.org/jira/browse/CLEREZZA-164?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Hasan Hasan closed CLEREZZA-164.
--------------------------------
Resolution: Won't Fix
> blank node labels not indicating identity in resultset
> ------------------------------------------------------
>
> Key: CLEREZZA-164
> URL: https://issues.apache.org/jira/browse/CLEREZZA-164
> Project: Clerezza
> Issue Type: Bug
> Environment: org.apache.clerezza/org.apache.clerezza.rdf.core/0.12-incubating-SNAPSHOT
> org.apache.clerezza/org.apache.clerezza.rdf.jena.sparql/0.5-incubating-SNAPSHOT
> org.apache.clerezza.ext/com.hp.hpl.jena.tdb/0.3-incubating-SNAPSHOT
> Reporter: Reto Gmür
> Priority: Major
>
> see: http://www.w3.org/TR/rdf-sparql-query/#BlankNodesInResults for how this should be.
> problem scenario
> graph contains the following
> <rdf:RDF
> xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
> xmlns:j.0="http://clerezza.org/2010/01/wwf#"
> xmlns:j.1="http://discobits.org/ontology#" >
> <rdf:Description rdf:about="http://cmsdemo.trialox.org/about_us-content-undernav/8000">
> <j.1:contains rdf:nodeID="A1"/>
> </rdf:Description>
> <rdf:Description rdf:nodeID="A1">
> <j.1:pos>0</j.1:pos>
> <j.1:holds rdf:resource="http://cmsdemo.trialox.org/about_us-content-undernav/8000-content"/>
> <rdf:type rdf:resource="http://discobits.org/ontology#Entry"/>
> </rdf:Description>
> </rdf:RDF>
> the query
> PREFIX dbt: <http://discobits.org/ontology#> SELECT ?entry ?p ?o WHERE {?entry ?p ?o . <http://cmsdemo.trialox.org/about_us-content-undernav/8000> dbt:contains ?entry . }
> yields to:
> <sparql xmlns="http://www.w3.org/2005/sparql-results#">
> <head><variable name="entry"/><variable name="p"/><variable name="o"/></head>
> <results>
> <result>
> <binding name="p"><uri>http://www.w3.org/1999/02/22-rdf-syntax-ns#type</uri></binding>
> <binding name="entry"><bnode>org.apache.clerezza.rdf.core.BNode@5ef59d</bnode></binding>
> <binding name="o"><uri>http://discobits.org/ontology#Entry</uri></binding>
> </result>
> <result>
> <binding name="p"><uri>http://discobits.org/ontology#holds</uri></binding>
> <binding name="entry"><bnode>org.apache.clerezza.rdf.core.BNode@4f1ab6</bnode></binding>
> <binding name="o"><uri>http://cmsdemo.trialox.org/about_us-content-undernav/8000-content</uri></binding>
> </result>
> <result>
> <binding name="p"><uri>http://discobits.org/ontology#pos</uri></binding>
> <binding name="entry"><bnode>org.apache.clerezza.rdf.core.BNode@162ac1e</bnode></binding>
> <binding name="o"><literal>0</literal></binding>
> </result>
> </results>
> </sparql>
> So we have 3 different bnode ids and not one as it should be as there is only one bnode and "Blank node labels are scoped to a result set".
--
This message was sent by Atlassian Jira
(v8.20.1#820001)