You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Dinesh Joshi (JIRA)" <ji...@apache.org> on 2018/06/11 04:00:00 UTC

[jira] [Commented] (CASSANDRA-14485) Optimize internode messaging protocol

    [ https://issues.apache.org/jira/browse/CASSANDRA-14485?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16507640#comment-16507640 ] 

Dinesh Joshi commented on CASSANDRA-14485:
------------------------------------------

Hi [~jasobrown], on the whole the changes look good. I have a few minor things -
 # {{MessageInHandler::decode}} - This method has a lot going on. It would be nice if you could separate the method into decodePre40 and decode40. Ideally, we should have a separate decoder class for pre 4.0 and 4.0 that gets instantiated in the handler depending on the passed version. Perhaps consider refactoring this.
 # {{MessageInHandler}} - Could you replace magic numbers (eg. 4) with named constants?
 # {{VIntCoding::readUnsignedVInt}} - Could you please add a unit test for this?

Nits -
 # {{MessageOutBench}} - Remove unused imports (java.security.NoSuchAlgorithmException; org.openjdk.jmh.infra.Blackhole)

> Optimize internode messaging protocol
> -------------------------------------
>
>                 Key: CASSANDRA-14485
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-14485
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Streaming and Messaging
>            Reporter: Jason Brown
>            Assignee: Jason Brown
>            Priority: Major
>             Fix For: 4.0.x
>
>
> There's some dead wood and places for optimization in the internode messaging protocol. Currently, we include the sender's \{{IPAddressAndPort}} in *every* internode message, even though we already sent that in the handshake that established the connection/session. Further, there are several places where we can use vints instead of a fixed, 4-byte integer value- especially as those values will almost always be less than one byte.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org