You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@mynewt.apache.org by "Sterling Hughes (JIRA)" <ji...@apache.org> on 2016/08/23 21:45:21 UTC
[jira] [Updated] (MYNEWT-79) Remove common code from HAL cputime in
MCU directories and make common
[ https://issues.apache.org/jira/browse/MYNEWT-79?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Sterling Hughes updated MYNEWT-79:
----------------------------------
Fix Version/s: (was: v0_10_0)
v1_0_0_beta1
> Remove common code from HAL cputime in MCU directories and make common
> ----------------------------------------------------------------------
>
> Key: MYNEWT-79
> URL: https://issues.apache.org/jira/browse/MYNEWT-79
> Project: Mynewt
> Issue Type: Improvement
> Components: HAL
> Reporter: William San Filippo
> Assignee: William San Filippo
> Priority: Minor
> Fix For: v1_0_0_beta1
>
>
> The current HAL cputime implementation has quite a fair amount of code duplication as a decent percentage of the code is common across MCU platforms. Would be a good idea to move the common code out of the MCU specific directories and place in a common directory.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)