You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by ab...@apache.org on 2026/06/05 18:09:49 UTC

(httpcomponents-website) 01/02: Updated website for HttpCore 5.5-beta1 release

This is an automated email from the ASF dual-hosted git repository.

arturobernalg pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-website.git

commit 9c98b6acb2c06ecbeeebbd8353145855b5beca11
Author: Arturo Bernal <ab...@apache.org>
AuthorDate: Fri Jun 5 20:08:53 2026 +0200

    Updated website for HttpCore 5.5-beta1 release
---
 src/site/markdown/news.md | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)

diff --git a/src/site/markdown/news.md b/src/site/markdown/news.md
index caf80a7..f6070b5 100644
--- a/src/site/markdown/news.md
+++ b/src/site/markdown/news.md
@@ -1,7 +1,7 @@
 <!--
     Licensed to the Apache Software Foundation (ASF) under one
     or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
+    distributed with t  zhis work for additional information
     regarding copyright ownership.  The ASF licenses this file
     to you under the Apache License, Version 2.0 (the
     "License"); you may not use this file except in compliance
@@ -20,6 +20,28 @@
 HttpComponents Project News
 ===========================
 
+###### 5 June 2026 - HttpComponents Core 5.5-beta1 released
+
+This is the first BETA release in the 5.5 release series that improves performance and
+robustness of connection pool implementations, further improves HTTP/2 specification
+conformance and introduces JSON message content bindings based on
+[Jackson](https://github.com/fasterxml/jackson) version 2.
+
+Notable changes and features included in the 5.5 series:
+
+* Connection pool implementation improvements.
+
+* HTTP message stream APIs and support for HTTP/2 message stream timeout.
+
+* SSLContexts to respect system properties by default.
+
+* Cap pending HTTP/2 request commands per connection.
+
+* HPACK RFC 7540 / RFC 7541 / HTTP/2 RFC 9113 conformance improvements.
+
+* JSON message content bindings
+
+
 ###### 20 April 2026 - HttpComponents Client 5.6.1 GA released
 
 This is a maintenance release that disables the experimental SCRAM auth scheme by