You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Hyukjin Kwon (Jira)" <ji...@apache.org> on 2020/07/28 03:23:00 UTC

[jira] [Commented] (SPARK-32423) class 'DataFrame' returns instance of type(self) instead of DataFrame

    [ https://issues.apache.org/jira/browse/SPARK-32423?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17166114#comment-17166114 ] 

Hyukjin Kwon commented on SPARK-32423:
--------------------------------------

Can you show some pseudo codes? It's a bit difficult to follow what the JIRA targets.

> class 'DataFrame' returns instance of type(self) instead of DataFrame 
> ----------------------------------------------------------------------
>
>                 Key: SPARK-32423
>                 URL: https://issues.apache.org/jira/browse/SPARK-32423
>             Project: Spark
>          Issue Type: Wish
>          Components: PySpark
>    Affects Versions: 2.4.6, 3.0.0
>            Reporter: Timothy
>            Priority: Minor
>
> To allow for appropriate child classing of DataFrame, I propose the following change:
> class 'DataFrame' returns instance of type(self) instead of  typeDataFrame 
>  
> Therefore child classes using methods such as '.limit()' will return an instance of the child class.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org