You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@james.apache.org by bt...@apache.org on 2023/11/07 13:51:16 UTC

(james-project) 03/03: JAMES-3954 Document RFC-9394 PARTIAL implementation

This is an automated email from the ASF dual-hosted git repository.

btellier pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/james-project.git

commit 1021e8118018386dadeb1b4ffdd2983bcf48ad52
Author: Benoit TELLIER <bt...@linagora.com>
AuthorDate: Wed Nov 1 20:40:11 2023 +0100

    JAMES-3954 Document RFC-9394 PARTIAL implementation
---
 .../docs/modules/ROOT/pages/architecture/implemented-standards.adoc      | 1 +
 src/site/xdoc/protocols/imap4.xml                                        | 1 +
 2 files changed, 2 insertions(+)

diff --git a/server/apps/distributed-app/docs/modules/ROOT/pages/architecture/implemented-standards.adoc b/server/apps/distributed-app/docs/modules/ROOT/pages/architecture/implemented-standards.adoc
index 1680592a1f..566e40a9b3 100644
--- a/server/apps/distributed-app/docs/modules/ROOT/pages/architecture/implemented-standards.adoc
+++ b/server/apps/distributed-app/docs/modules/ROOT/pages/architecture/implemented-standards.adoc
@@ -74,6 +74,7 @@ The following IMAP specifications are implemented:
  - link:https://www.rfc-editor.org/rfc/rfc8440.html[RFC-8440] IMAP4 Extension for Returning MYRIGHTS Information in Extended LIST
  - link:https://www.rfc-editor.org/rfc/rfc8440.html[RFC-6154] IMAP LIST Extension for Special-Use Mailboxes
  - link:https://www.rfc-editor.org/rfc/rfc8514.html[RFC-8514] IMAP SAVEDATE Extension
+ - link:https://www.rfc-editor.org/rfc/rfc8514.html[RFC-9394] IMAP PARTIAL Extension for Paged SEARCH and FETCH
 
 Partially implemented specifications:
 
diff --git a/src/site/xdoc/protocols/imap4.xml b/src/site/xdoc/protocols/imap4.xml
index d3b00c7e61..c61ffd1206 100644
--- a/src/site/xdoc/protocols/imap4.xml
+++ b/src/site/xdoc/protocols/imap4.xml
@@ -69,6 +69,7 @@
        <li>IMAP4 Extension for Returning MYRIGHTS Information in Extended LIST (https://www.rfc-editor.org/rfc/rfc8440.html)</li>
        <li>IMAP LIST Extension for Special-Use Mailboxes (https://www.rfc-editor.org/rfc/rfc6154.html)</li>
        <li>SAVEDATE Extension (https://www.rfc-editor.org/rfc/rfc8514.html)</li>
+       <li>IMAP PARTIAL Extension for Paged SEARCH and FETCH (https://www.rfc-editor.org/rfc/rfc9394.html)</li>
      </ul>
      <p>We follow RFC2683 recommendations for our implementations:</p>
      <ul>


---------------------------------------------------------------------
To unsubscribe, e-mail: notifications-unsubscribe@james.apache.org
For additional commands, e-mail: notifications-help@james.apache.org