You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-dev@hadoop.apache.org by "Rakesh R (JIRA)" <ji...@apache.org> on 2016/02/25 07:00:22 UTC

[jira] [Created] (HDFS-9857) Erasure Coding: Rename replication-based names in BlockManager to more generic

Rakesh R created HDFS-9857:
------------------------------

             Summary: Erasure Coding: Rename replication-based names in BlockManager to more generic
                 Key: HDFS-9857
                 URL: https://issues.apache.org/jira/browse/HDFS-9857
             Project: Hadoop HDFS
          Issue Type: Sub-task
            Reporter: Rakesh R
            Assignee: Rakesh R


The idea of this jira is to rename the following entities in BlockManager as,
- {{UnderReplicatedBlocks}} to {{LowRedundancyBlocks}}
- {{PendingReplicationBlocks}} to {{PendingReconstructionBlocks}}
- {{neededReplications}} to {{neededReconstruction}}
- {{excessReplicateMap}} to {{extraRedundancyMap}}

Thanks [~zhz], [~andrew.wang] for the useful [discussions|https://issues.apache.org/jira/browse/HDFS-7955?focusedCommentId=15149406&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15149406]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)