You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@lucene.apache.org by "David Smiley (Jira)" <ji...@apache.org> on 2020/03/26 04:27:00 UTC

[jira] [Created] (SOLR-14364) LTR SolrFeature fq improvements, like PostFilters

David Smiley created SOLR-14364:
-----------------------------------

             Summary: LTR SolrFeature fq improvements, like PostFilters
                 Key: SOLR-14364
                 URL: https://issues.apache.org/jira/browse/SOLR-14364
             Project: Solr
          Issue Type: Improvement
      Security Level: Public (Default Security Level. Issues are Public)
          Components: contrib - LTR
            Reporter: David Smiley
            Assignee: David Smiley


While working on another issue, I came upon LTR's SolrFeature class which calls SolrIndexSearcher.getProcessedFilter – a rather low-level method that that nobody should call directly if they can help it.  Furthermore, the way SolrFeature was processing the filter queries didn't support PostFilters, which would have been silently ignored (ouch!).  After looking around this SolrFeature class I found multiple things to improve to reduce complexity, perhaps performance in some cases, and IMO improve readability.  In my PR it has about 80 fewer lines of code now.  Additionally I found it useful to add a new utility method combineQueryAndFilter that is useful in quite a few places across Solr (and my PR does so).

I have some complaints with other things I see but want to stop here, with my primary objective of reducing a needless caller on getProcessedFilter.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@lucene.apache.org
For additional commands, e-mail: issues-help@lucene.apache.org