You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@cordova.apache.org by GitBox <gi...@apache.org> on 2022/11/16 15:24:24 UTC
[GitHub] [cordova-cli] breautek commented on issue #585: Updation of transitive dependency got@9.6.0 to version greater than 12.1.0
breautek commented on issue #585:
URL: https://github.com/apache/cordova-cli/issues/585#issuecomment-1317194619
Had a quick glance at this and this will require some work.
Our direct dependency that `got` comes from is `update-notifier` and we need to update to `6.0.2` which is a [breaking change](https://gist.github.com/sindresorhus/a39789f98801d908bbc7ff3ecc99d99c).
Version 6 is pure esm, which means you cannot directly require it via NodeJS `require`. It requires the use of ESM modules via `import` syntax.
This means to continue using `update-notifer` we need to convert Cordova to be ESM.
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@cordova.apache.org
For additional commands, e-mail: issues-help@cordova.apache.org