You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Wei-Chiu Chuang (Jira)" <ji...@apache.org> on 2026/04/14 00:28:00 UTC

[jira] [Commented] (HDDS-13503) Refactor S3MultipartUploadCommitPartRequest.validateAndUpdateCache for readability and maintainability

    [ https://issues.apache.org/jira/browse/HDDS-13503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=18073317#comment-18073317 ] 

Wei-Chiu Chuang commented on HDDS-13503:
----------------------------------------

please move it under HDDS-10611

> Refactor S3MultipartUploadCommitPartRequest.validateAndUpdateCache for readability and maintainability
> ------------------------------------------------------------------------------------------------------
>
>                 Key: HDDS-13503
>                 URL: https://issues.apache.org/jira/browse/HDDS-13503
>             Project: Apache Ozone
>          Issue Type: Improvement
>            Reporter: Mahesh kumar gaddam
>            Priority: Major
>
> Refactor {{S3MultipartUploadCommitPartRequest.validateAndUpdateCache}} for readability and maintainability
> *Description:*
> The {{validateAndUpdateCache}} method in {{S3MultipartUploadCommitPartRequest}} has grown complex due to recent enhancements for handling uncommitted blocks and overwritten parts. The logic for building the {{keyToDeleteMap}} and managing pseudo-keys can be extracted into helper methods for better readability, modularity, and testability.
> *Proposed Improvements:*
>  * *Extract Helper Methods:*
>  ** Introduce a {{buildKeyDeletionMap}} method to handle the creation of {{RepeatedOmKeyInfo}} for old keys and uncommitted pseudo-keys.
>  ** Move pseudo-key creation logic to a dedicated utility method.
>  * *Improve Logging:*
>  ** Add {{LOG.debug}} statements when pseudo-keys or overwritten keys are added to {{DeletedTable}} for easier troubleshooting.
>  * *Update Javadocs:*
>  ** Update outdated references (e.g., {{{}oldPartKeyInfo{}}}) in method documentation.
>  * *Enhance Unit Tests:*
>  ** Create focused unit tests for helper methods to ensure they work independently.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org