You are viewing a plain text version of this content. The canonical link for it is here.
Posted to users@spamassassin.apache.org by Carlo Filippetto <ca...@gmail.com> on 2015/01/20 18:06:11 UTC

Problem installing Spammassassin 3.4.0

hi all,
I have a CentOS release 5.5 (Final)

I have
SpamAssassin version 3.3.1
  running on Perl version 5.8.8

I would like to upgrade it to 3.4.0 so I upgrade cpan module and install
all the module on INSTALL document in the default root of the packages.

When I tried to install it with
perl Makefile.PL PREFIX=/opt/MailSpamassassin-3.4.0
CONFDIR=/etc/mail/spamassassin

I have this error:

--------
dependency check complete...

optional module out of date: IO::Socket::IP
optional binary missing or nonfunctional: fetch

warning: some functionality may not be available,
please read the above report before continuing!
----------

After some search on google I tried to install with cpan several module,
tried to install e remove spamassassin

but nothing

I tried to "forse install IO::Socket::IP" and now I have:
cpan> install
IO::Socket::IP

CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
  Database was generated on Tue, 20 Jan 2015 02:29:02 GMT
IO::Socket::IP is up to date.


If I made a test I have:
Warning: prerequisite Socket 1.97 not found. We have 1.78.
---- Unsatisfied dependencies detected during
[P/PE/PEVANS/IO-Socket-IP-0.36.tar.gz] -----

#   Failed test 'use IO::Socket::IP;'
#   at t/00use.t line 8.
#     Tried to use 'IO::Socket::IP'.
#     Error:  Socket version 1.97 required--this is only version 1.78 at
/root/.cpan/build/IO-Socket-IP-0.36/blib/lib/IO/Socket/IP.pm line 30.
# BEGIN failed--compilation aborted at
/root/.cpan/build/IO-Socket-IP-0.36/blib/lib/IO/Socket/IP.pm line 30.
# Compilation failed in require at t/00use.t line 8.
# BEGIN failed--compilation aborted at t/00use.t line 8.
# Looks like you failed 1 test of 1.


What I have to do?


thank you

Re: Problem installing Spammassassin 3.4.0

Posted by Carlo Filippetto <ca...@gmail.com>.
sorry!!
the compilation and installation were succesfully!

thank you



2015-01-21 12:24 GMT+01:00 Carlo Filippetto <ca...@gmail.com>:

> Thank you,
> but how can I remove 'the new IO::Socket::IP' from cpan?
>
> other questions:
> - I have to try to update my perl version?
> - you say that them are only warnings and I don't need to use IPv6, how
> can I go on installing spamassissin skipping those warnings?
>
> thank you
>
>
>
>
>
>
>
>
>
>
>
> 2015-01-20 18:23 GMT+01:00 Mark Martinec <Ma...@ijs.si>:
>
>> Carlo Filippetto wrote:
>>
>>> I have a CentOS release 5.5 (Final)
>>> SpamAssassin version 3.3.1
>>>   running on Perl version 5.8.8
>>>
>>> I would like to upgrade it to 3.4.0 so I upgrade cpan module and install
>>> all the module on INSTALL document in the default root of the packages.
>>>
>>> When I tried to install it with
>>> perl Makefile.PL PREFIX=/opt/MailSpamassassin-3.4.0
>>> CONFDIR=/etc/mail/spamassassin
>>>
>>> I have this error:
>>>
>>> optional module out of date: IO::Socket::IP
>>> optional binary missing or nonfunctional: fetch
>>>
>>> warning: some functionality may not be available,
>>> please read the above report before continuing!
>>>
>>
>> Just warnings. If you don't require a functional IPv6,
>> then you don't really need the IO::Socket::IP .
>>
>>
>>  After some search on google I tried to install with cpan several module,
>>> tried to install e remove spamassassin
>>>
>>> but nothing
>>>
>>> I tried to "forse install IO::Socket::IP" and now I have:
>>> cpan> install
>>> IO::Socket::IP
>>>
>>> CPAN: Storable loaded ok
>>> Going to read /root/.cpan/Metadata
>>>   Database was generated on Tue, 20 Jan 2015 02:29:02 GMT
>>> IO::Socket::IP is up to date.
>>>
>>> If I made a test I have:
>>> Warning: prerequisite Socket 1.97 not found. We have 1.78.
>>>
>>
>> Your perl is very old. Instead of investing potentially great effort
>> to bring the Socket module up to date too, it's probably easier
>> just to deinstall the new IO::Socket::IP .
>>
>>   Mark
>>
>
>

Re: Problem installing Spammassassin 3.4.0

Posted by Carlo Filippetto <ca...@gmail.com>.
Thank you,
but how can I remove 'the new IO::Socket::IP' from cpan?

other questions:
- I have to try to update my perl version?
- you say that them are only warnings and I don't need to use IPv6, how can
I go on installing spamassissin skipping those warnings?

thank you











2015-01-20 18:23 GMT+01:00 Mark Martinec <Ma...@ijs.si>:

> Carlo Filippetto wrote:
>
>> I have a CentOS release 5.5 (Final)
>> SpamAssassin version 3.3.1
>>   running on Perl version 5.8.8
>>
>> I would like to upgrade it to 3.4.0 so I upgrade cpan module and install
>> all the module on INSTALL document in the default root of the packages.
>>
>> When I tried to install it with
>> perl Makefile.PL PREFIX=/opt/MailSpamassassin-3.4.0
>> CONFDIR=/etc/mail/spamassassin
>>
>> I have this error:
>>
>> optional module out of date: IO::Socket::IP
>> optional binary missing or nonfunctional: fetch
>>
>> warning: some functionality may not be available,
>> please read the above report before continuing!
>>
>
> Just warnings. If you don't require a functional IPv6,
> then you don't really need the IO::Socket::IP .
>
>
>  After some search on google I tried to install with cpan several module,
>> tried to install e remove spamassassin
>>
>> but nothing
>>
>> I tried to "forse install IO::Socket::IP" and now I have:
>> cpan> install
>> IO::Socket::IP
>>
>> CPAN: Storable loaded ok
>> Going to read /root/.cpan/Metadata
>>   Database was generated on Tue, 20 Jan 2015 02:29:02 GMT
>> IO::Socket::IP is up to date.
>>
>> If I made a test I have:
>> Warning: prerequisite Socket 1.97 not found. We have 1.78.
>>
>
> Your perl is very old. Instead of investing potentially great effort
> to bring the Socket module up to date too, it's probably easier
> just to deinstall the new IO::Socket::IP .
>
>   Mark
>

Re: Problem installing Spammassassin 3.4.0

Posted by Mark Martinec <Ma...@ijs.si>.
Carlo Filippetto wrote:
> I have a CentOS release 5.5 (Final)
> SpamAssassin version 3.3.1
>   running on Perl version 5.8.8
> 
> I would like to upgrade it to 3.4.0 so I upgrade cpan module and 
> install
> all the module on INSTALL document in the default root of the packages.
> 
> When I tried to install it with
> perl Makefile.PL PREFIX=/opt/MailSpamassassin-3.4.0
> CONFDIR=/etc/mail/spamassassin
> 
> I have this error:
> 
> optional module out of date: IO::Socket::IP
> optional binary missing or nonfunctional: fetch
> 
> warning: some functionality may not be available,
> please read the above report before continuing!

Just warnings. If you don't require a functional IPv6,
then you don't really need the IO::Socket::IP .


> After some search on google I tried to install with cpan several 
> module,
> tried to install e remove spamassassin
> 
> but nothing
> 
> I tried to "forse install IO::Socket::IP" and now I have:
> cpan> install
> IO::Socket::IP
> 
> CPAN: Storable loaded ok
> Going to read /root/.cpan/Metadata
>   Database was generated on Tue, 20 Jan 2015 02:29:02 GMT
> IO::Socket::IP is up to date.
> 
> If I made a test I have:
> Warning: prerequisite Socket 1.97 not found. We have 1.78.

Your perl is very old. Instead of investing potentially great effort
to bring the Socket module up to date too, it's probably easier
just to deinstall the new IO::Socket::IP .

   Mark