You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@allura.apache.org by Dillon Walls <di...@slashdotmedia.com.INVALID> on 2024/06/27 19:56:29 UTC

[allura:tickets] #8565 Prepare for Upgrade to Pymongo 4



---

**[tickets:#8565] Prepare for Upgrade to Pymongo 4**

**Status:** open
**Milestone:** unreleased
**Created:** Thu Jun 27, 2024 07:56 PM UTC by Dillon Walls
**Last Updated:** Thu Jun 27, 2024 07:56 PM UTC
**Owner:** Dillon Walls





---

Sent from forge-allura.apache.org because dev@allura.apache.org is subscribed to https://forge-allura.apache.org/p/allura/tickets/

To unsubscribe from further messages, a project admin can change settings at https://forge-allura.apache.org/p/allura/admin/tickets/options.  Or, if this is a mailing list, you can unsubscribe from the mailing list.

[allura:tickets] #8565 Prepare for Upgrade to Pymongo 4

Posted by Dave Brondsema <da...@brondsema.net>.
When we get everything updated, we can remove the ming & pymongo lines in pytest.ini that make it `ignore` deprecation warnings.


---

**[tickets:#8565] Prepare for Upgrade to Pymongo 4**

**Status:** open
**Milestone:** unreleased
**Created:** Thu Jun 27, 2024 07:56 PM UTC by Dillon Walls
**Last Updated:** Mon Jul 01, 2024 09:21 PM UTC
**Owner:** Dillon Walls


There are quite a few methods that were removed or changed in the jump from pymongo3 to pymongo4. Many of these have been back-ported to pymongo3. 

In coordination with Ming, we should incrementally work towards pymongo4. A good way to accomplish this is to keep pymongo3 but migrate to the new api in as many places as possible.


---

Sent from forge-allura.apache.org because dev@allura.apache.org is subscribed to https://forge-allura.apache.org/p/allura/tickets/

To unsubscribe from further messages, a project admin can change settings at https://forge-allura.apache.org/p/allura/admin/tickets/options.  Or, if this is a mailing list, you can unsubscribe from the mailing list.

[allura:tickets] #8565 Prepare for Upgrade to Pymongo 4

Posted by Dillon Walls <di...@slashdotmedia.com.INVALID>.
I have completed this prep on branch `dw/8565`

However, these updates were made in concert with pre-release Ming changes. We shouldn't merge this branch until a new version of Ming has been published that includes its own API migration prep.


---

**[tickets:#8565] Prepare for Upgrade to Pymongo 4**

**Status:** open
**Milestone:** unreleased
**Created:** Thu Jun 27, 2024 07:56 PM UTC by Dillon Walls
**Last Updated:** Thu Jun 27, 2024 07:58 PM UTC
**Owner:** Dillon Walls


There are quite a few methods that were removed or changed in the jump from pymongo3 to pymongo4. Many of these have been back-ported to pymongo3. 

In coordination with Ming, we should incrementally work towards pymongo4. A good way to accomplish this is to keep pymongo3 but migrate to the new api in as many places as possible.


---

Sent from forge-allura.apache.org because dev@allura.apache.org is subscribed to https://forge-allura.apache.org/p/allura/tickets/

To unsubscribe from further messages, a project admin can change settings at https://forge-allura.apache.org/p/allura/admin/tickets/options.  Or, if this is a mailing list, you can unsubscribe from the mailing list.

[allura:tickets] #8565 Prepare for Upgrade to Pymongo 4

Posted by Dave Brondsema <da...@brondsema.net>.
- **status**: open --> closed



---

**[tickets:#8565] Prepare for Upgrade to Pymongo 4**

**Status:** closed
**Milestone:** unreleased
**Created:** Thu Jun 27, 2024 07:56 PM UTC by Dillon Walls
**Last Updated:** Tue Jul 02, 2024 08:54 PM UTC
**Owner:** Dillon Walls


There are quite a few methods that were removed or changed in the jump from pymongo3 to pymongo4. Many of these have been back-ported to pymongo3. 

In coordination with Ming, we should incrementally work towards pymongo4. A good way to accomplish this is to keep pymongo3 but migrate to the new api in as many places as possible.


---

Sent from forge-allura.apache.org because dev@allura.apache.org is subscribed to https://forge-allura.apache.org/p/allura/tickets/

To unsubscribe from further messages, a project admin can change settings at https://forge-allura.apache.org/p/allura/admin/tickets/options.  Or, if this is a mailing list, you can unsubscribe from the mailing list.

[allura:tickets] #8565 Prepare for Upgrade to Pymongo 4

Posted by Dillon Walls <di...@slashdotmedia.com.INVALID>.
- Description has changed:

Diff:

~~~~

--- old
+++ new
@@ -0,0 +1,3 @@
+There are quite a few methods that were removed or changed in the jump from pymongo3 to pymongo4. Many of these have been back-ported to pymongo3. 
+
+In coordination with Ming, we should incrementally work towards pymongo4. A good way to accomplish this is to keep pymongo3 but migrate to the new api in as many places as possible.

~~~~




---

**[tickets:#8565] Prepare for Upgrade to Pymongo 4**

**Status:** open
**Milestone:** unreleased
**Created:** Thu Jun 27, 2024 07:56 PM UTC by Dillon Walls
**Last Updated:** Thu Jun 27, 2024 07:56 PM UTC
**Owner:** Dillon Walls


There are quite a few methods that were removed or changed in the jump from pymongo3 to pymongo4. Many of these have been back-ported to pymongo3. 

In coordination with Ming, we should incrementally work towards pymongo4. A good way to accomplish this is to keep pymongo3 but migrate to the new api in as many places as possible.


---

Sent from forge-allura.apache.org because dev@allura.apache.org is subscribed to https://forge-allura.apache.org/p/allura/tickets/

To unsubscribe from further messages, a project admin can change settings at https://forge-allura.apache.org/p/allura/admin/tickets/options.  Or, if this is a mailing list, you can unsubscribe from the mailing list.

[allura:tickets] #8565 Prepare for Upgrade to Pymongo 4

Posted by Dave Brondsema <da...@brondsema.net>.
- `Allura/allura/lib/custom_middleware.py` remove the `'group'` method wrapping
- instead of `.estimated_document_count()` what do you think about `.count({})`?  It seems like estimated_document_count should be reliable in nearly all cases, but I don't like the name, it makes it _seem_ unreliable.   And its long.
- `find_and_modify` had `new=True`, but `find_one_and_update` doesn’t have that kwarg, it has a `upsert` kwarg instead.


Looking pretty good, just reviewing the code.  Haven't actually tried running it


---

**[tickets:#8565] Prepare for Upgrade to Pymongo 4**

**Status:** open
**Milestone:** unreleased
**Created:** Thu Jun 27, 2024 07:56 PM UTC by Dillon Walls
**Last Updated:** Thu Jun 27, 2024 08:07 PM UTC
**Owner:** Dillon Walls


There are quite a few methods that were removed or changed in the jump from pymongo3 to pymongo4. Many of these have been back-ported to pymongo3. 

In coordination with Ming, we should incrementally work towards pymongo4. A good way to accomplish this is to keep pymongo3 but migrate to the new api in as many places as possible.


---

Sent from forge-allura.apache.org because dev@allura.apache.org is subscribed to https://forge-allura.apache.org/p/allura/tickets/

To unsubscribe from further messages, a project admin can change settings at https://forge-allura.apache.org/p/allura/admin/tickets/options.  Or, if this is a mailing list, you can unsubscribe from the mailing list.