You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@cloudstack.apache.org by Darren Shepherd <da...@gmail.com> on 2013/09/27 19:22:42 UTC

Network.{Provider,Service,Capability} string names don't match constant names

For Network.{Provider,Service,Capability} the getName() does not
always match the constant names.  For example
Capability.SupportedVpnProtocols, the getName() is
"SupportedVpnTypes".  For Capability.SupportedLBAlgorithms the
getName() is "SupportedLbAlgorithms".

Can we just clean up all those constants, meaning make the string
match what the constant name is?  Is that going to have some impact?
I can submit a patch that has a unit test to ensure the static's
getName always matches the static name.

Darren

Re: Network.{Provider,Service,Capability} string names don't match constant names

Posted by Darren Shepherd <da...@gmail.com>.
I created https://reviews.apache.org/r/14360/ for this.  I found that
changing the provider names would be rather impactful, but changing
the Capability and Service didn't seem to matter.  I can't find any
reference to the string constant names anywhere.  The unit test I
added will ensure that future additions to Capability, Service, and
Provider match the constant names.

Darren

On Fri, Sep 27, 2013 at 10:22 AM, Darren Shepherd
<da...@gmail.com> wrote:
> For Network.{Provider,Service,Capability} the getName() does not
> always match the constant names.  For example
> Capability.SupportedVpnProtocols, the getName() is
> "SupportedVpnTypes".  For Capability.SupportedLBAlgorithms the
> getName() is "SupportedLbAlgorithms".
>
> Can we just clean up all those constants, meaning make the string
> match what the constant name is?  Is that going to have some impact?
> I can submit a patch that has a unit test to ensure the static's
> getName always matches the static name.
>
> Darren