You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@pivot.apache.org by "Sandro Martini (JIRA)" <ji...@apache.org> on 2013/10/01 15:50:23 UTC

[jira] [Commented] (PIVOT-922) Some renderers were not calling their "toString" methods in the "render" methods

    [ https://issues.apache.org/jira/browse/PIVOT-922?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13782944#comment-13782944 ] 

Sandro Martini commented on PIVOT-922:
--------------------------------------

Hi Roger, this issue should be resolved (and merged in trunk), right ?


> Some renderers were not calling their "toString" methods in the "render" methods
> --------------------------------------------------------------------------------
>
>                 Key: PIVOT-922
>                 URL: https://issues.apache.org/jira/browse/PIVOT-922
>             Project: Pivot
>          Issue Type: Bug
>          Components: wtk
>    Affects Versions: 2.0.3
>         Environment: All
>            Reporter: Roger Whitcomb
>            Assignee: Roger Whitcomb
>            Priority: Minor
>              Labels: renderer, wtk
>             Fix For: 2.0.4, 2.1
>
>
> Most Renderer instances have the required "render" method and also a "toString" method.  Since "render" can be complicated it is tempting to create a subclass and just change the "toString" method to do something special with the text (like using something besides "Object.toString()" to get the proper text).  But, many of the renderers don't call the "toString(Object)" method from "render", but instead duplicate the logic in there.  This renders the subclass approach ineffective.  And there is no particular reason for having the "toString" method except for it to be used in "render".



--
This message was sent by Atlassian JIRA
(v6.1#6144)