You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Lin Zeng (JIRA)" <ji...@apache.org> on 2017/04/21 09:50:04 UTC

[jira] [Comment Edited] (HADOOP-14261) Some refactoring work for erasure coding raw coder

    [ https://issues.apache.org/jira/browse/HADOOP-14261?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15978410#comment-15978410 ] 

Lin Zeng edited comment on HADOOP-14261 at 4/21/17 9:49 AM:
------------------------------------------------------------

# Refactor work:
#* Rename RSRawDecoderLegacy to RSLegacyRawDecoder.
#* Rename RSRawEncoderLegacy to RSLegacyRawEncoder.
#* Rename RSRawErasureCoderFactoryLegacy to RSLegacyRawErasureCoderFactory.
#* TestRSRawCoderLegacy to TestRSLegacyRawCoder.
# Create RawEncoder and RawDecoder via the appropriate factory.


was (Author: zenglinx):
# Refactor work:
#* Rename RSRawDecoderLegacy to RSLegacyRawDecoder.
#* Rename RSRawEncoderLegacy to RSLegacyRawEncoder.
#* Rename RSRawErasureCoderFactoryLegacy to RSLegacyRawErasureCoderFactory.
#* TestRSRawCoderLegacy to TestRSLegacyRawCoder.

# Create RawEncoder and RawDecoder via the appropriate factory.

> Some refactoring work for erasure coding raw coder
> --------------------------------------------------
>
>                 Key: HADOOP-14261
>                 URL: https://issues.apache.org/jira/browse/HADOOP-14261
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Kai Zheng
>            Assignee: Lin Zeng
>             Fix For: 3.0.0-alpha3
>
>         Attachments: HADOOP-14261.001.patch
>
>
> This is from [~andrew.wang] commented in HADOOP-13200:
> {quote}
> Other questions/comments from looking at this code:
> We also should rename RSRawEncoderLegacy to RSLegacyRawEncoder and RSRawErasureCoderFactoryLegacy to RSLegacyErasureCoderFactory, to match the naming of other subclasses.
> TestRawEncoderBase, should this use a configured factory to get the raw coders, rather than referencing the raw coders directly? I didn't check other usages, but it seems like we should be creating via the appropriate factory whenever possible.
> {quote}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org