You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@chemistry.apache.org by "David Caruana (JIRA)" <ji...@apache.org> on 2010/04/30 10:46:54 UTC

[jira] Created: (CMIS-200) PagingList refactor part 2

PagingList refactor part 2
--------------------------

                 Key: CMIS-200
                 URL: https://issues.apache.org/jira/browse/CMIS-200
             Project: Chemistry
          Issue Type: Bug
          Components: opencmis-client
            Reporter: David Caruana


- rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable, ...
- removes "maxItems" from the service calls
- adds maxItems to OperationContext
- adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (CMIS-200) PagingList refactor part 2

Posted by "Stephan Klevenz (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CMIS-200?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Stephan Klevenz updated CMIS-200:
---------------------------------

    Status: Patch Available  (was: Open)

    * removes "maxItems" from the service calls -> fixed
    * adds maxItems to OperationContext -> fixed
    * adds a getPage(int maxItems) -> fixed

Unit tests are provided.

Open: renaming of PagingIterator

> PagingList refactor part 2
> --------------------------
>
>                 Key: CMIS-200
>                 URL: https://issues.apache.org/jira/browse/CMIS-200
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>            Reporter: David Caruana
>            Assignee: Stephan Klevenz
>
> - rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable, ...
> - removes "maxItems" from the service calls
> - adds maxItems to OperationContext
> - adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (CMIS-200) PagingList refactor part 2

Posted by "Stephan Klevenz (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CMIS-200?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Stephan Klevenz resolved CMIS-200.
----------------------------------

    Resolution: Fixed

> PagingList refactor part 2
> --------------------------
>
>                 Key: CMIS-200
>                 URL: https://issues.apache.org/jira/browse/CMIS-200
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>            Reporter: David Caruana
>            Assignee: Stephan Klevenz
>
> - rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable, ...
> - removes "maxItems" from the service calls
> - adds maxItems to OperationContext
> - adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Assigned: (CMIS-200) PagingList refactor part 2

Posted by "Stephan Klevenz (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CMIS-200?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Stephan Klevenz reassigned CMIS-200:
------------------------------------

    Assignee: Stephan Klevenz

> PagingList refactor part 2
> --------------------------
>
>                 Key: CMIS-200
>                 URL: https://issues.apache.org/jira/browse/CMIS-200
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>            Reporter: David Caruana
>            Assignee: Stephan Klevenz
>
> - rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable, ...
> - removes "maxItems" from the service calls
> - adds maxItems to OperationContext
> - adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Reopened: (CMIS-200) PagingList refactor part 2

Posted by "Stephan Klevenz (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CMIS-200?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Stephan Klevenz reopened CMIS-200:
----------------------------------


Colapse ItemIterator and ItemIterable interface

> PagingList refactor part 2
> --------------------------
>
>                 Key: CMIS-200
>                 URL: https://issues.apache.org/jira/browse/CMIS-200
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>            Reporter: David Caruana
>            Assignee: Stephan Klevenz
>
> - rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable, ...
> - removes "maxItems" from the service calls
> - adds maxItems to OperationContext
> - adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Issue Comment Edited: (CMIS-200) PagingList refactor part 2

Posted by "Stephan Klevenz (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CMIS-200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12864315#action_12864315 ] 

Stephan Klevenz edited comment on CMIS-200 at 5/5/10 8:42 AM:
--------------------------------------------------------------

Collapse ItemIterator and ItemIterable interface to one single interface using standard Iterator interface.

      was (Author: klevenzs):
    Collapse ItemIterator and ItemIterable interface
  
> PagingList refactor part 2
> --------------------------
>
>                 Key: CMIS-200
>                 URL: https://issues.apache.org/jira/browse/CMIS-200
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>            Reporter: David Caruana
>            Assignee: Stephan Klevenz
>
> - rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable, ...
> - removes "maxItems" from the service calls
> - adds maxItems to OperationContext
> - adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Closed: (CMIS-200) PagingList refactor part 2

Posted by "Stephan Klevenz (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CMIS-200?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Stephan Klevenz closed CMIS-200.
--------------------------------


> PagingList refactor part 2
> --------------------------
>
>                 Key: CMIS-200
>                 URL: https://issues.apache.org/jira/browse/CMIS-200
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>            Reporter: David Caruana
>            Assignee: Stephan Klevenz
>
> - rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable, ...
> - removes "maxItems" from the service calls
> - adds maxItems to OperationContext
> - adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Issue Comment Edited: (CMIS-200) PagingList refactor part 2

Posted by "Stephan Klevenz (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CMIS-200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12864315#action_12864315 ] 

Stephan Klevenz edited comment on CMIS-200 at 5/5/10 8:40 AM:
--------------------------------------------------------------

Collapse ItemIterator and ItemIterable interface

      was (Author: klevenzs):
    Colapse ItemIterator and ItemIterable interface
  
> PagingList refactor part 2
> --------------------------
>
>                 Key: CMIS-200
>                 URL: https://issues.apache.org/jira/browse/CMIS-200
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>            Reporter: David Caruana
>            Assignee: Stephan Klevenz
>
> - rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable, ...
> - removes "maxItems" from the service calls
> - adds maxItems to OperationContext
> - adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (CMIS-200) PagingList refactor part 2

Posted by "Stephan Klevenz (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CMIS-200?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Stephan Klevenz updated CMIS-200:
---------------------------------

        Status: Resolved  (was: Patch Available)
    Resolution: Fixed

Renaming to ItemIterator done.

> PagingList refactor part 2
> --------------------------
>
>                 Key: CMIS-200
>                 URL: https://issues.apache.org/jira/browse/CMIS-200
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>            Reporter: David Caruana
>            Assignee: Stephan Klevenz
>
> - rename PagingIterable to the chosen name :-)  - candidates: SkipIterable, ItemIterable, ...
> - removes "maxItems" from the service calls
> - adds maxItems to OperationContext
> - adds a getPage(int maxItems)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.