You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hbase.apache.org by "Duo Zhang (Jira)" <ji...@apache.org> on 2022/04/02 05:40:00 UTC

[jira] [Created] (HBASE-26919) Rewrite the counting rows part in TestFromClientSide4

Duo Zhang created HBASE-26919:
---------------------------------

             Summary: Rewrite the counting rows part in TestFromClientSide4
                 Key: HBASE-26919
                 URL: https://issues.apache.org/jira/browse/HBASE-26919
             Project: HBase
          Issue Type: Sub-task
            Reporter: Duo Zhang


Now we add an annotation to the variable declaration in the for loop, it will lead the following result after formatting
{code}
        for (@SuppressWarnings("unused")
        Result row : scanner) {
          nbRows++;
        }
{code}

It looks really strange and checkstyle also reports indentation error.

Let's just rewrite it an avoiding using annotation in this way, I do not know what is a better format for this scenario.



--
This message was sent by Atlassian Jira
(v8.20.1#820001)