You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@tinkerpop.apache.org by GitBox <gi...@apache.org> on 2019/05/02 16:13:35 UTC

[GitHub] [tinkerpop] dkuppitz opened a new pull request #1108: TINKERPOP-2207 Provide SimpleValueMapStrategy

dkuppitz opened a new pull request #1108: TINKERPOP-2207 Provide SimpleValueMapStrategy
URL: https://github.com/apache/tinkerpop/pull/1108
 
 
   https://issues.apache.org/jira/browse/TINKERPOP-2207
   
   Implemented `SimpleValueMapStrategy`, which can be used by providers who do not support multi-valued properties.
   
   ```
   gremlin> g = TinkerFactory.createModern().traversal()
   ==>graphtraversalsource[tinkergraph[vertices:6 edges:6], standard]
   gremlin> g.V().valueMap()
   ==>[name:[marko],age:[29]]
   ==>[name:[vadas],age:[27]]
   ==>[name:[lop],lang:[java]]
   ==>[name:[josh],age:[32]]
   ==>[name:[ripple],lang:[java]]
   ==>[name:[peter],age:[35]]
   gremlin> g.withStrategies(SimpleValueMapStrategy.instance()).V().valueMap()
   ==>[name:marko,age:29]
   ==>[name:vadas,age:27]
   ==>[name:lop,lang:java]
   ==>[name:josh,age:32]
   ==>[name:ripple,lang:java]
   ==>[name:peter,age:35]
   ```
   
   VOTE +1

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services