You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Colin Patrick McCabe (JIRA)" <ji...@apache.org> on 2012/11/16 22:19:12 UTC

[jira] [Commented] (HDFS-4175) Extend existing TestSnapshot to support more complicated directory structure and more modifications on current files/direcotories

    [ https://issues.apache.org/jira/browse/HDFS-4175?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13499150#comment-13499150 ] 

Colin Patrick McCabe commented on HDFS-4175:
--------------------------------------------

Hi Jing,

This one doesn't apply for me with the latest from HDFS-2802.  Can you rebase the patch on the latest code?

* I think it makes more sense to rename {{DirCreationDeletion}} to {{DirCreationOrDeletion}}, since it's one or the other (but not both).
* In {{testSnapshottableDirectory}}, {{testDeleteDirectoryWithSnapshot}}, {{testDeleteDirectoryWithSnapshot2}}, etc., it seems like you check for {{RemoteException}} in every case.  This seems awfully generic.  Any remote exception could cause the test to succeed here.  Can you check for the exception that is wrapped in the {{RemoteException}} instead?  Or in the edit log code we sometimes do something like e.getMessage().contains(EXPECTED_STRING), to make sure that the failure we're observing is really the one we expect to get in the test, and not something else.
                
> Extend existing TestSnapshot to support more complicated directory structure and more modifications on current files/direcotories
> ---------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: HDFS-4175
>                 URL: https://issues.apache.org/jira/browse/HDFS-4175
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: data-node, name-node
>            Reporter: Jing Zhao
>            Assignee: Jing Zhao
>         Attachments: HDFS-4175-snapshot-test.002.patch, snapshot-test.001.patch
>
>
> Currently the TestSnapshot only uses a static simple directory structure for testing snapshot functionalities. We need to test snapshot under more complicated directory structures. 
> Also the current TestSnapshot only compares snapshots before/after three types of modifications: file creation, deletion, and appending. We need to test snapshots for more file modifications, including file permission change, replication factor change, owner/group change, and sub-directory creation/deletion.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira