You are viewing a plain text version of this content. The canonical link for it is here.
Posted to site-dev@james.apache.org by rd...@apache.org on 2009/09/05 11:50:18 UTC

svn commit: r811613 [37/48] - in /james/site/trunk/www/jsieve: ./ apidocs/ apidocs/org/apache/jsieve/ apidocs/org/apache/jsieve/class-use/ apidocs/org/apache/jsieve/commands/ apidocs/org/apache/jsieve/commands/class-use/ apidocs/org/apache/jsieve/comma...

Modified: james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/Not.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/Not.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/Not.html (original)
+++ james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/Not.html Sat Sep  5 09:49:32 2009
@@ -6,7 +6,7 @@
 <link type="text/css" rel="stylesheet" href="../../../../stylesheet.css" />
 </head>
 <body>
-<div id="overview"><a href="../../../../../../../../../../../workspace/jsieve/main/target/site/apidocs/org/apache/jsieve/tests/Not.html">View Javadoc</a></div><pre>
+<div id="overview"><a href="../../../../../apidocs/org/apache/jsieve/tests/Not.html">View Javadoc</a></div><pre>
 
 <a name="1" href="#1">1</a>   <em class="jxr_javadoccomment">/**</em><em class="jxr_javadoccomment">**************************************************************</em>
 <a name="2" href="#2">2</a>   <em class="jxr_javadoccomment"> * Licensed to the Apache Software Foundation (ASF) under one   *</em>

Modified: james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/Size.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/Size.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/Size.html (original)
+++ james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/Size.html Sat Sep  5 09:49:32 2009
@@ -6,7 +6,7 @@
 <link type="text/css" rel="stylesheet" href="../../../../stylesheet.css" />
 </head>
 <body>
-<div id="overview"><a href="../../../../../../../../../../../workspace/jsieve/main/target/site/apidocs/org/apache/jsieve/tests/Size.html">View Javadoc</a></div><pre>
+<div id="overview"><a href="../../../../../apidocs/org/apache/jsieve/tests/Size.html">View Javadoc</a></div><pre>
 
 <a name="1" href="#1">1</a>   <em class="jxr_javadoccomment">/**</em><em class="jxr_javadoccomment">**************************************************************</em>
 <a name="2" href="#2">2</a>   <em class="jxr_javadoccomment"> * Licensed to the Apache Software Foundation (ASF) under one   *</em>

Modified: james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/True.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/True.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/True.html (original)
+++ james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/True.html Sat Sep  5 09:49:32 2009
@@ -6,7 +6,7 @@
 <link type="text/css" rel="stylesheet" href="../../../../stylesheet.css" />
 </head>
 <body>
-<div id="overview"><a href="../../../../../../../../../../../workspace/jsieve/main/target/site/apidocs/org/apache/jsieve/tests/True.html">View Javadoc</a></div><pre>
+<div id="overview"><a href="../../../../../apidocs/org/apache/jsieve/tests/True.html">View Javadoc</a></div><pre>
 
 <a name="1" href="#1">1</a>   <em class="jxr_javadoccomment">/**</em><em class="jxr_javadoccomment">**************************************************************</em>
 <a name="2" href="#2">2</a>   <em class="jxr_javadoccomment"> * Licensed to the Apache Software Foundation (ASF) under one   *</em>

Modified: james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/optional/Body.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/optional/Body.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/optional/Body.html (original)
+++ james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/optional/Body.html Sat Sep  5 09:49:32 2009
@@ -6,7 +6,7 @@
 <link type="text/css" rel="stylesheet" href="../../../../../stylesheet.css" />
 </head>
 <body>
-<div id="overview"><a href="../../../../../../../../../../../../workspace/jsieve/main/target/site/apidocs/org/apache/jsieve/tests/optional/Body.html">View Javadoc</a></div><pre>
+<div id="overview"><a href="../../../../../../apidocs/org/apache/jsieve/tests/optional/Body.html">View Javadoc</a></div><pre>
 
 <a name="1" href="#1">1</a>   <em class="jxr_javadoccomment">/**</em><em class="jxr_javadoccomment">**************************************************************</em>
 <a name="2" href="#2">2</a>   <em class="jxr_javadoccomment"> * Licensed to the Apache Software Foundation (ASF) under one   *</em>
@@ -43,8 +43,8 @@
 <a name="33" href="#33">33</a>  <strong class="jxr_keyword">import</strong> org.apache.jsieve.tests.AbstractTest;
 <a name="34" href="#34">34</a>  
 <a name="35" href="#35">35</a>  <em class="jxr_javadoccomment">/**</em>
-<a name="36" href="#36">36</a>  <em class="jxr_javadoccomment"> * This implements a single subset of the 'body' Sieve test as define here:</em>
-<a name="37" href="#37">37</a>  <em class="jxr_javadoccomment"> * <a href="http://tools.ietf.org/html/draft-ietf-sieve-body-00" target="alexandria_uri">http://tools.ietf.org/html/draft-ietf-sieve-body-00</a></em>
+<a name="36" href="#36">36</a>  <em class="jxr_javadoccomment"> * Implementation of body extension defined in</em>
+<a name="37" href="#37">37</a>  <em class="jxr_javadoccomment"> * &lt;a href='<a href="http://tools.ietf.org/html/rfc5173'&gt;RFC5173&lt;/a&gt;." target="alexandria_uri">http://tools.ietf.org/html/rfc5173'&gt;RFC5173&lt;/a&gt;.</a></em>
 <a name="38" href="#38">38</a>  <em class="jxr_javadoccomment"> */</em>
 <a name="39" href="#39">39</a>  <strong class="jxr_keyword">public</strong> <strong class="jxr_keyword">class</strong> <a href="../../../../../org/apache/jsieve/tests/optional/Body.html">Body</a> <strong class="jxr_keyword">extends</strong> <a href="../../../../../org/apache/jsieve/tests/AbstractTest.html">AbstractTest</a> {
 <a name="40" href="#40">40</a>      <strong class="jxr_keyword">private</strong> <a href="../../../../../org/apache/jsieve/StringListArgument.html">StringListArgument</a> strings;

Modified: james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/optional/Envelope.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/optional/Envelope.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/optional/Envelope.html (original)
+++ james/site/trunk/www/jsieve/main/xref/org/apache/jsieve/tests/optional/Envelope.html Sat Sep  5 09:49:32 2009
@@ -6,7 +6,7 @@
 <link type="text/css" rel="stylesheet" href="../../../../../stylesheet.css" />
 </head>
 <body>
-<div id="overview"><a href="../../../../../../../../../../../../workspace/jsieve/main/target/site/apidocs/org/apache/jsieve/tests/optional/Envelope.html">View Javadoc</a></div><pre>
+<div id="overview"><a href="../../../../../../apidocs/org/apache/jsieve/tests/optional/Envelope.html">View Javadoc</a></div><pre>
 
 <a name="1" href="#1">1</a>   <em class="jxr_javadoccomment">/**</em><em class="jxr_javadoccomment">**************************************************************</em>
 <a name="2" href="#2">2</a>   <em class="jxr_javadoccomment"> * Licensed to the Apache Software Foundation (ASF) under one   *</em>

Modified: james/site/trunk/www/jsieve/plugin-management.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/plugin-management.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/plugin-management.html (original)
+++ james/site/trunk/www/jsieve/plugin-management.html Sat Sep  5 09:49:32 2009
@@ -18,11 +18,11 @@
       @import url("./css/site.css");
     </style>
     <link rel="stylesheet" href="./css/print.css" type="text/css" media="print" />
-        <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
+        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
       </head>
   <body class="composite">
     <div id="banner">
-                  <a href="http://james.apache.org/" id="bannerLeft">
+                  <a href="../" id="bannerLeft">
     
                                             <img src="images/james-jsieve-logo.gif" alt="" />
     
@@ -45,13 +45,13 @@
   
   
             <div class="xleft">
-        Last Published: 08/03/2009
+        Last Published: 09/05/2009
                       </div>
             <div class="xright">      <a href="../index.html">JAMES Project</a>
           |
           <a href="../imap/index.html">IMAP</a>
           |
-          <a href="../jsieve/index.html">JSieve</a>
+          <a href="index.html">JSieve</a>
           |
           <a href="../jspf/index.html">jSPF</a>
           |
@@ -89,46 +89,54 @@
         <ul>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/main/index.html">Main</a>
+              <a href="main/index.html">Main</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/mailet/index.html">Mailet</a>
+              <a href="mailet/index.html">Mailet</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/util/index.html">Util</a>
+              <a href="util/index.html">Util</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/jira-report.html">Changes</a>
+              <a href="jira-report.html">Changes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/release-notes.html">Release Notes</a>
+              <a href="release-notes.html">Release Notes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/apidocs/index.html">JavaDocs</a>
+              <a href="apidocs/index.html">JavaDocs</a>
         </li>
           </ul>
           <h5>Specifications</h5>
         <ul>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 (ABNF)</a>
+              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 ABNF</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 (ACAP)</a>
+              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 ACAP</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 (MDN)</a>
+              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 MDN</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc3028.txt">RFC 3028 (Sieve)</a>
+              <a href="http://tools.ietf.org/html/rfc5228">RFC 5228 Sieve</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc4790">RFC 4790 IAPCR</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc5173">RFC 5173 Body Extension</a>
         </li>
           </ul>
           <h5>0.3 Release</h5>
@@ -233,7 +241,138 @@
     </div>
     <div id="bodyColumn">
       <div id="contentBox">
-        <div class="section"><h2>Project Plugin Management</h2><table class="bodyTable"><tr class="a"><th>GroupId</th><th>ArtifactId</th><th>Version</th></tr><tr class="b"><td>org.apache.felix</td><td><a href="http://felix.apache.org/maven-bundle-plugin">maven-bundle-plugin</a></td><td>1.4.3</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-antrun-plugin">maven-antrun-plugin</a></td><td>1.3</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-assembly-plugin">maven-assembly-plugin</a></td><td>2.2-beta-2</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-clean-plugin">maven-clean-plugin</a></td><td>2.3</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-compiler-plugin">maven-compiler-plugin</a></td><td>2.0.2</td></tr><tr class="a"><td>org.apache.maven.plugi
 ns</td><td><a href="http://maven.apache.org/plugins/maven-dependency-plugin">maven-dependency-plugin</a></td><td>2.0</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-deploy-plugin">maven-deploy-plugin</a></td><td>2.4</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-doap-plugin">maven-doap-plugin</a></td><td>1.0</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-docck-plugin">maven-docck-plugin</a></td><td>1.0</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-ear-plugin">maven-ear-plugin</a></td><td>2.3.1</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-ejb-plugin">maven-ejb-plugin</a></td><td>2.1</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugi
 ns/maven-enforcer-plugin/">maven-enforcer-plugin</a></td><td>1.0-beta-1</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-gpg-plugin">maven-gpg-plugin</a></td><td>1.0-alpha-4</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-install-plugin">maven-install-plugin</a></td><td>2.2</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-invoker-plugin">maven-invoker-plugin</a></td><td>1.3</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-jar-plugin">maven-jar-plugin</a></td><td>2.2</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-javadoc-plugin">maven-javadoc-plugin</a></td><td>2.5</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-plugin-plugin">mav
 en-plugin-plugin</a></td><td>2.5</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-rar-plugin">maven-rar-plugin</a></td><td>2.2</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-release-plugin/">maven-release-plugin</a></td><td>2.0-beta-9</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-remote-resources-plugin">maven-remote-resources-plugin</a></td><td>1.0</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-resources-plugin">maven-resources-plugin</a></td><td>2.3</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-scm-plugin">maven-scm-plugin</a></td><td>1.2</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-site-plugin">maven-site-plugin</a><
 /td><td>2.0-beta-5</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-source-plugin">maven-source-plugin</a></td><td>2.0.4</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/surefire/maven-surefire-plugin">maven-surefire-plugin</a></td><td>2.4.3</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-war-plugin">maven-war-plugin</a></td><td>2.1-alpha-2</td></tr><tr class="a"><td>org.codehaus.modello</td><td><a href="http://modello.codehaus.org/modello-maven-plugin">modello-maven-plugin</a></td><td>1.0.1</td></tr><tr class="b"><td>org.codehaus.mojo</td><td><a href="http://mojo.codehaus.org/clirr-maven-plugin">clirr-maven-plugin</a></td><td>2.2.2</td></tr><tr class="a"><td>org.codehaus.mojo</td><td><a href="http://mojo.codehaus.org/rat-maven-plugin">rat-maven-plugin</a></td><td>1.0-alpha-3</td></tr><tr class="b"><td>org.codehaus.p
 lexus</td><td>plexus-maven-plugin</td><td>1.3.8</td></tr></table></div>
+        <div class="section"><h2>Project Plugin Management</h2>
+<table class="bodyTable"><tr class="a"><th>GroupId</th>
+<th>ArtifactId</th>
+<th>Version</th>
+</tr>
+<tr class="b"><td>org.apache.felix</td>
+<td><a class="externalLink" href="http://felix.apache.org/maven-bundle-plugin">maven-bundle-plugin</a></td>
+<td>1.4.3</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-antrun-plugin">maven-antrun-plugin</a></td>
+<td>1.3</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-assembly-plugin">maven-assembly-plugin</a></td>
+<td>2.2-beta-2</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-clean-plugin">maven-clean-plugin</a></td>
+<td>2.3</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-compiler-plugin">maven-compiler-plugin</a></td>
+<td>2.0.2</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-dependency-plugin">maven-dependency-plugin</a></td>
+<td>2.0</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-deploy-plugin">maven-deploy-plugin</a></td>
+<td>2.4</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-doap-plugin">maven-doap-plugin</a></td>
+<td>1.0</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-docck-plugin">maven-docck-plugin</a></td>
+<td>1.0</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-ear-plugin">maven-ear-plugin</a></td>
+<td>2.3.1</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-ejb-plugin">maven-ejb-plugin</a></td>
+<td>2.1</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-enforcer-plugin/">maven-enforcer-plugin</a></td>
+<td>1.0-beta-1</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-gpg-plugin">maven-gpg-plugin</a></td>
+<td>1.0-alpha-4</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-install-plugin">maven-install-plugin</a></td>
+<td>2.2</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-invoker-plugin">maven-invoker-plugin</a></td>
+<td>1.3</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-jar-plugin">maven-jar-plugin</a></td>
+<td>2.2</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-javadoc-plugin">maven-javadoc-plugin</a></td>
+<td>2.5</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-plugin-plugin">maven-plugin-plugin</a></td>
+<td>2.5</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-rar-plugin">maven-rar-plugin</a></td>
+<td>2.2</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-release-plugin/">maven-release-plugin</a></td>
+<td>2.0-beta-9</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-remote-resources-plugin">maven-remote-resources-plugin</a></td>
+<td>1.0</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-resources-plugin">maven-resources-plugin</a></td>
+<td>2.3</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-scm-plugin">maven-scm-plugin</a></td>
+<td>1.2</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-site-plugin">maven-site-plugin</a></td>
+<td>2.0.1</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-source-plugin">maven-source-plugin</a></td>
+<td>2.0.4</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/surefire/maven-surefire-plugin">maven-surefire-plugin</a></td>
+<td>2.4.3</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-war-plugin">maven-war-plugin</a></td>
+<td>2.1-alpha-2</td>
+</tr>
+<tr class="a"><td>org.codehaus.modello</td>
+<td><a class="externalLink" href="http://modello.codehaus.org/modello-maven-plugin">modello-maven-plugin</a></td>
+<td>1.0.1</td>
+</tr>
+<tr class="b"><td>org.codehaus.mojo</td>
+<td><a class="externalLink" href="http://mojo.codehaus.org/clirr-maven-plugin">clirr-maven-plugin</a></td>
+<td>2.2.2</td>
+</tr>
+<tr class="a"><td>org.codehaus.mojo</td>
+<td><a class="externalLink" href="http://mojo.codehaus.org/rat-maven-plugin">rat-maven-plugin</a></td>
+<td>1.0-alpha-3</td>
+</tr>
+<tr class="b"><td>org.codehaus.plexus</td>
+<td>plexus-maven-plugin</td>
+<td>1.3.8</td>
+</tr>
+</table>
+</div>
+
       </div>
     </div>
     <div class="clear">

Modified: james/site/trunk/www/jsieve/plugins.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/plugins.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/plugins.html (original)
+++ james/site/trunk/www/jsieve/plugins.html Sat Sep  5 09:49:32 2009
@@ -18,11 +18,11 @@
       @import url("./css/site.css");
     </style>
     <link rel="stylesheet" href="./css/print.css" type="text/css" media="print" />
-        <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
+        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
       </head>
   <body class="composite">
     <div id="banner">
-                  <a href="http://james.apache.org/" id="bannerLeft">
+                  <a href="../" id="bannerLeft">
     
                                             <img src="images/james-jsieve-logo.gif" alt="" />
     
@@ -45,13 +45,13 @@
   
   
             <div class="xleft">
-        Last Published: 08/03/2009
+        Last Published: 09/05/2009
                       </div>
             <div class="xright">      <a href="../index.html">JAMES Project</a>
           |
           <a href="../imap/index.html">IMAP</a>
           |
-          <a href="../jsieve/index.html">JSieve</a>
+          <a href="index.html">JSieve</a>
           |
           <a href="../jspf/index.html">jSPF</a>
           |
@@ -89,46 +89,54 @@
         <ul>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/main/index.html">Main</a>
+              <a href="main/index.html">Main</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/mailet/index.html">Mailet</a>
+              <a href="mailet/index.html">Mailet</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/util/index.html">Util</a>
+              <a href="util/index.html">Util</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/jira-report.html">Changes</a>
+              <a href="jira-report.html">Changes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/release-notes.html">Release Notes</a>
+              <a href="release-notes.html">Release Notes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/apidocs/index.html">JavaDocs</a>
+              <a href="apidocs/index.html">JavaDocs</a>
         </li>
           </ul>
           <h5>Specifications</h5>
         <ul>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 (ABNF)</a>
+              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 ABNF</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 (ACAP)</a>
+              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 ACAP</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 (MDN)</a>
+              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 MDN</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc3028.txt">RFC 3028 (Sieve)</a>
+              <a href="http://tools.ietf.org/html/rfc5228">RFC 5228 Sieve</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc4790">RFC 4790 IAPCR</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc5173">RFC 5173 Body Extension</a>
         </li>
           </ul>
           <h5>0.3 Release</h5>
@@ -233,7 +241,41 @@
     </div>
     <div id="bodyColumn">
       <div id="contentBox">
-        <div class="section"><h2>Project Build Plugins</h2><table class="bodyTable"><tr class="a"><th>GroupId</th><th>ArtifactId</th><th>Version</th></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-remote-resources-plugin">maven-remote-resources-plugin</a></td><td>1.0</td></tr></table></div><div class="section"><h2>Project Report Plugins</h2><table class="bodyTable"><tr class="a"><th>GroupId</th><th>ArtifactId</th><th>Version</th></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-changes-plugin-2.1">maven-changes-plugin</a></td><td>2.1</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-javadoc-plugin">maven-javadoc-plugin</a></td><td>2.4</td></tr><tr class="b"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-project-info-reports-plugin">maven-project-info-reports-plugin</a></td><td
 >2.1.1</td></tr><tr class="a"><td>org.apache.maven.plugins</td><td><a href="http://maven.apache.org/plugins/maven-site-plugin">maven-site-plugin</a></td><td>2.0-beta-7</td></tr></table></div>
+        <div class="section"><h2>Project Build Plugins</h2>
+<table class="bodyTable"><tr class="a"><th>GroupId</th>
+<th>ArtifactId</th>
+<th>Version</th>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-remote-resources-plugin">maven-remote-resources-plugin</a></td>
+<td>1.0</td>
+</tr>
+</table>
+</div>
+<div class="section"><h2>Project Report Plugins</h2>
+<table class="bodyTable"><tr class="a"><th>GroupId</th>
+<th>ArtifactId</th>
+<th>Version</th>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-changes-plugin-2.1">maven-changes-plugin</a></td>
+<td>2.1</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-javadoc-plugin">maven-javadoc-plugin</a></td>
+<td>2.4</td>
+</tr>
+<tr class="b"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-project-info-reports-plugin">maven-project-info-reports-plugin</a></td>
+<td>2.1.1</td>
+</tr>
+<tr class="a"><td>org.apache.maven.plugins</td>
+<td><a class="externalLink" href="http://maven.apache.org/plugins/maven-site-plugin">maven-site-plugin</a></td>
+<td>2.0-beta-7</td>
+</tr>
+</table>
+</div>
+
       </div>
     </div>
     <div class="clear">

Modified: james/site/trunk/www/jsieve/project-info.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/project-info.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/project-info.html (original)
+++ james/site/trunk/www/jsieve/project-info.html Sat Sep  5 09:49:32 2009
@@ -18,11 +18,11 @@
       @import url("./css/site.css");
     </style>
     <link rel="stylesheet" href="./css/print.css" type="text/css" media="print" />
-        <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
+        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
       </head>
   <body class="composite">
     <div id="banner">
-                  <a href="http://james.apache.org/" id="bannerLeft">
+                  <a href="../" id="bannerLeft">
     
                                             <img src="images/james-jsieve-logo.gif" alt="" />
     
@@ -45,13 +45,13 @@
   
   
             <div class="xleft">
-        Last Published: 08/03/2009
+        Last Published: 09/05/2009
                       </div>
             <div class="xright">      <a href="../index.html">JAMES Project</a>
           |
           <a href="../imap/index.html">IMAP</a>
           |
-          <a href="../jsieve/index.html">JSieve</a>
+          <a href="index.html">JSieve</a>
           |
           <a href="../jspf/index.html">jSPF</a>
           |
@@ -89,46 +89,54 @@
         <ul>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/main/index.html">Main</a>
+              <a href="main/index.html">Main</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/mailet/index.html">Mailet</a>
+              <a href="mailet/index.html">Mailet</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/util/index.html">Util</a>
+              <a href="util/index.html">Util</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/jira-report.html">Changes</a>
+              <a href="jira-report.html">Changes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/release-notes.html">Release Notes</a>
+              <a href="release-notes.html">Release Notes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/apidocs/index.html">JavaDocs</a>
+              <a href="apidocs/index.html">JavaDocs</a>
         </li>
           </ul>
           <h5>Specifications</h5>
         <ul>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 (ABNF)</a>
+              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 ABNF</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 (ACAP)</a>
+              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 ACAP</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 (MDN)</a>
+              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 MDN</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc3028.txt">RFC 3028 (Sieve)</a>
+              <a href="http://tools.ietf.org/html/rfc5228">RFC 5228 Sieve</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc4790">RFC 4790 IAPCR</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc5173">RFC 5173 Body Extension</a>
         </li>
           </ul>
           <h5>0.3 Release</h5>
@@ -233,7 +241,55 @@
     </div>
     <div id="bodyColumn">
       <div id="contentBox">
-        <div class="section"><h2>Project Information</h2><p>This document provides an overview of the various documents and links that are part of this project's general information. All of this content is automatically generated by <a href="http://maven.apache.org">Maven</a> on behalf of the project.</p><div class="section"><h3>Overview</h3><table class="bodyTable"><tr class="a"><th>Document</th><th>Description</th></tr><tr class="b"><td><a href="dependencies.html">Dependencies</a></td><td>This document lists the project's dependencies and provides information on each dependency.</td></tr><tr class="a"><td><a href="mail-lists.html">Mailing Lists</a></td><td>This document provides subscription and archive information for this project's mailing lists.</td></tr><tr class="b"><td><a href="source-repository.html">Source Repository</a></td><td>This is a link to the online source repository that can be viewed via a web browser.</td></tr><tr class="a"><td><a href="dependency-conver
 gence.html">Dependency Convergence</a></td><td>This document presents the convergence of dependency versions across the entire project, and its sub modules.</td></tr><tr class="b"><td><a href="license.html">Project License</a></td><td>This is a link to the definitions of project licenses.</td></tr><tr class="a"><td><a href="plugin-management.html">Plugin Management</a></td><td>This document lists the plugins that are defined through pluginManagement.</td></tr><tr class="b"><td><a href="team-list.html">Project Team</a></td><td>This document provides information on the members of this project. These are the individuals who have contributed to the project in one form or another.</td></tr><tr class="a"><td><a href="integration.html">Continuous Integration</a></td><td>This is a link to the definitions of all continuous integration processes that builds and tests code on a frequent, regular basis.</td></tr><tr class="b"><td><a href="issue-tracking.html">Issue Tracking</a></td><td>
 This is a link to the issue management system for this project. Issues (bugs, features, change requests) can be created and queried using this link.</td></tr><tr class="a"><td><a href="project-summary.html">Project Summary</a></td><td>This document lists other related information of this project</td></tr><tr class="b"><td><a href="plugins.html">Project Plugins</a></td><td>This document lists the build plugins and the report plugins used by this project.</td></tr><tr class="a"><td><a href="dependency-management.html">Dependency Management</a></td><td>This document lists the dependencies that are defined through dependencyManagement.</td></tr></table></div></div>
+        <div class="section"><h2>Project Information</h2>
+<p>This document provides an overview of the various documents and links that are part of this project's general information. All of this content is automatically generated by <a class="externalLink" href="http://maven.apache.org">Maven</a> on behalf of the project.</p>
+<div class="section"><h3>Overview</h3>
+<table class="bodyTable"><tr class="a"><th>Document</th>
+<th>Description</th>
+</tr>
+<tr class="b"><td><a href="index.html">About</a></td>
+<td>Apache JAMES JSieve Project</td>
+</tr>
+<tr class="a"><td><a href="dependencies.html">Dependencies</a></td>
+<td>This document lists the project's dependencies and provides information on each dependency.</td>
+</tr>
+<tr class="b"><td><a href="mail-lists.html">Mailing Lists</a></td>
+<td>This document provides subscription and archive information for this project's mailing lists.</td>
+</tr>
+<tr class="a"><td><a href="source-repository.html">Source Repository</a></td>
+<td>This is a link to the online source repository that can be viewed via a web browser.</td>
+</tr>
+<tr class="b"><td><a href="dependency-convergence.html">Dependency Convergence</a></td>
+<td>This document presents the convergence of dependency versions across the entire project, and its sub modules.</td>
+</tr>
+<tr class="a"><td><a href="license.html">Project License</a></td>
+<td>This is a link to the definitions of project licenses.</td>
+</tr>
+<tr class="b"><td><a href="plugin-management.html">Plugin Management</a></td>
+<td>This document lists the plugins that are defined through pluginManagement.</td>
+</tr>
+<tr class="a"><td><a href="team-list.html">Project Team</a></td>
+<td>This document provides information on the members of this project. These are the individuals who have contributed to the project in one form or another.</td>
+</tr>
+<tr class="b"><td><a href="integration.html">Continuous Integration</a></td>
+<td>This is a link to the definitions of all continuous integration processes that builds and tests code on a frequent, regular basis.</td>
+</tr>
+<tr class="a"><td><a href="project-summary.html">Project Summary</a></td>
+<td>This document lists other related information of this project</td>
+</tr>
+<tr class="b"><td><a href="issue-tracking.html">Issue Tracking</a></td>
+<td>This is a link to the issue management system for this project. Issues (bugs, features, change requests) can be created and queried using this link.</td>
+</tr>
+<tr class="a"><td><a href="plugins.html">Project Plugins</a></td>
+<td>This document lists the build plugins and the report plugins used by this project.</td>
+</tr>
+<tr class="b"><td><a href="dependency-management.html">Dependency Management</a></td>
+<td>This document lists the dependencies that are defined through dependencyManagement.</td>
+</tr>
+</table>
+</div>
+</div>
+
       </div>
     </div>
     <div class="clear">

Modified: james/site/trunk/www/jsieve/project-reports.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/project-reports.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/project-reports.html (original)
+++ james/site/trunk/www/jsieve/project-reports.html Sat Sep  5 09:49:32 2009
@@ -18,11 +18,11 @@
       @import url("./css/site.css");
     </style>
     <link rel="stylesheet" href="./css/print.css" type="text/css" media="print" />
-        <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
+        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
       </head>
   <body class="composite">
     <div id="banner">
-                  <a href="http://james.apache.org/" id="bannerLeft">
+                  <a href="../" id="bannerLeft">
     
                                             <img src="images/james-jsieve-logo.gif" alt="" />
     
@@ -45,13 +45,13 @@
   
   
             <div class="xleft">
-        Last Published: 08/03/2009
+        Last Published: 09/05/2009
                       </div>
             <div class="xright">      <a href="../index.html">JAMES Project</a>
           |
           <a href="../imap/index.html">IMAP</a>
           |
-          <a href="../jsieve/index.html">JSieve</a>
+          <a href="index.html">JSieve</a>
           |
           <a href="../jspf/index.html">jSPF</a>
           |
@@ -89,46 +89,54 @@
         <ul>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/main/index.html">Main</a>
+              <a href="main/index.html">Main</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/mailet/index.html">Mailet</a>
+              <a href="mailet/index.html">Mailet</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/util/index.html">Util</a>
+              <a href="util/index.html">Util</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/jira-report.html">Changes</a>
+              <a href="jira-report.html">Changes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/release-notes.html">Release Notes</a>
+              <a href="release-notes.html">Release Notes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/apidocs/index.html">JavaDocs</a>
+              <a href="apidocs/index.html">JavaDocs</a>
         </li>
           </ul>
           <h5>Specifications</h5>
         <ul>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 (ABNF)</a>
+              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 ABNF</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 (ACAP)</a>
+              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 ACAP</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 (MDN)</a>
+              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 MDN</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc3028.txt">RFC 3028 (Sieve)</a>
+              <a href="http://tools.ietf.org/html/rfc5228">RFC 5228 Sieve</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc4790">RFC 4790 IAPCR</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc5173">RFC 5173 Body Extension</a>
         </li>
           </ul>
           <h5>0.3 Release</h5>
@@ -233,7 +241,25 @@
     </div>
     <div id="bodyColumn">
       <div id="contentBox">
-        <div class="section"><h2>Generated Reports</h2><p>This document provides an overview of the various reports that are automatically generated by <a href="http://maven.apache.org">Maven</a> Each report is briefly described below.</p><div class="section"><h3>Overview</h3><table class="bodyTable"><tr class="a"><th>Document</th><th>Description</th></tr><tr class="b"><td><a href="apidocs/index.html">JavaDocs</a></td><td>JavaDoc API documentation.</td></tr><tr class="a"><td><a href="jira-report.html">JIRA Report</a></td><td>Report on Issues from the JIRA Issue Tracking System.</td></tr><tr class="b"><td><a href="testapidocs/index.html">Test JavaDocs</a></td><td>Test JavaDoc API documentation.</td></tr></table></div></div>
+        <div class="section"><h2>Generated Reports</h2>
+<p>This document provides an overview of the various reports that are automatically generated by <a class="externalLink" href="http://maven.apache.org">Maven</a> . Each report is briefly described below.</p>
+<div class="section"><h3>Overview</h3>
+<table class="bodyTable"><tr class="a"><th>Document</th>
+<th>Description</th>
+</tr>
+<tr class="b"><td><a href="apidocs/index.html">JavaDocs</a></td>
+<td>JavaDoc API documentation.</td>
+</tr>
+<tr class="a"><td><a href="jira-report.html">JIRA Report</a></td>
+<td>Report on Issues from the JIRA Issue Tracking System.</td>
+</tr>
+<tr class="b"><td><a href="testapidocs/index.html">Test JavaDocs</a></td>
+<td>Test JavaDoc API documentation.</td>
+</tr>
+</table>
+</div>
+</div>
+
       </div>
     </div>
     <div class="clear">

Modified: james/site/trunk/www/jsieve/project-summary.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/project-summary.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/project-summary.html (original)
+++ james/site/trunk/www/jsieve/project-summary.html Sat Sep  5 09:49:32 2009
@@ -18,11 +18,11 @@
       @import url("./css/site.css");
     </style>
     <link rel="stylesheet" href="./css/print.css" type="text/css" media="print" />
-        <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
+        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
       </head>
   <body class="composite">
     <div id="banner">
-                  <a href="http://james.apache.org/" id="bannerLeft">
+                  <a href="../" id="bannerLeft">
     
                                             <img src="images/james-jsieve-logo.gif" alt="" />
     
@@ -45,13 +45,13 @@
   
   
             <div class="xleft">
-        Last Published: 08/03/2009
+        Last Published: 09/05/2009
                       </div>
             <div class="xright">      <a href="../index.html">JAMES Project</a>
           |
           <a href="../imap/index.html">IMAP</a>
           |
-          <a href="../jsieve/index.html">JSieve</a>
+          <a href="index.html">JSieve</a>
           |
           <a href="../jspf/index.html">jSPF</a>
           |
@@ -89,46 +89,54 @@
         <ul>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/main/index.html">Main</a>
+              <a href="main/index.html">Main</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/mailet/index.html">Mailet</a>
+              <a href="mailet/index.html">Mailet</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/util/index.html">Util</a>
+              <a href="util/index.html">Util</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/jira-report.html">Changes</a>
+              <a href="jira-report.html">Changes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/release-notes.html">Release Notes</a>
+              <a href="release-notes.html">Release Notes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/apidocs/index.html">JavaDocs</a>
+              <a href="apidocs/index.html">JavaDocs</a>
         </li>
           </ul>
           <h5>Specifications</h5>
         <ul>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 (ABNF)</a>
+              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 ABNF</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 (ACAP)</a>
+              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 ACAP</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 (MDN)</a>
+              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 MDN</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc3028.txt">RFC 3028 (Sieve)</a>
+              <a href="http://tools.ietf.org/html/rfc5228">RFC 5228 Sieve</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc4790">RFC 4790 IAPCR</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc5173">RFC 5173 Body Extension</a>
         </li>
           </ul>
           <h5>0.3 Release</h5>
@@ -233,7 +241,54 @@
     </div>
     <div id="bodyColumn">
       <div id="contentBox">
-        <div class="section"><h2>Project Summary</h2><div class="section"><h3>Project Information</h3><table class="bodyTable"><tr class="a"><th>Field</th><th>Value</th></tr><tr class="b"><td>Name</td><td>Apache JAMES JSieve Project</td></tr><tr class="a"><td>Description</td><td>Apache JAMES JSieve Project</td></tr><tr class="b"><td>Homepage</td><td><a href="../../../../people.apache.org/www/james.apache.org//jsieve/">../../../../people.apache.org/www/james.apache.org//jsieve/</a></td></tr></table></div><div class="section"><h3>Project Organization</h3><table class="bodyTable"><tr class="a"><th>Field</th><th>Value</th></tr><tr class="b"><td>Name</td><td>The Apache Software Foundation</td></tr><tr class="a"><td>URL</td><td><a href="http://www.apache.org">http://www.apache.org</a></td></tr></table></div><div class="section"><h3>Build Information</h3><table class="bodyTable"><tr class="b"><th>Field</th><th>Value</th></tr><tr class="a"><td>GroupId</td><td>org.apache.james</td></
 tr><tr class="b"><td>ArtifactId</td><td>jsieve-project</td></tr><tr class="a"><td>Version</td><td>0.4-SNAPSHOT</td></tr><tr class="b"><td>Type</td><td>pom</td></tr></table></div></div>
+        <div class="section"><h2>Project Summary</h2>
+<div class="section"><h3>Project Information</h3>
+<table class="bodyTable"><tr class="a"><th>Field</th>
+<th>Value</th>
+</tr>
+<tr class="b"><td>Name</td>
+<td>Apache JAMES JSieve Project</td>
+</tr>
+<tr class="a"><td>Description</td>
+<td>Apache JAMES JSieve Project</td>
+</tr>
+<tr class="b"><td>Homepage</td>
+<td><a class="externalLink" href="http://james.apache.org/jsieve/">http://james.apache.org/jsieve/</a></td>
+</tr>
+</table>
+</div>
+<div class="section"><h3>Project Organization</h3>
+<table class="bodyTable"><tr class="a"><th>Field</th>
+<th>Value</th>
+</tr>
+<tr class="b"><td>Name</td>
+<td>The Apache Software Foundation</td>
+</tr>
+<tr class="a"><td>URL</td>
+<td><a class="externalLink" href="http://www.apache.org">http://www.apache.org</a></td>
+</tr>
+</table>
+</div>
+<div class="section"><h3>Build Information</h3>
+<table class="bodyTable"><tr class="b"><th>Field</th>
+<th>Value</th>
+</tr>
+<tr class="a"><td>GroupId</td>
+<td>org.apache.james</td>
+</tr>
+<tr class="b"><td>ArtifactId</td>
+<td>jsieve-project</td>
+</tr>
+<tr class="a"><td>Version</td>
+<td>0.4-SNAPSHOT</td>
+</tr>
+<tr class="b"><td>Type</td>
+<td>pom</td>
+</tr>
+</table>
+</div>
+</div>
+
       </div>
     </div>
     <div class="clear">

Modified: james/site/trunk/www/jsieve/release-notes.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/release-notes.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/release-notes.html (original)
+++ james/site/trunk/www/jsieve/release-notes.html Sat Sep  5 09:49:32 2009
@@ -19,11 +19,11 @@
     </style>
     <link rel="stylesheet" href="./css/print.css" type="text/css" media="print" />
           <meta name="author" content="Apache JAMES Project Team" />
-        <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
+        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
       </head>
   <body class="composite">
     <div id="banner">
-                  <a href="http://james.apache.org/" id="bannerLeft">
+                  <a href="../" id="bannerLeft">
     
                                             <img src="images/james-jsieve-logo.gif" alt="" />
     
@@ -46,13 +46,13 @@
   
   
             <div class="xleft">
-        Last Published: 08/03/2009
+        Last Published: 09/05/2009
                       </div>
             <div class="xright">      <a href="../index.html">JAMES Project</a>
           |
           <a href="../imap/index.html">IMAP</a>
           |
-          <a href="../jsieve/index.html">JSieve</a>
+          <a href="index.html">JSieve</a>
           |
           <a href="../jspf/index.html">jSPF</a>
           |
@@ -90,46 +90,54 @@
         <ul>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/main/index.html">Main</a>
+              <a href="main/index.html">Main</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/mailet/index.html">Mailet</a>
+              <a href="mailet/index.html">Mailet</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/util/index.html">Util</a>
+              <a href="util/index.html">Util</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/jira-report.html">Changes</a>
+              <a href="jira-report.html">Changes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/release-notes.html">Release Notes</a>
+              <strong>Release Notes</strong>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/apidocs/index.html">JavaDocs</a>
+              <a href="apidocs/index.html">JavaDocs</a>
         </li>
           </ul>
           <h5>Specifications</h5>
         <ul>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 (ABNF)</a>
+              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 ABNF</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 (ACAP)</a>
+              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 ACAP</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 (MDN)</a>
+              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 MDN</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc3028.txt">RFC 3028 (Sieve)</a>
+              <a href="http://tools.ietf.org/html/rfc5228">RFC 5228 Sieve</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc4790">RFC 4790 IAPCR</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc5173">RFC 5173 Body Extension</a>
         </li>
           </ul>
           <h5>0.3 Release</h5>
@@ -234,7 +242,58 @@
     </div>
     <div id="bodyColumn">
       <div id="contentBox">
-        <div class="section"><h2>Release Notes</h2></div><div class="section"><h2>Apache JSieve</h2><p>jSieve is a Java implementation of the Sieve mail filtering language defined by RFC 3028. jSieve is implemented as a langauge processor that can be plugged into any internet mail application to add Sieve support.</p><div class="section"><h3>Comments, Questions and Issues</h3><p>jSieve is a sub-project of Apache James. Please direct your comments and questions to the relevant James list.</p><p>To report issues, such as bugs, go to http://issues.apache.org/jira/browse/JSIEVE As jSieve comes with a fairly extensive suite of jUnit Tests, it would be most helpful for bug reports to be accompanied by an illustrative jUnit test case.</p></div><div class="section"><h3>Licensing and legal issues</h3><p>For legal and licensing issues, please look in the legal section of the documentation or read the LICENSE and NOTICE files.</p></div></div><div class="section"><h2>Version 0.3</h2><p>
 This release is the first to include mailet and utility modules, in addition to the core parsing library. The configuration API has changed significantly to replace magic singletons with POJOs suitable for IoC. The default configuration mechanism has been retained so though calls have changed, existing configurations should still be compatible.</p><p>Utilities include node serializers to xml and sieve script. The mailet module provides Sieve in the James 3 codebase.</p><div class="section"><h3>Changes </h3><div class="section"><h4>Sub-tasks Completed</h4><ul><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-27">JSIEVE-27</a>] - Refactor ComparatorManager</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-29">JSIEVE-29</a>] - Refactor ConfigurationManager</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-32">JSIEVE-32</a>] - Refactor TestManager</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-37">JSIEVE-37</a>] - Push main sour
 ce down a level</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-38">JSIEVE-38</a>] - Modular Ant Build</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-44">JSIEVE-44</a>] - Create Check Module</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-45">JSIEVE-45</a>] - Extract Reusable Ant Macros</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-46">JSIEVE-46</a>] - Unified Distribution</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-48">JSIEVE-48</a>] - Release Quality Maven Build</li></ul></div><div class="section"><h4>Bugs Fixed</h4><ul><li>[<a href="href='https://issues.apache.org/jira/browse/JSIEVE-49">JSIEVE-49</a>] - CPU spins when :matches expression contains &amp;quot;*************&amp;quot;</li></ul></div><div class="section"><h4>Improvements Made</h4><ul><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-47">JSIEVE-47</a>] - Access to script comments</li><li>[<a href="https://issues.apache.org
 /jira/browse/JSIEVE-52">JSIEVE-52</a>] - Check Support For Numeric Quantifiers</li></ul></div><div class="section"><h4>New Features Added</h4><ul><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-43">JSIEVE-43</a>] - Add API for generating a Sieve script from a parse tree </li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-50">JSIEVE-50</a>] - Sieve-In-XML (Experimental Preview)</li></ul></div><div class="section"><h4>Tasks Completed</h4><ul><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-16">JSIEVE-16</a>] - Singletons -&gt; IoC</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-24">JSIEVE-24</a>] - Include build time libraries (javacc, javamail, activation) in the source distribution</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-33">JSIEVE-33</a>] - Remove .junit. package name from tests.</li><li>[<a href="https://issues.apache.org/jira/browse/JSIEVE-34">JSIEVE-34</a>] - make jsieve a multimodule project</li></ul
 ></div></div></div>
+        <div class="section"><h2>Release Notes</h2>
+</div>
+<div class="section"><h2>Apache JSieve</h2>
+<p>jSieve is a Java implementation of the Sieve mail filtering language defined by RFC 3028. jSieve is implemented as a langauge processor that can be plugged into any internet mail application to add Sieve support.</p>
+<div class="section"><h3>Comments, Questions and Issues</h3>
+<p>jSieve is a sub-project of Apache James. Please direct your comments and questions to the relevant James list.</p>
+<p>To report issues, such as bugs, go to http://issues.apache.org/jira/browse/JSIEVE As jSieve comes with a fairly extensive suite of jUnit Tests, it would be most helpful for bug reports to be accompanied by an illustrative jUnit test case.</p>
+</div>
+<div class="section"><h3>Licensing and legal issues</h3>
+<p>For legal and licensing issues, please look in the legal section of the documentation or read the LICENSE and NOTICE files.</p>
+</div>
+</div>
+<div class="section"><h2>Version 0.3</h2>
+<p>This release is the first to include mailet and utility modules, in addition to the core parsing library. The configuration API has changed significantly to replace magic singletons with POJOs suitable for IoC. The default configuration mechanism has been retained so though calls have changed, existing configurations should still be compatible.</p>
+<p>Utilities include node serializers to xml and sieve script. The mailet module provides Sieve in the James 3 codebase.</p>
+<div class="section"><h3>Changes </h3>
+<div class="section"><h4>Sub-tasks Completed</h4>
+<ul><li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-27">JSIEVE-27</a>] - Refactor ComparatorManager</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-29">JSIEVE-29</a>] - Refactor ConfigurationManager</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-32">JSIEVE-32</a>] - Refactor TestManager</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-37">JSIEVE-37</a>] - Push main source down a level</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-38">JSIEVE-38</a>] - Modular Ant Build</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-44">JSIEVE-44</a>] - Create Check Module</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-45">JSIEVE-45</a>] - Extract Reusable Ant Macros</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-46">JSIEVE-46</a>] - Unified Distribution</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-48">JSIEVE-48</a>] - Release Quality Maven Build</li>
+</ul>
+</div>
+<div class="section"><h4>Bugs Fixed</h4>
+<ul><li>[<a href="href='https://issues.apache.org/jira/browse/JSIEVE-49">JSIEVE-49</a>] - CPU spins when :matches expression contains &amp;quot;*************&amp;quot;</li>
+</ul>
+</div>
+<div class="section"><h4>Improvements Made</h4>
+<ul><li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-47">JSIEVE-47</a>] - Access to script comments</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-52">JSIEVE-52</a>] - Check Support For Numeric Quantifiers</li>
+</ul>
+</div>
+<div class="section"><h4>New Features Added</h4>
+<ul><li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-43">JSIEVE-43</a>] - Add API for generating a Sieve script from a parse tree </li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-50">JSIEVE-50</a>] - Sieve-In-XML (Experimental Preview)</li>
+</ul>
+</div>
+<div class="section"><h4>Tasks Completed</h4>
+<ul><li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-16">JSIEVE-16</a>] - Singletons -&gt; IoC</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-24">JSIEVE-24</a>] - Include build time libraries (javacc, javamail, activation) in the source distribution</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-33">JSIEVE-33</a>] - Remove .junit. package name from tests.</li>
+<li>[<a class="externalLink" href="https://issues.apache.org/jira/browse/JSIEVE-34">JSIEVE-34</a>] - make jsieve a multimodule project</li>
+</ul>
+</div>
+</div>
+</div>
+
       </div>
     </div>
     <div class="clear">

Modified: james/site/trunk/www/jsieve/source-repository.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/source-repository.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/source-repository.html (original)
+++ james/site/trunk/www/jsieve/source-repository.html Sat Sep  5 09:49:32 2009
@@ -18,11 +18,11 @@
       @import url("./css/site.css");
     </style>
     <link rel="stylesheet" href="./css/print.css" type="text/css" media="print" />
-        <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
+        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
       </head>
   <body class="composite">
     <div id="banner">
-                  <a href="http://james.apache.org/" id="bannerLeft">
+                  <a href="../" id="bannerLeft">
     
                                             <img src="images/james-jsieve-logo.gif" alt="" />
     
@@ -45,13 +45,13 @@
   
   
             <div class="xleft">
-        Last Published: 08/03/2009
+        Last Published: 09/05/2009
                       </div>
             <div class="xright">      <a href="../index.html">JAMES Project</a>
           |
           <a href="../imap/index.html">IMAP</a>
           |
-          <a href="../jsieve/index.html">JSieve</a>
+          <a href="index.html">JSieve</a>
           |
           <a href="../jspf/index.html">jSPF</a>
           |
@@ -89,46 +89,54 @@
         <ul>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/main/index.html">Main</a>
+              <a href="main/index.html">Main</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/mailet/index.html">Mailet</a>
+              <a href="mailet/index.html">Mailet</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/util/index.html">Util</a>
+              <a href="util/index.html">Util</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/jira-report.html">Changes</a>
+              <a href="jira-report.html">Changes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/release-notes.html">Release Notes</a>
+              <a href="release-notes.html">Release Notes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/apidocs/index.html">JavaDocs</a>
+              <a href="apidocs/index.html">JavaDocs</a>
         </li>
           </ul>
           <h5>Specifications</h5>
         <ul>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 (ABNF)</a>
+              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 ABNF</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 (ACAP)</a>
+              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 ACAP</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 (MDN)</a>
+              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 MDN</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc3028.txt">RFC 3028 (Sieve)</a>
+              <a href="http://tools.ietf.org/html/rfc5228">RFC 5228 Sieve</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc4790">RFC 4790 IAPCR</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc5173">RFC 5173 Body Extension</a>
         </li>
           </ul>
           <h5>0.3 Release</h5>
@@ -233,10 +241,42 @@
     </div>
     <div id="bodyColumn">
       <div id="contentBox">
-        <div class="section"><h2>Overview</h2>This project uses <a href="http://subversion.tigris.org/">Subversion</a> to manage its source code. Instructions on Subversion use can be found at <a href="http://svnbook.red-bean.com/">http://svnbook.red-bean.com/</a>.</div><div class="section"><h2>Web Access</h2><p>The following is a link to the online source repository.</p><div class="source"><pre><a href="http://svn.apache.org/viewcvs.cgi/james/jsieve/trunk/?root=Apache-SVN">http://svn.apache.org/viewcvs.cgi/james/jsieve/trunk/?root=Apache-SVN</a></pre></div></div><div class="section"><h2>Anonymous access</h2><p>The source can be checked out anonymously from SVN with this command:</p><div class="source"><pre>$ svn checkout http://svn.apache.org/repos/asf/james/jsieve/trunk jsieve-project</pre></div></div><div class="section"><h2>Developer access</h2><p>Everyone can access the Subversion repository via HTTP, but Committers must checkout the Subversion repository via HTTPS.</p>
 <div class="source"><pre>$ svn checkout https://svn.apache.org/repos/asf/james/jsieve/trunk jsieve-project</pre></div><p>To commit changes to the repository, execute the following command to commit your changes (svn will prompt you for your password)</p><div class="source"><pre>$ svn commit --username your-username -m &quot;A message&quot;</pre></div></div><div class="section"><h2>Access from behind a firewall</h2><p>For those users who are stuck behind a corporate firewall which is blocking HTTP access to the Subversion repository, you can try to access it via the developer connection:</p><div class="source"><pre>$ svn checkout https://svn.apache.org/repos/asf/james/jsieve/trunk jsieve-project</pre></div></div><div class="section"><h2>Access through a proxy</h2><p>The Subversion client can go through a proxy, if you configure it to do so. First, edit your &quot;servers&quot; configuration file to indicate which proxy to use. The file's location depends on your operating sys
 tem. On Linux or Unix it is located in the directory &quot;~/.subversion&quot;. On Windows it is in &quot;%APPDATA%\Subversion&quot;. (Try &quot;echo %APPDATA%&quot;, note this is a hidden directory.)</p><p>There are comments in the file explaining what to do. If you don't have that file, get the latest Subversion client and run any command; this will cause the configuration directory and template files to be created.</p><p>Example: Edit the 'servers' file and add something like:</p><div class="source"><pre>[global]
+        <div class="section"><h2>Overview</h2>
+This project uses <a class="externalLink" href="http://subversion.tigris.org/">Subversion</a> to manage its source code. Instructions on Subversion use can be found at <a class="externalLink" href="http://svnbook.red-bean.com/">http://svnbook.red-bean.com/</a>.</div>
+<div class="section"><h2>Web Access</h2>
+<p>The following is a link to the online source repository.</p>
+<div class="source"><pre><a class="externalLink" href="http://svn.apache.org/viewcvs.cgi/james/jsieve/trunk/?root=Apache-SVN">http://svn.apache.org/viewcvs.cgi/james/jsieve/trunk/?root=Apache-SVN</a></pre>
+</div>
+</div>
+<div class="section"><h2>Anonymous access</h2>
+<p>The source can be checked out anonymously from SVN with this command:</p>
+<div class="source"><pre>$ svn checkout http://svn.apache.org/repos/asf/james/jsieve/trunk jsieve-project</pre>
+</div>
+</div>
+<div class="section"><h2>Developer access</h2>
+<p>Everyone can access the Subversion repository via HTTP, but Committers must checkout the Subversion repository via HTTPS.</p>
+<div class="source"><pre>$ svn checkout https://svn.apache.org/repos/asf/james/jsieve/trunk jsieve-project</pre>
+</div>
+<p>To commit changes to the repository, execute the following command to commit your changes (svn will prompt you for your password)</p>
+<div class="source"><pre>$ svn commit --username your-username -m &quot;A message&quot;</pre>
+</div>
+</div>
+<div class="section"><h2>Access from behind a firewall</h2>
+<p>For those users who are stuck behind a corporate firewall which is blocking HTTP access to the Subversion repository, you can try to access it via the developer connection:</p>
+<div class="source"><pre>$ svn checkout https://svn.apache.org/repos/asf/james/jsieve/trunk jsieve-project</pre>
+</div>
+</div>
+<div class="section"><h2>Access through a proxy</h2>
+<p>The Subversion client can go through a proxy, if you configure it to do so. First, edit your &quot;servers&quot; configuration file to indicate which proxy to use. The file's location depends on your operating system. On Linux or Unix it is located in the directory &quot;~/.subversion&quot;. On Windows it is in &quot;%APPDATA%\Subversion&quot;. (Try &quot;echo %APPDATA%&quot;, note this is a hidden directory.)</p>
+<p>There are comments in the file explaining what to do. If you don't have that file, get the latest Subversion client and run any command; this will cause the configuration directory and template files to be created.</p>
+<p>Example: Edit the 'servers' file and add something like:</p>
+<div class="source"><pre>[global]
 http-proxy-host = your.proxy.name
 http-proxy-port = 3128
-</pre></div></div>
+</pre>
+</div>
+</div>
+
       </div>
     </div>
     <div class="clear">

Modified: james/site/trunk/www/jsieve/team-list.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/team-list.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/team-list.html (original)
+++ james/site/trunk/www/jsieve/team-list.html Sat Sep  5 09:49:32 2009
@@ -18,11 +18,11 @@
       @import url("./css/site.css");
     </style>
     <link rel="stylesheet" href="./css/print.css" type="text/css" media="print" />
-        <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
+        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
       </head>
   <body class="composite">
     <div id="banner">
-                  <a href="http://james.apache.org/" id="bannerLeft">
+                  <a href="../" id="bannerLeft">
     
                                             <img src="images/james-jsieve-logo.gif" alt="" />
     
@@ -45,13 +45,13 @@
   
   
             <div class="xleft">
-        Last Published: 08/03/2009
+        Last Published: 09/05/2009
                       </div>
             <div class="xright">      <a href="../index.html">JAMES Project</a>
           |
           <a href="../imap/index.html">IMAP</a>
           |
-          <a href="../jsieve/index.html">JSieve</a>
+          <a href="index.html">JSieve</a>
           |
           <a href="../jspf/index.html">jSPF</a>
           |
@@ -89,46 +89,54 @@
         <ul>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/main/index.html">Main</a>
+              <a href="main/index.html">Main</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/mailet/index.html">Mailet</a>
+              <a href="mailet/index.html">Mailet</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/util/index.html">Util</a>
+              <a href="util/index.html">Util</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/jira-report.html">Changes</a>
+              <a href="jira-report.html">Changes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/release-notes.html">Release Notes</a>
+              <a href="release-notes.html">Release Notes</a>
         </li>
               
     <li class="none">
-              <a href="http://james.apache.org/jsieve/apidocs/index.html">JavaDocs</a>
+              <a href="apidocs/index.html">JavaDocs</a>
         </li>
           </ul>
           <h5>Specifications</h5>
         <ul>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 (ABNF)</a>
+              <a href="http://www.ietf.org/rfc/rfc2234.txt">RFC 2234 ABNF</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 (ACAP)</a>
+              <a href="http://www.ietf.org/rfc/rfc2244.txt">RFC 2244 ACAP</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 (MDN)</a>
+              <a href="http://www.ietf.org/rfc/rfc2298.txt">RFC 2298 MDN</a>
         </li>
               
     <li class="none">
-              <a href="http://www.ietf.org/rfc/rfc3028.txt">RFC 3028 (Sieve)</a>
+              <a href="http://tools.ietf.org/html/rfc5228">RFC 5228 Sieve</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc4790">RFC 4790 IAPCR</a>
+        </li>
+              
+    <li class="none">
+              <a href="http://tools.ietf.org/html/rfc5173">RFC 5173 Body Extension</a>
         </li>
           </ul>
           <h5>0.3 Release</h5>
@@ -233,7 +241,172 @@
     </div>
     <div id="bodyColumn">
       <div id="contentBox">
-        <div class="section"><h2>The Team</h2><p>A successful project requires many people to play many roles. Some members write code or documentation, while others are valuable as testers, submitting patches and suggestions.</p><p>The team is comprised of Members and Contributors. Members have direct access to the source of a project and actively evolve the code-base. Contributors improve the project through submission of patches and suggestions to the Members. The number of Contributors to the project is unbounded. Get involved today. All contributions to the project are greatly appreciated.</p><div class="section"><h3>Members</h3><p>The following is a list of developers with commit privileges that have directly contributed to the project in one way or another.</p><table class="bodyTable"><tr class="a"><th>Id</th><th>Name</th><th>Email</th><th>Organization</th><th>Roles</th><th>Time Zone</th><th>Actual Time (GMT)</th><th>Properties</th></tr><tr class="b"><td><a name="bago
 "></a>bago</td><td>Stefano Bagnara</td><td>bago at apache.org</td><td>-</td><td>Developer</td><td>2</td><td><span id="developer-0">2</span></td><td>-</td></tr><tr class="a"><td><a name="norman"></a>norman</td><td>Norman Maurer</td><td>norman at apache.org</td><td>-</td><td>Developer</td><td>2</td><td><span id="developer-1">2</span></td><td>-</td></tr><tr class="b"><td><a name="serge"></a>serge</td><td>Serge Knystautas</td><td>sergek at lokitech.com</td><td>-</td><td>Developer</td><td>-</td><td><span id="developer-2">-</span></td><td>-</td></tr><tr class="a"><td><a name="benrdf"></a>benrdf</td><td>Bernd Fondermann</td><td>bf_jak at brainlounge.de</td><td>-</td><td>Developer</td><td>-</td><td><span id="developer-3">-</span></td><td>-</td></tr><tr class="b"><td><a name="sbrewin"></a>sbrewin</td><td>Steve Brewin</td><td>sbrewin at synsys.com</td><td>-</td><td>Developer</td><td>-</td><td><span id="developer-4">-</span></td><td>-</td></tr><tr class="a"><td><a name="hilmer"></a>hil
 mer</td><td>Soren Hilmer</td><td>sh at widetrail.dk</td><td>-</td><td>Developer</td><td>-</td><td><span id="developer-5">-</span></td><td>-</td></tr><tr class="b"><td><a name="noel"></a>noel</td><td>Noel J. Bergman</td><td>noel at devtech.com</td><td>-</td><td>Developer</td><td>-</td><td><span id="developer-6">-</span></td><td>-</td></tr><tr class="a"><td><a name="danny"></a>danny</td><td>Danny Angus</td><td>danny at apache.org</td><td>-</td><td>Developer</td><td>-</td><td><span id="developer-7">-</span></td><td>-</td></tr><tr class="b"><td><a name="adc"></a>adc</td><td>Alan D. Cabrera</td><td>list at toolazydogs.com</td><td>-</td><td>Developer</td><td>-8</td><td><span id="developer-8">-8</span></td><td>-</td></tr><tr class="a"><td><a name="vincenzo"></a>vincenzo</td><td>Vincenzo Gianferrari Pini</td><td>vincenzo.gianferraripini at praxis.it</td><td>-</td><td>Developer</td><td>-</td><td><span id="developer-9">-</span></td><td>-</td></tr><tr class="b"><td><a name="rdonkin"></
 a>rdonkin</td><td>Robert Burrell Donkin</td><td>rdonkin at apache.org</td><td>-</td><td>Developer</td><td>-</td><td><span id="developer-10">-</span></td><td>-</td></tr><tr class="a"><td><a name="niklas"></a>niklas</td><td>Niklas Therning</td><td>niklas(at)apache(dot)org</td><td>Trillian AB</td><td>-</td><td>-</td><td><span id="developer-11">-</span></td><td>-</td></tr><tr class="b"><td><a name="jcheng"></a>jcheng</td><td>Joe Cheng</td><td>joe(at)joecheng(dot)com</td><td>-</td><td>-</td><td>-</td><td><span id="developer-12">-</span></td><td>description=Former author to the mime4j product</td></tr><tr class="a"><td><a name="mwiederkehr"></a>mwiederkehr</td><td>Markus Wiederkehr</td><td>mwiederkehr at apache.org</td><td>-</td><td>PMC Member</td><td>-</td><td><span id="developer-13">-</span></td><td>-</td></tr><tr class="b"><td><a name="olegk"></a>olegk</td><td>Oleg Kalnichevski</td><td>olegk at apache.org</td><td>-</td><td>PMC Member</td><td>-</td><td><span id="developer-14">-<
 /span></td><td>-</td></tr></table></div><div class="section"><h3>Contributors</h3><p>The following additional people have contributed to this project through the way of suggestions, patches or documentation.</p><table class="bodyTable"><tr class="a"><th>Name</th><th>Properties</th></tr><tr class="b"><td>Rob Oxspring</td><td>description=Contributed to the mime4j product</td></tr><tr class="a"><td>Roger Fullerton</td><td>description=Wrote spfjava, the first spf implementation in java</td></tr></table></div></div><script type="text/javascript">
+        <div class="section"><h2>The Team</h2>
+<p>A successful project requires many people to play many roles. Some members write code or documentation, while others are valuable as testers, submitting patches and suggestions.</p>
+<p>The team is comprised of Members and Contributors. Members have direct access to the source of a project and actively evolve the code-base. Contributors improve the project through submission of patches and suggestions to the Members. The number of Contributors to the project is unbounded. Get involved today. All contributions to the project are greatly appreciated.</p>
+<div class="section"><h3>Members</h3>
+<p>The following is a list of developers with commit privileges that have directly contributed to the project in one way or another.</p>
+<table class="bodyTable"><tr class="a"><th>Id</th>
+<th>Name</th>
+<th>Email</th>
+<th>Organization</th>
+<th>Roles</th>
+<th>Time Zone</th>
+<th>Actual Time (GMT)</th>
+<th>Properties</th>
+</tr>
+<tr class="b"><td><a name="bago"></a>bago</td>
+<td>Stefano Bagnara</td>
+<td>bago at apache.org</td>
+<td>-</td>
+<td>Developer</td>
+<td>2</td>
+<td><span id="developer-0">2</span></td>
+<td>-</td>
+</tr>
+<tr class="a"><td><a name="norman"></a>norman</td>
+<td>Norman Maurer</td>
+<td>norman at apache.org</td>
+<td>-</td>
+<td>Developer</td>
+<td>2</td>
+<td><span id="developer-1">2</span></td>
+<td>-</td>
+</tr>
+<tr class="b"><td><a name="serge"></a>serge</td>
+<td>Serge Knystautas</td>
+<td>sergek at lokitech.com</td>
+<td>-</td>
+<td>Developer</td>
+<td>-</td>
+<td><span id="developer-2">-</span></td>
+<td>-</td>
+</tr>
+<tr class="a"><td><a name="benrdf"></a>benrdf</td>
+<td>Bernd Fondermann</td>
+<td>bf_jak at brainlounge.de</td>
+<td>-</td>
+<td>Developer</td>
+<td>-</td>
+<td><span id="developer-3">-</span></td>
+<td>-</td>
+</tr>
+<tr class="b"><td><a name="sbrewin"></a>sbrewin</td>
+<td>Steve Brewin</td>
+<td>sbrewin at synsys.com</td>
+<td>-</td>
+<td>Developer</td>
+<td>-</td>
+<td><span id="developer-4">-</span></td>
+<td>-</td>
+</tr>
+<tr class="a"><td><a name="hilmer"></a>hilmer</td>
+<td>Soren Hilmer</td>
+<td>sh at widetrail.dk</td>
+<td>-</td>
+<td>Developer</td>
+<td>-</td>
+<td><span id="developer-5">-</span></td>
+<td>-</td>
+</tr>
+<tr class="b"><td><a name="noel"></a>noel</td>
+<td>Noel J. Bergman</td>
+<td>noel at devtech.com</td>
+<td>-</td>
+<td>Developer</td>
+<td>-</td>
+<td><span id="developer-6">-</span></td>
+<td>-</td>
+</tr>
+<tr class="a"><td><a name="danny"></a>danny</td>
+<td>Danny Angus</td>
+<td>danny at apache.org</td>
+<td>-</td>
+<td>Developer</td>
+<td>-</td>
+<td><span id="developer-7">-</span></td>
+<td>-</td>
+</tr>
+<tr class="b"><td><a name="adc"></a>adc</td>
+<td>Alan D. Cabrera</td>
+<td>list at toolazydogs.com</td>
+<td>-</td>
+<td>Developer</td>
+<td>-8</td>
+<td><span id="developer-8">-8</span></td>
+<td>-</td>
+</tr>
+<tr class="a"><td><a name="vincenzo"></a>vincenzo</td>
+<td>Vincenzo Gianferrari Pini</td>
+<td>vincenzo.gianferraripini at praxis.it</td>
+<td>-</td>
+<td>Developer</td>
+<td>-</td>
+<td><span id="developer-9">-</span></td>
+<td>-</td>
+</tr>
+<tr class="b"><td><a name="rdonkin"></a>rdonkin</td>
+<td>Robert Burrell Donkin</td>
+<td>rdonkin at apache.org</td>
+<td>-</td>
+<td>Developer</td>
+<td>-</td>
+<td><span id="developer-10">-</span></td>
+<td>-</td>
+</tr>
+<tr class="a"><td><a name="niklas"></a>niklas</td>
+<td>Niklas Therning</td>
+<td>niklas(at)apache(dot)org</td>
+<td>Trillian AB</td>
+<td>-</td>
+<td>-</td>
+<td><span id="developer-11">-</span></td>
+<td>-</td>
+</tr>
+<tr class="b"><td><a name="jcheng"></a>jcheng</td>
+<td>Joe Cheng</td>
+<td>joe(at)joecheng(dot)com</td>
+<td>-</td>
+<td>-</td>
+<td>-</td>
+<td><span id="developer-12">-</span></td>
+<td>description=Former author to the mime4j product</td>
+</tr>
+<tr class="a"><td><a name="mwiederkehr"></a>mwiederkehr</td>
+<td>Markus Wiederkehr</td>
+<td>mwiederkehr at apache.org</td>
+<td>-</td>
+<td>PMC Member</td>
+<td>-</td>
+<td><span id="developer-13">-</span></td>
+<td>-</td>
+</tr>
+<tr class="b"><td><a name="olegk"></a>olegk</td>
+<td>Oleg Kalnichevski</td>
+<td>olegk at apache.org</td>
+<td>-</td>
+<td>PMC Member</td>
+<td>-</td>
+<td><span id="developer-14">-</span></td>
+<td>-</td>
+</tr>
+</table>
+</div>
+<div class="section"><h3>Contributors</h3>
+<p>The following additional people have contributed to this project through the way of suggestions, patches or documentation.</p>
+<table class="bodyTable"><tr class="a"><th>Name</th>
+<th>Properties</th>
+</tr>
+<tr class="b"><td>Rob Oxspring</td>
+<td>description=Contributed to the mime4j product</td>
+</tr>
+<tr class="a"><td>Roger Fullerton</td>
+<td>description=Wrote spfjava, the first spf implementation in java</td>
+</tr>
+</table>
+</div>
+</div>
+<script type="text/javascript">
 function offsetDate(id, offset) {
     var now = new Date();
     var nowTime = now.getTime();

Modified: james/site/trunk/www/jsieve/testapidocs/allclasses-frame.html
URL: http://svn.apache.org/viewvc/james/site/trunk/www/jsieve/testapidocs/allclasses-frame.html?rev=811613&r1=811612&r2=811613&view=diff
==============================================================================
--- james/site/trunk/www/jsieve/testapidocs/allclasses-frame.html (original)
+++ james/site/trunk/www/jsieve/testapidocs/allclasses-frame.html Sat Sep  5 09:49:32 2009
@@ -2,7 +2,7 @@
 <!--NewPage-->
 <HTML>
 <HEAD>
-<!-- Generated by javadoc (build 1.5.0_18) on Mon Aug 03 17:10:15 BST 2009 -->
+<!-- Generated by javadoc (build 1.5.0_20) on Sat Sep 05 09:33:18 BST 2009 -->
 <META http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
 <TITLE>
 All Classes (Apache JAMES JSieve Project 0.4-SNAPSHOT Test API)
@@ -31,6 +31,8 @@
 <BR>
 <A HREF="org/apache/jsieve/AnyOfTest.html" title="class in org.apache.jsieve" target="classFrame">AnyOfTest</A>
 <BR>
+<A HREF="org/apache/jsieve/comparators/AsciiNumericTest.html" title="class in org.apache.jsieve.comparators" target="classFrame">AsciiNumericTest</A>
+<BR>
 <A HREF="org/apache/jsieve/BodyTest.html" title="class in org.apache.jsieve" target="classFrame">BodyTest</A>
 <BR>
 <A HREF="org/apache/jsieve/comparator/ComparatorUtilsTest.html" title="class in org.apache.jsieve.comparator" target="classFrame">ComparatorUtilsTest</A>
@@ -77,6 +79,8 @@
 <BR>
 <A HREF="org/apache/jsieve/RejectTest.html" title="class in org.apache.jsieve" target="classFrame">RejectTest</A>
 <BR>
+<A HREF="org/apache/jsieve/comparators/RequireComparatorTest.html" title="class in org.apache.jsieve.comparators" target="classFrame">RequireComparatorTest</A>
+<BR>
 <A HREF="org/apache/jsieve/RequireMissingTest.html" title="class in org.apache.jsieve" target="classFrame">RequireMissingTest</A>
 <BR>
 <A HREF="org/apache/jsieve/RequireTest.html" title="class in org.apache.jsieve" target="classFrame">RequireTest</A>