You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hive.apache.org by "László Bodor (Jira)" <ji...@apache.org> on 2023/12/01 08:12:00 UTC
[jira] [Updated] (HIVE-27925) HiveConf: unify ConfVars enum and use underscore for better readability
[ https://issues.apache.org/jira/browse/HIVE-27925?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
László Bodor updated HIVE-27925:
--------------------------------
Description: When I read something like "BASICSTATSTASKSMAXTHREADSFACTOR" I feel someone in the world laughs out loud thinking of me struggling. I can read it, but I hate it :) imagine what if we have vars like HIVE_MATERIALIZED_VIEW_ENABLE_AUTO_REWRITING_SUBQUERY_SQL without underscores. (was: When I read something like "BASICSTATSTASKSMAXTHREADSFACTOR" I feel someone in the world laughs out loud thinking of me struggling. I can read it, but I hate it :) image what if we have vars like HIVE_MATERIALIZED_VIEW_ENABLE_AUTO_REWRITING_SUBQUERY_SQL without underscores.)
> HiveConf: unify ConfVars enum and use underscore for better readability
> ------------------------------------------------------------------------
>
> Key: HIVE-27925
> URL: https://issues.apache.org/jira/browse/HIVE-27925
> Project: Hive
> Issue Type: Improvement
> Reporter: László Bodor
> Priority: Major
>
> When I read something like "BASICSTATSTASKSMAXTHREADSFACTOR" I feel someone in the world laughs out loud thinking of me struggling. I can read it, but I hate it :) imagine what if we have vars like HIVE_MATERIALIZED_VIEW_ENABLE_AUTO_REWRITING_SUBQUERY_SQL without underscores.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)