You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@giraph.apache.org by "Hudson (JIRA)" <ji...@apache.org> on 2015/01/28 19:49:34 UTC
[jira] [Commented] (GIRAPH-987) Improve naming for ReduceOperation
[ https://issues.apache.org/jira/browse/GIRAPH-987?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14295605#comment-14295605 ]
Hudson commented on GIRAPH-987:
-------------------------------
FAILURE: Integrated in Giraph-trunk-Commit #1523 (See [https://builds.apache.org/job/Giraph-trunk-Commit/1523/])
[GIRAPH-987] Improve naming for ReduceOperation (majakabiljo: http://git-wip-us.apache.org/repos/asf?p=giraph.git&a=commit&h=931569d5816a520a9f67844eca296e24140bd259)
* giraph-core/src/main/java/org/apache/giraph/comm/aggregators/OwnerAggregatorServerData.java
* giraph-core/src/main/java/org/apache/giraph/reducers/impl/OrReduce.java
* giraph-core/src/main/java/org/apache/giraph/master/AggregatorReduceOperation.java
* giraph-core/src/main/java/org/apache/giraph/reducers/Reducer.java
* giraph-core/src/main/java/org/apache/giraph/reducers/impl/SumReduce.java
* giraph-core/src/main/java/org/apache/giraph/master/MasterAggregatorHandler.java
* giraph-core/src/main/java/org/apache/giraph/reducers/ReduceSameTypeOperation.java
* giraph-core/src/main/java/org/apache/giraph/reducers/OnSameReduceOperation.java
* giraph-core/src/main/java/org/apache/giraph/reducers/impl/MaxReduce.java
* giraph-core/src/main/java/org/apache/giraph/worker/WorkerAggregatorHandler.java
* giraph-core/src/main/java/org/apache/giraph/worker/WorkerReduceUsage.java
* CHANGELOG
* giraph-core/src/main/java/org/apache/giraph/benchmark/ReducersBenchmark.java
* giraph-core/src/main/java/org/apache/giraph/worker/WorkerAggregatorDelegator.java
* giraph-core/src/main/java/org/apache/giraph/reducers/impl/MinReduce.java
* giraph-core/src/main/java/org/apache/giraph/reducers/ReduceOperation.java
* giraph-core/src/main/java/org/apache/giraph/reducers/impl/AndReduce.java
> Improve naming for ReduceOperation
> ----------------------------------
>
> Key: GIRAPH-987
> URL: https://issues.apache.org/jira/browse/GIRAPH-987
> Project: Giraph
> Issue Type: Improvement
> Reporter: Igor Kabiljo
> Priority: Minor
>
> reduceSingle/reducePartial can be slightly confusing.
> Also OnSameReduceOperation should be named better
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)