You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Doug Cutting (JIRA)" <ji...@apache.org> on 2008/03/03 22:46:50 UTC

[jira] Issue Comment Edited: (HADOOP-2926) Ignoring IOExceptions on close

    [ https://issues.apache.org/jira/browse/HADOOP-2926?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12574753#action_12574753 ] 

cutting edited comment on HADOOP-2926 at 3/3/08 1:46 PM:
--------------------------------------------------------------

The standard idiom for multiple streams, as mentioned above, is nested try blocks, e.g.:

{noformat}
OutputStream out1 = fs.open(...);
try {
  OutputStream out2 = fs.open(...);
  try {
    out1.write(...);
    out2.write(...);
  } finally {
    out2.close();
} finally {
  out1.close();
}
{noformat}


      was (Author: cutting):
    The standard idiom for multiple streams, as mentioned above, is nested try blocks, e.g.:

{noformat}
OutputStream out1 = fs.open(...);
try {
  OutputStream out2 = fs.open(...);
  try {
    out1.write(...);
    out2.write(...);
  } finally {
    out2.close();
  }
  out1.close();
}
{noformat}

  
> Ignoring IOExceptions on close
> ------------------------------
>
>                 Key: HADOOP-2926
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2926
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: dfs
>    Affects Versions: 0.16.0
>            Reporter: Owen O'Malley
>            Assignee: dhruba borthakur
>            Priority: Critical
>             Fix For: 0.16.1
>
>
> Currently in HDFS there are a lot of calls to IOUtils.closeStream that are from finally blocks. I'm worried that this can lead to data corruption in the file system. Take the first instance in DataNode.copyBlock: it writes the block and then calls closeStream on the output stream. If there is an error at the end of the file that is detected in the close, it will be *completely* ignored. Note that logging the error is not enough, the error should be thrown so that the client knows the failure happened.
> {code}
>    try {
>      file1.write(...);
>      file2.write(...);
>    } finally {
>       IOUtils.closeStream(file);
>   }
> {code}
> is *bad*. It must be rewritten as:
> {code}
>    try {
>      file1.write(...);
>      file2.write(...);
>      file1.close(...);
>      file2.close(...);
>    } catch (IOException ie) {
>      IOUtils.closeStream(file1);
>      IOUtils.closeStream(file2);
>      throw ie;
>    }
> {code}
> I also think that IOUtils.closeStream should be renamed IOUtils.cleanupFailedStream or something to make it clear it can only be used after the write operation has failed and is being cleaned up.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.