You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Dongjoon Hyun (Jira)" <ji...@apache.org> on 2025/11/28 22:16:00 UTC

[jira] [Assigned] (SPARK-54547) Use host instead of hostPort

     [ https://issues.apache.org/jira/browse/SPARK-54547?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dongjoon Hyun reassigned SPARK-54547:
-------------------------------------

    Assignee: duanshilong

> Use host instead of hostPort
> ----------------------------
>
>                 Key: SPARK-54547
>                 URL: https://issues.apache.org/jira/browse/SPARK-54547
>             Project: Spark
>          Issue Type: Bug
>          Components: Spark Core
>    Affects Versions: 4.0.0
>            Reporter: duanshilong
>            Assignee: duanshilong
>            Priority: Major
>              Labels: pull-request-available
>
> Rename hostPort to host because executorIdToHost stores only the hostname (or IP), not the host:port combination. This improves code clarity and prevents potential misuse.
> {code:scala}
> // TaskSchedulerImpl.resourceOffers
> executorIdToHost(o.executorId) = o.host
> {code}
> so, when we get host from executorIdToHost, we should us host instead of hostPort.
> {code:scala}
> // TaskSchedulerImpl.executorLost
> val hostPort = executorIdToHost(executorId)
> {code}



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org