You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Owen O'Malley (JIRA)" <ji...@apache.org> on 2006/11/07 09:52:53 UTC

[jira] Commented: (HADOOP-611) SequenceFile.Sorter should have a merge method that returns an iterator

    [ http://issues.apache.org/jira/browse/HADOOP-611?page=comments#action_12447719 ] 
            
Owen O'Malley commented on HADOOP-611:
--------------------------------------

1. The first change in SequenceFile is a spacing-only change.
2. lazyDecompress should be deleted instead of being commented out.
3. In a couple of places you go past 80 character lines making it hard to read.
4. Instead of:
+      private TreeMap <SequenceFile.Sorter.SegmentDescriptor,String>
+      sortedSegmentSizes =
+         new TreeMap <SequenceFile.Sorter.SegmentDescriptor,String>();
Use:
  private Map<SequenceFile.Sorter.SegmentDesriptor, String> 
       sortedSegmentSizes = new TreeMap();
5. Actually, since you don't use the value of the sortedSegmentSizes Map anywhere, some type like Void would probably be clearer about your intent.

> SequenceFile.Sorter should have a merge method that returns an iterator
> -----------------------------------------------------------------------
>
>                 Key: HADOOP-611
>                 URL: http://issues.apache.org/jira/browse/HADOOP-611
>             Project: Hadoop
>          Issue Type: New Feature
>          Components: io
>            Reporter: Owen O'Malley
>         Assigned To: Devaraj Das
>             Fix For: 0.9.0
>
>         Attachments: merge.patch, merge.patch
>
>
> SequenceFile.Sorter should get a new merge method that returns an iterator over the keys/values.
> The current merge method should become a simple method that gets the iterator and writes the records out to a file.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira