You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@ofbiz.apache.org by "Jacques Le Roux (JIRA)" <ji...@apache.org> on 2018/10/29 17:02:02 UTC

[jira] [Closed] (OFBIZ-7520) Minilang code readability and consistency improvements

     [ https://issues.apache.org/jira/browse/OFBIZ-7520?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jacques Le Roux closed OFBIZ-7520.
----------------------------------

Closing, thanks to Suraj for the reminder

> Minilang code readability and consistency improvements
> ------------------------------------------------------
>
>                 Key: OFBIZ-7520
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-7520
>             Project: OFBiz
>          Issue Type: Improvement
>          Components: ALL COMPONENTS
>    Affects Versions: 16.11.01
>            Reporter: Divesh Dutta
>            Assignee: Divesh Dutta
>            Priority: Major
>             Fix For: Upcoming Branch
>
>
> Code written in minilang is not consistent through out the application and some times its hard to read. For eg:
> {code}
> <set from-field="productFacility.minimumStock"  field="minimumStock"/>
> {code}
> should be written as :
> {code}
> <set  field="minimumStock" from-field="productFacility.minimumStock" />
> {code}
> There are many such examples where code for all such tags in minilang can be improved, which will improve code readability and we will have consistency through out the application. This is a parent/place holder ticket, I will create logical sub-tickets for managing the effort. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)