You are viewing a plain text version of this content. The canonical link for it is here.
Posted to mapreduce-issues@hadoop.apache.org by "Szilard Nemeth (JIRA)" <ji...@apache.org> on 2019/03/08 17:14:00 UTC

[jira] [Comment Edited] (MAPREDUCE-7190) Add SleepJob additional parameter to make parallel runs distinguishable

    [ https://issues.apache.org/jira/browse/MAPREDUCE-7190?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16788078#comment-16788078 ] 

Szilard Nemeth edited comment on MAPREDUCE-7190 at 3/8/19 5:13 PM:
-------------------------------------------------------------------

Thanks [~adam.antal] for this patch, this is quite valuable and nice work!

One comment: 
 For the new createJob method, can't you use SLEEP_JOB_NAME as the default name value instead of null? 
 Then in the other createJob method (that has String name as the last parameter), instead of the null and empty-string check, you could check that if the name not equals SLEEP_JOB_NAME, then you need to set the name with the SLEEP_JOB_NAME prefix: 
{code:java}
job.setJobName(SLEEP_JOB_NAME + " - " + name);{code}
I think this way, the code would be much cleaner.

Please fix the checkstyle issues and check if the UT failure is related.

Thanks!


was (Author: snemeth):
Thanks [~adam.antal] for this patch, this is quite valuable and nice work!

One comment: 
For the new createJob method, can't you use SLEEP_JOB_NAME as the default name value instead of null? 
Then in the other createJob method (that has String name as the last parameter), instead of the null and empty-string check, you could check that if the name not equals SLEEP_JOB_NAME, then you need to set the name with the SLEEP_JOB_NAME prefix: 
job.setJobName(SLEEP_JOB_NAME + " - " + name);

I think this way, the code would be much cleaner.

Please fix the checkstyle issues and check if the UT failure is related.

Thanks!

> Add SleepJob additional parameter to make parallel runs distinguishable
> -----------------------------------------------------------------------
>
>                 Key: MAPREDUCE-7190
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-7190
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>    Affects Versions: 3.2.0
>            Reporter: Adam Antal
>            Assignee: Adam Antal
>            Priority: Major
>         Attachments: MAPREDUCE-7190.001.patch
>
>
> InĀ ourĀ testing framework, we use SleepJobs for test scheduling and to check different resource types are assigned properly to containers. Sometimes we start multiple jobs in parallel, and if one fails, we have to track which one was that. It is not too hard to find out that information, but would have been much more convenient if it was written in the name of the job.
> Proposal: additional parameter to SleepJob, so that its name can be changed from default "Sleep job." to something like "Sleep job - _additional info_".



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: mapreduce-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: mapreduce-issues-help@hadoop.apache.org