You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@kudu.apache.org by "Alexey Serbin (Code Review)" <ge...@cloudera.org> on 2019/05/30 07:10:23 UTC

[kudu-CR] [util] extract libkudu nvm cache from libkudu util

Alexey Serbin has uploaded this change for review. ( http://gerrit.cloudera.org:8080/13468


Change subject: [util] extract libkudu_nvm_cache from libkudu_util
......................................................................

[util] extract libkudu_nvm_cache from libkudu_util

This patch extracts NVM/memkind-specific code from libkudu_util into
its own separate library: libkudu_nvm_cache.  The motivation for this
change is to avoid linking NVM-backed LRU/FIFO cache code and libmemkind
into libraries and binaries which do not use that functionality,
but use DRAM-backed LRU/FIFO cache only.

Follow-up changelists depend on this patch to introduce TTL cache
into DnsResolver.

Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
---
M src/kudu/cfile/CMakeLists.txt
M src/kudu/util/CMakeLists.txt
M src/kudu/util/cache.cc
M src/kudu/util/cache.h
M src/kudu/util/nvm_cache.cc
M src/kudu/util/nvm_cache.h
6 files changed, 48 insertions(+), 43 deletions(-)



  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/68/13468/1
-- 
To view, visit http://gerrit.cloudera.org:8080/13468
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: newchange
Gerrit-Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
Gerrit-Change-Number: 13468
Gerrit-PatchSet: 1
Gerrit-Owner: Alexey Serbin <as...@cloudera.com>

[kudu-CR] [util] extract libkudu nvm cache from libkudu util

Posted by "Adar Dembo (Code Review)" <ge...@cloudera.org>.
Adar Dembo has posted comments on this change. ( http://gerrit.cloudera.org:8080/13468 )

Change subject: [util] extract libkudu_nvm_cache from libkudu_util
......................................................................


Patch Set 2:

(1 comment)

http://gerrit.cloudera.org:8080/#/c/13468/2//COMMIT_MSG
Commit Message:

http://gerrit.cloudera.org:8080/#/c/13468/2//COMMIT_MSG@7
PS2, Line 7: libkudu_nvm_cache
Could we just call it libnvm_cache instead? The kudu prefix was helpful for util/ because "libutil" is just too generic to be useful.



-- 
To view, visit http://gerrit.cloudera.org:8080/13468
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
Gerrit-Change-Number: 13468
Gerrit-PatchSet: 2
Gerrit-Owner: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Comment-Date: Thu, 30 May 2019 23:52:09 +0000
Gerrit-HasComments: Yes

[kudu-CR] [util] extract libnvm cache from libkudu util

Posted by "Alexey Serbin (Code Review)" <ge...@cloudera.org>.
Alexey Serbin has submitted this change and it was merged. ( http://gerrit.cloudera.org:8080/13468 )

Change subject: [util] extract libnvm_cache from libkudu_util
......................................................................

[util] extract libnvm_cache from libkudu_util

This patch extracts NVM/memkind-specific code from libkudu_util into
its own separate library: libnvm_cache.  The motivation for this
change is to avoid linking NVM-backed LRU/FIFO cache code and libmemkind
into libraries and binaries which do not use that functionality,
but use DRAM-backed LRU/FIFO cache only.

A few follow-up changelists depend on this patch to introduce TTL cache
into DnsResolver.

Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
Reviewed-on: http://gerrit.cloudera.org:8080/13468
Tested-by: Kudu Jenkins
Reviewed-by: Adar Dembo <ad...@cloudera.com>
---
M src/kudu/cfile/CMakeLists.txt
M src/kudu/util/CMakeLists.txt
M src/kudu/util/cache.cc
M src/kudu/util/cache.h
M src/kudu/util/nvm_cache.cc
M src/kudu/util/nvm_cache.h
6 files changed, 48 insertions(+), 43 deletions(-)

Approvals:
  Kudu Jenkins: Verified
  Adar Dembo: Looks good to me, approved

-- 
To view, visit http://gerrit.cloudera.org:8080/13468
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: merged
Gerrit-Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
Gerrit-Change-Number: 13468
Gerrit-PatchSet: 4
Gerrit-Owner: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins (120)

[kudu-CR] [util] extract libnvm cache from libkudu util

Posted by "Alexey Serbin (Code Review)" <ge...@cloudera.org>.
Alexey Serbin has posted comments on this change. ( http://gerrit.cloudera.org:8080/13468 )

Change subject: [util] extract libnvm_cache from libkudu_util
......................................................................


Patch Set 2:

(1 comment)

http://gerrit.cloudera.org:8080/#/c/13468/2//COMMIT_MSG
Commit Message:

http://gerrit.cloudera.org:8080/#/c/13468/2//COMMIT_MSG@7
PS2, Line 7: libkudu_nvm_cache
> Could we just call it libnvm_cache instead? The kudu prefix was helpful for
Done



-- 
To view, visit http://gerrit.cloudera.org:8080/13468
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
Gerrit-Change-Number: 13468
Gerrit-PatchSet: 2
Gerrit-Owner: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Comment-Date: Fri, 31 May 2019 01:53:46 +0000
Gerrit-HasComments: Yes

[kudu-CR] [util] extract libkudu nvm cache from libkudu util

Posted by "Alexey Serbin (Code Review)" <ge...@cloudera.org>.
Alexey Serbin has posted comments on this change. ( http://gerrit.cloudera.org:8080/13468 )

Change subject: [util] extract libkudu_nvm_cache from libkudu_util
......................................................................


Patch Set 1: Verified+1

unrelated flakes in:
  * mvcc-test.0
  * org.apache.kudu.client.TestRowResult
  * org.apache.kudu.flume.sink.SecureKuduSinkTest
  * org.apache.kudu.client.TestKuduScanner


-- 
To view, visit http://gerrit.cloudera.org:8080/13468
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
Gerrit-Change-Number: 13468
Gerrit-PatchSet: 1
Gerrit-Owner: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Comment-Date: Thu, 30 May 2019 08:19:03 +0000
Gerrit-HasComments: No

[kudu-CR] [util] extract libnvm cache from libkudu util

Posted by "Alexey Serbin (Code Review)" <ge...@cloudera.org>.
Hello Kudu Jenkins, Adar Dembo, 

I'd like you to reexamine a change. Please visit

    http://gerrit.cloudera.org:8080/13468

to look at the new patch set (#3).

Change subject: [util] extract libnvm_cache from libkudu_util
......................................................................

[util] extract libnvm_cache from libkudu_util

This patch extracts NVM/memkind-specific code from libkudu_util into
its own separate library: libnvm_cache.  The motivation for this
change is to avoid linking NVM-backed LRU/FIFO cache code and libmemkind
into libraries and binaries which do not use that functionality,
but use DRAM-backed LRU/FIFO cache only.

A few follow-up changelists depend on this patch to introduce TTL cache
into DnsResolver.

Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
---
M src/kudu/cfile/CMakeLists.txt
M src/kudu/util/CMakeLists.txt
M src/kudu/util/cache.cc
M src/kudu/util/cache.h
M src/kudu/util/nvm_cache.cc
M src/kudu/util/nvm_cache.h
6 files changed, 48 insertions(+), 43 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/68/13468/3
-- 
To view, visit http://gerrit.cloudera.org:8080/13468
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: newpatchset
Gerrit-Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
Gerrit-Change-Number: 13468
Gerrit-PatchSet: 3
Gerrit-Owner: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins (120)

[kudu-CR] [util] extract libnvm cache from libkudu util

Posted by "Adar Dembo (Code Review)" <ge...@cloudera.org>.
Adar Dembo has posted comments on this change. ( http://gerrit.cloudera.org:8080/13468 )

Change subject: [util] extract libnvm_cache from libkudu_util
......................................................................


Patch Set 3: Code-Review+2


-- 
To view, visit http://gerrit.cloudera.org:8080/13468
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
Gerrit-Change-Number: 13468
Gerrit-PatchSet: 3
Gerrit-Owner: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Adar Dembo <ad...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Comment-Date: Fri, 31 May 2019 04:24:23 +0000
Gerrit-HasComments: No

[kudu-CR] [util] extract libkudu nvm cache from libkudu util

Posted by "Alexey Serbin (Code Review)" <ge...@cloudera.org>.
Alexey Serbin has removed Kudu Jenkins from this change.  ( http://gerrit.cloudera.org:8080/13468 )

Change subject: [util] extract libkudu_nvm_cache from libkudu_util
......................................................................


Removed reviewer Kudu Jenkins with the following votes:

* Verified-1 by Kudu Jenkins (120)
-- 
To view, visit http://gerrit.cloudera.org:8080/13468
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: deleteReviewer
Gerrit-Change-Id: Ibafea70676f7be9c086f9f195ab215cfff0719fe
Gerrit-Change-Number: 13468
Gerrit-PatchSet: 1
Gerrit-Owner: Alexey Serbin <as...@cloudera.com>