You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Siddharth Ahuja (Jira)" <ji...@apache.org> on 2019/12/23 23:13:00 UTC
[jira] [Assigned] (YARN-9998) Code cleanup in
LeveldbConfigurationStore
[ https://issues.apache.org/jira/browse/YARN-9998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Siddharth Ahuja reassigned YARN-9998:
-------------------------------------
Assignee: Siddharth Ahuja (was: Szilard Nemeth)
> Code cleanup in LeveldbConfigurationStore
> -----------------------------------------
>
> Key: YARN-9998
> URL: https://issues.apache.org/jira/browse/YARN-9998
> Project: Hadoop YARN
> Issue Type: Improvement
> Reporter: Szilard Nemeth
> Assignee: Siddharth Ahuja
> Priority: Minor
>
> Many things can be improved:
> * Field compactionTimer could be a local variable
> * Field versiondb should be camelcase
> * initDatabase is a very long method: Initialize db / versionDb should be in separate methods, split this method into smaller chunks
> * Remove TODOs
> * Remove duplicated code block in LeveldbConfigurationStore.CompactionTimerTask
> * Any other cleanup
--
This message was sent by Atlassian Jira
(v8.3.4#803005)
---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org