You are viewing a plain text version of this content. The canonical link for it is here.
Posted to java-user@axis.apache.org by Andrew Whelan <aw...@syrres.com> on 2005/12/16 19:55:37 UTC

WSDL2Java _PortType issue

I am in the process of trying to upgrade from Axis 1.1 to Axis 1.3 and have
run into an issue with the WSDL2Java functionality.

 

It seems that there is some unnecessary name collision functionality being
fired off that was happening before. The interface name of the port type
interface that is generated now is being generated with a _PortType
extension. There is no class name collision so this shouldn't be happening. 

 

1)Has anyone else experienced this?

 

2)Is this a known bug? If so I'm having trouble locating it in the axis bug
tracking site. It may be a REAL old one that I'm just not finding?

3

)Is there a convenient way to turn this off without having to force it off
by using the -N namespace mapping option?(this seems to be causing other
problems). We were just using the -p option and we had one package name for
this generated client code and  this worked fine with axis 1.1.



Re: WSDL2Java _PortType issue

Posted by Dies Koper <di...@jp.fujitsu.com>.
Hello Andrew,

I was just looking into that last night.

This is what I found:

1. WSDL generated by Axis' Java2WSDL uses the SEI class name for both 
the portType name and the port name

2. The JAX-RPC 1.1 spec has name collision rules, saying that when the 
binding name and the portType name are the same, "_PortType" should be 
appended to the generated SEI name (section 4.3.12)

3. When the portType name and the port name are the same, Axis applies 
the name collision rule in 2. and appends "_PortType" to the generated 
SEI name

4. All WSDL examples in the JAX-RPC 1.1, WSDL 1.1, WS-I BP1.0 
specifications use <SEI name> + "Port" for the port names.

I think that the name collision detection processing might be looking at 
the wrong elements in Axis (portType name and port name instead of 
portType name and binding name).
I also wonder why Axis generates different port names than the examples 
in the specification. I could not find anything in the specs mandating 
what they should be called so this does not have to be a bug.
#I only looked at Axis 1.3

This is a long answer to your first question. I hope someone will answer 
the other two.

Regards,
Dies


Andrew Whelan wrote:
> I am in the process of trying to upgrade from Axis 1.1 to Axis 1.3 and have
> run into an issue with the WSDL2Java functionality.
> 
>  
> 
> It seems that there is some unnecessary name collision functionality being
> fired off that was happening before. The interface name of the port type
> interface that is generated now is being generated with a _PortType
> extension. There is no class name collision so this shouldn't be happening. 
> 
>  
> 
> 1)Has anyone else experienced this?
> 
>  
> 
> 2)Is this a known bug? If so I'm having trouble locating it in the axis bug
> tracking site. It may be a REAL old one that I'm just not finding?
> 
> 3
> 
> )Is there a convenient way to turn this off without having to force it off
> by using the -N namespace mapping option?(this seems to be causing other
> problems). We were just using the -p option and we had one package name for
> this generated client code and  this worked fine with axis 1.1.
> 
> 
>