You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@commons.apache.org by gg...@apache.org on 2024/06/16 23:02:29 UTC

(commons-net) 04/11: Javadoc

This is an automated email from the ASF dual-hosted git repository.

ggregory pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-net.git

commit 93097d065e704c17d9434bf4506da0ee7516b484
Author: Gary Gregory <ga...@gmail.com>
AuthorDate: Sun Jun 16 18:25:55 2024 -0400

    Javadoc
---
 .../commons/net/examples/telnet/TelnetClientExample.java |  4 ++--
 .../commons/net/examples/telnet/WeatherTelnet.java       |  4 ++--
 .../org/apache/commons/net/telnet/EchoOptionHandler.java |  2 +-
 .../commons/net/telnet/SuppressGAOptionHandler.java      |  2 +-
 src/main/java/org/apache/commons/net/telnet/Telnet.java  |  4 ++--
 .../java/org/apache/commons/net/telnet/TelnetClient.java | 16 ++++++++--------
 .../org/apache/commons/net/telnet/TelnetCommand.java     |  8 ++++----
 .../org/apache/commons/net/telnet/TelnetInputStream.java |  4 ++--
 .../commons/net/telnet/TelnetNotificationHandler.java    |  2 +-
 .../java/org/apache/commons/net/telnet/TelnetOption.java |  8 ++++----
 .../apache/commons/net/telnet/TelnetOptionHandler.java   |  2 +-
 .../commons/net/telnet/TerminalTypeOptionHandler.java    |  2 +-
 .../commons/net/telnet/WindowSizeOptionHandler.java      |  2 +-
 13 files changed, 30 insertions(+), 30 deletions(-)

diff --git a/src/main/java/org/apache/commons/net/examples/telnet/TelnetClientExample.java b/src/main/java/org/apache/commons/net/examples/telnet/TelnetClientExample.java
index f160e7f9..41f60931 100644
--- a/src/main/java/org/apache/commons/net/examples/telnet/TelnetClientExample.java
+++ b/src/main/java/org/apache/commons/net/examples/telnet/TelnetClientExample.java
@@ -95,7 +95,7 @@ public class TelnetClientExample implements Runnable, TelnetNotificationHandler
                 final Thread reader = new Thread(new TelnetClientExample());
                 tc.registerNotifHandler(new TelnetClientExample());
                 System.out.println("TelnetClientExample");
-                System.out.println("Type AYT to send an AYT telnet command");
+                System.out.println("Type AYT to send an AYT Telnet command");
                 System.out.println("Type OPT to print a report of status of options (0-24)");
                 System.out.println("Type REGISTER to register a new SimpleOptionHandler");
                 System.out.println("Type UNREGISTER to unregister an OptionHandler");
@@ -260,7 +260,7 @@ public class TelnetClientExample implements Runnable, TelnetNotificationHandler
         try {
             tc.disconnect();
         } catch (final IOException e) {
-            System.err.println("Exception while closing telnet:" + e.getMessage());
+            System.err.println("Exception while closing Telnet:" + e.getMessage());
         }
     }
 }
diff --git a/src/main/java/org/apache/commons/net/examples/telnet/WeatherTelnet.java b/src/main/java/org/apache/commons/net/examples/telnet/WeatherTelnet.java
index ee297e59..d4c89bbd 100644
--- a/src/main/java/org/apache/commons/net/examples/telnet/WeatherTelnet.java
+++ b/src/main/java/org/apache/commons/net/examples/telnet/WeatherTelnet.java
@@ -24,9 +24,9 @@ import org.apache.commons.net.telnet.TelnetClient;
 
 /**
  * This is an example of a trivial use of the TelnetClient class. It connects to the weather server at the University of Michigan, um-weather.sprl.umich.edu
- * port 3000, and allows the user to interact with the server via standard input. You could use this example to connect to any telnet server, but it is
+ * port 3000, and allows the user to interact with the server via standard input. You could use this example to connect to any Telnet server, but it is
  * obviously not general purpose because it reads from standard input a line at a time, making it inconvenient for use with a remote interactive shell. The
- * TelnetClient class used by itself is mostly intended for automating access to telnet resources rather than interactive use.
+ * TelnetClient class used by itself is mostly intended for automating access to Telnet resources rather than interactive use.
  */
 
 // This class requires the IOUtil support class!
diff --git a/src/main/java/org/apache/commons/net/telnet/EchoOptionHandler.java b/src/main/java/org/apache/commons/net/telnet/EchoOptionHandler.java
index 5364cb41..80571d61 100644
--- a/src/main/java/org/apache/commons/net/telnet/EchoOptionHandler.java
+++ b/src/main/java/org/apache/commons/net/telnet/EchoOptionHandler.java
@@ -18,7 +18,7 @@
 package org.apache.commons.net.telnet;
 
 /**
- * Implements the telnet echo option RFC 857.
+ * Implements the Telnet echo option RFC 857.
  */
 public class EchoOptionHandler extends TelnetOptionHandler {
     /**
diff --git a/src/main/java/org/apache/commons/net/telnet/SuppressGAOptionHandler.java b/src/main/java/org/apache/commons/net/telnet/SuppressGAOptionHandler.java
index 7e20fc42..2678e761 100644
--- a/src/main/java/org/apache/commons/net/telnet/SuppressGAOptionHandler.java
+++ b/src/main/java/org/apache/commons/net/telnet/SuppressGAOptionHandler.java
@@ -18,7 +18,7 @@
 package org.apache.commons.net.telnet;
 
 /**
- * Implements the telnet suppress go ahead option RFC 858.
+ * Implements the Telnet suppress go ahead option RFC 858.
  */
 public class SuppressGAOptionHandler extends TelnetOptionHandler {
     /**
diff --git a/src/main/java/org/apache/commons/net/telnet/Telnet.java b/src/main/java/org/apache/commons/net/telnet/Telnet.java
index 5041cb94..ba4eb0c1 100644
--- a/src/main/java/org/apache/commons/net/telnet/Telnet.java
+++ b/src/main/java/org/apache/commons/net/telnet/Telnet.java
@@ -276,7 +276,7 @@ class Telnet extends SocketClient {
     }
 
     /**
-     * Registers a new TelnetOptionHandler for this telnet to use.
+     * Registers a new TelnetOptionHandler for this Telnet to use.
      *
      * @param opthand   option handler to be registered.
      * @throws InvalidTelnetOptionException - The option code is invalid.
@@ -592,7 +592,7 @@ class Telnet extends SocketClient {
     }
 
     /**
-     * Registers a notification handler to which will be sent notifications of received telnet option negotiation commands.
+     * Registers a notification handler to which will be sent notifications of received Telnet option negotiation commands.
      *
      * @param notifhand   TelnetNotificationHandler to be registered
      */
diff --git a/src/main/java/org/apache/commons/net/telnet/TelnetClient.java b/src/main/java/org/apache/commons/net/telnet/TelnetClient.java
index 61b87476..af3d793a 100644
--- a/src/main/java/org/apache/commons/net/telnet/TelnetClient.java
+++ b/src/main/java/org/apache/commons/net/telnet/TelnetClient.java
@@ -105,7 +105,7 @@ public class TelnetClient extends Telnet {
     }
 
     /**
-     * Registers a new TelnetOptionHandler for this telnet client to use.
+     * Registers a new TelnetOptionHandler for this Telnet client to use.
      *
      * @param opthand   option handler to be registered.
      *
@@ -143,8 +143,8 @@ public class TelnetClient extends Telnet {
     }
 
     /**
-     * Disconnects the telnet session, closing the input and output streams as well as the socket. If you have references to the input and output streams of the
-     * telnet connection, you should not close them yourself, but rather call disconnect to properly close the connection.
+     * Disconnects the Telnet session, closing the input and output streams as well as the socket. If you have references to the input and output streams of the
+     * Telnet connection, you should not close them yourself, but rather call disconnect to properly close the connection.
      */
     @Override
     public void disconnect() throws IOException {
@@ -170,10 +170,10 @@ public class TelnetClient extends Telnet {
     }
 
     /**
-     * Returns the telnet connection input stream. You should not close the stream when you finish with it. Rather, you should call {@link #disconnect
+     * Returns the Telnet connection input stream. You should not close the stream when you finish with it. Rather, you should call {@link #disconnect
      * disconnect }.
      *
-     * @return The telnet connection input stream.
+     * @return The Telnet connection input stream.
      */
     public InputStream getInputStream() {
         return input;
@@ -195,10 +195,10 @@ public class TelnetClient extends Telnet {
     /* Code Section added for supporting AYT (start) */
 
     /**
-     * Returns the telnet connection output stream. You should not close the stream when you finish with it. Rather, you should call {@link #disconnect
+     * Returns the Telnet connection output stream. You should not close the stream when you finish with it. Rather, you should call {@link #disconnect
      * disconnect }.
      *
-     * @return The telnet connection output stream.
+     * @return The Telnet connection output stream.
      */
     public OutputStream getOutputStream() {
         return output;
@@ -324,7 +324,7 @@ public class TelnetClient extends Telnet {
 
     /**
      * Sends a protocol-specific subnegotiation message to the remote peer. {@link TelnetClient} will add the IAC SB &amp; IAC SE framing bytes; the first byte
-     * in {@code message} should be the appropriate telnet option code.
+     * in {@code message} should be the appropriate Telnet option code.
      *
      * <p>
      * This method does not wait for any response. Subnegotiation messages sent by the remote end can be handled by registering an approrpriate
diff --git a/src/main/java/org/apache/commons/net/telnet/TelnetCommand.java b/src/main/java/org/apache/commons/net/telnet/TelnetCommand.java
index d86d540c..2b5b11ee 100644
--- a/src/main/java/org/apache/commons/net/telnet/TelnetCommand.java
+++ b/src/main/java/org/apache/commons/net/telnet/TelnetCommand.java
@@ -18,7 +18,7 @@
 package org.apache.commons.net.telnet;
 
 /**
- * The TelnetCommand class cannot be instantiated and only serves as a storehouse for telnet command constants.
+ * The TelnetCommand class cannot be instantiated and only serves as a storehouse for Telnet command constants.
  *
  * @see org.apache.commons.net.telnet.Telnet
  * @see org.apache.commons.net.telnet.TelnetClient
@@ -99,10 +99,10 @@ public final class TelnetCommand {
     private static final int LAST_COMMAND = EOF;
 
     /**
-     * Returns the string representation of the telnet protocol command corresponding to the given command code.
+     * Returns the string representation of the Telnet protocol command corresponding to the given command code.
      *
-     * @param code The command code of the telnet protocol command.
-     * @return The string representation of the telnet protocol command.
+     * @param code The command code of the Telnet protocol command.
+     * @return The string representation of the Telnet protocol command.
      */
     public static String getCommand(final int code) {
         return commandString[FIRST_COMMAND - code];
diff --git a/src/main/java/org/apache/commons/net/telnet/TelnetInputStream.java b/src/main/java/org/apache/commons/net/telnet/TelnetInputStream.java
index 372e66a5..ad478976 100644
--- a/src/main/java/org/apache/commons/net/telnet/TelnetInputStream.java
+++ b/src/main/java/org/apache/commons/net/telnet/TelnetInputStream.java
@@ -117,7 +117,7 @@ final class TelnetInputStream extends BufferedInputStream implements Runnable {
     }
 
     // synchronized(client) critical sections are to protect against
-    // TelnetOutputStream writing through the telnet client at same time
+    // TelnetOutputStream writing through the Telnet client at same time
     // as a processDo/Will/etc. command invoked from TelnetInputStream
     // tries to write. Returns true if buffer was previously empty.
     private boolean processChar(final int ch) throws InterruptedException {
@@ -256,7 +256,7 @@ final class TelnetInputStream extends BufferedInputStream implements Runnable {
     }
 
     // synchronized(client) critical sections are to protect against
-    // TelnetOutputStream writing through the telnet client at same time
+    // TelnetOutputStream writing through the Telnet client at same time
     // as a processDo/Will/etc. command invoked from TelnetInputStream
     // tries to write.
     /**
diff --git a/src/main/java/org/apache/commons/net/telnet/TelnetNotificationHandler.java b/src/main/java/org/apache/commons/net/telnet/TelnetNotificationHandler.java
index 6827b823..364a78f7 100644
--- a/src/main/java/org/apache/commons/net/telnet/TelnetNotificationHandler.java
+++ b/src/main/java/org/apache/commons/net/telnet/TelnetNotificationHandler.java
@@ -18,7 +18,7 @@
 package org.apache.commons.net.telnet;
 
 /**
- * The TelnetNotificationHandler interface can be used to handle notification of options negotiation commands received on a telnet session.
+ * The TelnetNotificationHandler interface can be used to handle notification of options negotiation commands received on a Telnet session.
  * <p>
  * The user can implement this interface and register a TelnetNotificationHandler by using the registerNotificationHandler() of TelnetClient to be notified of
  * option negotiation commands.
diff --git a/src/main/java/org/apache/commons/net/telnet/TelnetOption.java b/src/main/java/org/apache/commons/net/telnet/TelnetOption.java
index 396c9048..a3922404 100644
--- a/src/main/java/org/apache/commons/net/telnet/TelnetOption.java
+++ b/src/main/java/org/apache/commons/net/telnet/TelnetOption.java
@@ -18,7 +18,7 @@
 package org.apache.commons.net.telnet;
 
 /**
- * The TelnetOption class cannot be instantiated and only serves as a storehouse for telnet option constants.
+ * The TelnetOption class cannot be instantiated and only serves as a storehouse for Telnet option constants.
  * <p>
  * Details regarding Telnet option specification can be found in RFC 855.
  * </p>
@@ -262,10 +262,10 @@ public class TelnetOption {
             "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "", "Extended-Options-List" };
 
     /**
-     * Returns the string representation of the telnet protocol option corresponding to the given option code.
+     * Returns the string representation of the Telnet protocol option corresponding to the given option code.
      *
-     * @param code The option code of the telnet protocol option
-     * @return The string representation of the telnet protocol option.
+     * @param code The option code of the Telnet protocol option
+     * @return The string representation of the Telnet protocol option.
      */
     public static final String getOption(final int code) {
         if (optionString[code].isEmpty()) {
diff --git a/src/main/java/org/apache/commons/net/telnet/TelnetOptionHandler.java b/src/main/java/org/apache/commons/net/telnet/TelnetOptionHandler.java
index 13cb0227..f02dbbf5 100644
--- a/src/main/java/org/apache/commons/net/telnet/TelnetOptionHandler.java
+++ b/src/main/java/org/apache/commons/net/telnet/TelnetOptionHandler.java
@@ -18,7 +18,7 @@
 package org.apache.commons.net.telnet;
 
 /**
- * The TelnetOptionHandler class is the base class to be used for implementing handlers for telnet options.
+ * The TelnetOptionHandler class is the base class to be used for implementing handlers for Telnet options.
  * <p>
  * TelnetOptionHandler implements basic option handling functionality and defines abstract methods that must be implemented to define subnegotiation behavior.
  * </p>
diff --git a/src/main/java/org/apache/commons/net/telnet/TerminalTypeOptionHandler.java b/src/main/java/org/apache/commons/net/telnet/TerminalTypeOptionHandler.java
index 88eccfb9..9a31c87f 100644
--- a/src/main/java/org/apache/commons/net/telnet/TerminalTypeOptionHandler.java
+++ b/src/main/java/org/apache/commons/net/telnet/TerminalTypeOptionHandler.java
@@ -18,7 +18,7 @@
 package org.apache.commons.net.telnet;
 
 /**
- * Implements the telnet terminal type option RFC 1091.
+ * Implements the Telnet terminal type option RFC 1091.
  */
 public class TerminalTypeOptionHandler extends TelnetOptionHandler {
     /**
diff --git a/src/main/java/org/apache/commons/net/telnet/WindowSizeOptionHandler.java b/src/main/java/org/apache/commons/net/telnet/WindowSizeOptionHandler.java
index c4f80ae4..1f5353ad 100644
--- a/src/main/java/org/apache/commons/net/telnet/WindowSizeOptionHandler.java
+++ b/src/main/java/org/apache/commons/net/telnet/WindowSizeOptionHandler.java
@@ -18,7 +18,7 @@
 package org.apache.commons.net.telnet;
 
 /**
- * Implements the telnet window size option RFC 1073.
+ * Implements the Telnet window size option RFC 1073.
  *
  * @since 2.0
  */