You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Mark Miller (JIRA)" <ji...@apache.org> on 2010/09/12 13:35:32 UTC
[jira] Commented: (SOLR-2118)
IndexReaderFactory.setTermIndexInterval is misleading and confusing
[ https://issues.apache.org/jira/browse/SOLR-2118?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12908445#action_12908445 ]
Mark Miller commented on SOLR-2118:
-----------------------------------
Setting the divisor that way shouldn't likely work on trunk anymore, since Lucene dropped it. That is just a generic 'call this bean method' system.
I think the story is that the interval came first, but we don't specify indexwriter anywhere in solrconfig, so it made sense to go where it is perhaps - and then later this generic system to call setters was impl'd, and it just happens that for a little while you could use it to set the termIndexInterval.
I'm all for consistency if it possible though. So far, Solr has really avoided exposing an IndexWriter - it's not even part of the UpdateHandler interface. We have hacked around that here and there by exposing in DirectUpdateHandler2 and counting on that impl for certain functionality.
> IndexReaderFactory.setTermIndexInterval is misleading and confusing
> -------------------------------------------------------------------
>
> Key: SOLR-2118
> URL: https://issues.apache.org/jira/browse/SOLR-2118
> Project: Solr
> Issue Type: Improvement
> Components: search
> Affects Versions: 1.4
> Reporter: Robert Muir
> Fix For: 3.1, 4.0
>
>
> To change the terms index divisor: you currently do this:
> {noformat}
> <indexReaderFactory name="IndexReaderFactory" class="org.apache.solr.core.StandardIndexReaderFactory">
> <int name="setTermIndexInterval">12</int>
> </indexReaderFactory >
> {noformat}
> But to change the terms index interval, you do this:
> {noformat}
> <indexDefaults>
> ...
> <termIndexInterval>256</termIndexInterval>
> ...
> </indexDefaults>
> {noformat}
> I feel the IR parameter should be *setTermIndexDivisor* or similar instead:
> the name is very misleading and someone could easily put a terrible value
> in the wrong place by confusing the two.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org