You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Hyrum K Wright <hy...@wandisco.com> on 2012/05/25 18:06:41 UTC

Re: svn commit: r1342682 - /subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp

Is this change specific to the branch, or is is beneficial for general
JavaHL use?  If the latter, it should be committed to trunk first,
then backported to the branch.

I realize you don't (yet) have commit privileges to trunk.  The way
this would usually work is that you'd post the patch, somebody would
either apply it to trunk, or just ask you to apply it, and you'd
reference that approval in the commit message.

-Hyrum

On Fri, May 25, 2012 at 10:19 AM,  <vm...@apache.org> wrote:
> Author: vmpn
> Date: Fri May 25 15:19:21 2012
> New Revision: 1342682
>
> URL: http://svn.apache.org/viewvc?rev=1342682&view=rev
> Log:
> JavaHL: Changed return value from the java svn_stream_t read function to be compatible with the txdelta_next_window function
>
> [ in subversion/bindings/javahl/native ]
>
> * InputStream.cpp
>  (read): Return 0 instead of -1 as expected by the txdelta_next_window function
>
> Modified:
>    subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
>
> Modified: subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
> URL: http://svn.apache.org/viewvc/subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp?rev=1342682&r1=1342681&r2=1342682&view=diff
> ==============================================================================
> --- subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp (original)
> +++ subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp Fri May 25 15:19:21 2012
> @@ -99,6 +99,14 @@ svn_error_t *InputStream::read(void *bat
>   if (JNIUtil::isJavaExceptionThrown())
>     return SVN_NO_ERROR;
>
> +  /*
> +   * Convert -1 from InputStream.read that means EOF, 0 which is subversion equivalent
> +   */
> +  if(jread == -1)
> +    {
> +      jread = 0;
> +    }
> +
>   // Put the Java byte array into a helper object to retrieve the
>   // data bytes.
>   JNIByteArray outdata(data, true);
> @@ -107,7 +115,7 @@ svn_error_t *InputStream::read(void *bat
>
>   // Catch when the Java method tells us it read too much data.
>   if (jread > (jint) *len)
> -    jread = -1;
> +    jread = 0;
>
>   // In the case of success copy the data back to the Subversion
>   // buffer.
>
>



-- 

uberSVN: Apache Subversion Made Easy
http://www.uberSVN.com/

Re: svn commit: r1342682 - /subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp

Posted by Vladimir Berezniker <vm...@hitechman.com>.
Thank you. Please ignore the other email on this subject, I sent it before
I saw  your reply.

Vladimir

On Fri, May 25, 2012 at 12:43 PM, Hyrum K Wright
<hy...@wandisco.com>wrote:

> Thanks for begin willing to work within the guidelines of the project.
>  I understand that sometimes they may seem somewhat arbitrary, but
> they've grown out of a decade of experience.  While they may at first
> appear to increase friction, they generally work out to improve the
> efficiency of the project as a whole.
>
> As for this particular fix, I'll go ahead and cherrypick merge it back
> to trunk.  Thanks again for the patches!
>
> -Hyrum
>
> On Fri, May 25, 2012 at 11:39 AM, Vladimir Berezniker
> <vm...@hitechman.com> wrote:
> > As this change plus another one are beneficial for general JavaHL use, I
> > will send them as patches on separate threads.
> >
> > Thank you for the guidance,
> >
> > Vladimir
> >
> >
> > On Fri, May 25, 2012 at 12:06 PM, Hyrum K Wright <
> hyrum.wright@wandisco.com>
> > wrote:
> >>
> >> Is this change specific to the branch, or is is beneficial for general
> >> JavaHL use?  If the latter, it should be committed to trunk first,
> >> then backported to the branch.
> >>
> >> I realize you don't (yet) have commit privileges to trunk.  The way
> >> this would usually work is that you'd post the patch, somebody would
> >> either apply it to trunk, or just ask you to apply it, and you'd
> >> reference that approval in the commit message.
> >>
> >> -Hyrum
> >>
> >> On Fri, May 25, 2012 at 10:19 AM,  <vm...@apache.org> wrote:
> >> > Author: vmpn
> >> > Date: Fri May 25 15:19:21 2012
> >> > New Revision: 1342682
> >> >
> >> > URL: http://svn.apache.org/viewvc?rev=1342682&view=rev
> >> > Log:
> >> > JavaHL: Changed return value from the java svn_stream_t read function
> to
> >> > be compatible with the txdelta_next_window function
> >> >
> >> > [ in subversion/bindings/javahl/native ]
> >> >
> >> > * InputStream.cpp
> >> >  (read): Return 0 instead of -1 as expected by the txdelta_next_window
> >> > function
> >> >
> >> > Modified:
> >> >
> >> >
>  subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
> >> >
> >> > Modified:
> >> >
> subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
> >> > URL:
> >> >
> http://svn.apache.org/viewvc/subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp?rev=1342682&r1=1342681&r2=1342682&view=diff
> >> >
> >> >
> ==============================================================================
> >> > ---
> >> >
> subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
> >> > (original)
> >> > +++
> >> >
> subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
> >> > Fri May 25 15:19:21 2012
> >> > @@ -99,6 +99,14 @@ svn_error_t *InputStream::read(void *bat
> >> >   if (JNIUtil::isJavaExceptionThrown())
> >> >     return SVN_NO_ERROR;
> >> >
> >> > +  /*
> >> > +   * Convert -1 from InputStream.read that means EOF, 0 which is
> >> > subversion equivalent
> >> > +   */
> >> > +  if(jread == -1)
> >> > +    {
> >> > +      jread = 0;
> >> > +    }
> >> > +
> >> >   // Put the Java byte array into a helper object to retrieve the
> >> >   // data bytes.
> >> >   JNIByteArray outdata(data, true);
> >> > @@ -107,7 +115,7 @@ svn_error_t *InputStream::read(void *bat
> >> >
> >> >   // Catch when the Java method tells us it read too much data.
> >> >   if (jread > (jint) *len)
> >> > -    jread = -1;
> >> > +    jread = 0;
> >> >
> >> >   // In the case of success copy the data back to the Subversion
> >> >   // buffer.
> >> >
> >> >
> >>
> >>
> >>
> >> --
> >>
> >> uberSVN: Apache Subversion Made Easy
> >> http://www.uberSVN.com/
> >
> >
>
>
>
> --
>
> uberSVN: Apache Subversion Made Easy
> http://www.uberSVN.com/
>

Re: svn commit: r1342682 - /subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp

Posted by Hyrum K Wright <hy...@wandisco.com>.
Thanks for begin willing to work within the guidelines of the project.
 I understand that sometimes they may seem somewhat arbitrary, but
they've grown out of a decade of experience.  While they may at first
appear to increase friction, they generally work out to improve the
efficiency of the project as a whole.

As for this particular fix, I'll go ahead and cherrypick merge it back
to trunk.  Thanks again for the patches!

-Hyrum

On Fri, May 25, 2012 at 11:39 AM, Vladimir Berezniker
<vm...@hitechman.com> wrote:
> As this change plus another one are beneficial for general JavaHL use, I
> will send them as patches on separate threads.
>
> Thank you for the guidance,
>
> Vladimir
>
>
> On Fri, May 25, 2012 at 12:06 PM, Hyrum K Wright <hy...@wandisco.com>
> wrote:
>>
>> Is this change specific to the branch, or is is beneficial for general
>> JavaHL use?  If the latter, it should be committed to trunk first,
>> then backported to the branch.
>>
>> I realize you don't (yet) have commit privileges to trunk.  The way
>> this would usually work is that you'd post the patch, somebody would
>> either apply it to trunk, or just ask you to apply it, and you'd
>> reference that approval in the commit message.
>>
>> -Hyrum
>>
>> On Fri, May 25, 2012 at 10:19 AM,  <vm...@apache.org> wrote:
>> > Author: vmpn
>> > Date: Fri May 25 15:19:21 2012
>> > New Revision: 1342682
>> >
>> > URL: http://svn.apache.org/viewvc?rev=1342682&view=rev
>> > Log:
>> > JavaHL: Changed return value from the java svn_stream_t read function to
>> > be compatible with the txdelta_next_window function
>> >
>> > [ in subversion/bindings/javahl/native ]
>> >
>> > * InputStream.cpp
>> >  (read): Return 0 instead of -1 as expected by the txdelta_next_window
>> > function
>> >
>> > Modified:
>> >
>> >  subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
>> >
>> > Modified:
>> > subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
>> > URL:
>> > http://svn.apache.org/viewvc/subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp?rev=1342682&r1=1342681&r2=1342682&view=diff
>> >
>> > ==============================================================================
>> > ---
>> > subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
>> > (original)
>> > +++
>> > subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
>> > Fri May 25 15:19:21 2012
>> > @@ -99,6 +99,14 @@ svn_error_t *InputStream::read(void *bat
>> >   if (JNIUtil::isJavaExceptionThrown())
>> >     return SVN_NO_ERROR;
>> >
>> > +  /*
>> > +   * Convert -1 from InputStream.read that means EOF, 0 which is
>> > subversion equivalent
>> > +   */
>> > +  if(jread == -1)
>> > +    {
>> > +      jread = 0;
>> > +    }
>> > +
>> >   // Put the Java byte array into a helper object to retrieve the
>> >   // data bytes.
>> >   JNIByteArray outdata(data, true);
>> > @@ -107,7 +115,7 @@ svn_error_t *InputStream::read(void *bat
>> >
>> >   // Catch when the Java method tells us it read too much data.
>> >   if (jread > (jint) *len)
>> > -    jread = -1;
>> > +    jread = 0;
>> >
>> >   // In the case of success copy the data back to the Subversion
>> >   // buffer.
>> >
>> >
>>
>>
>>
>> --
>>
>> uberSVN: Apache Subversion Made Easy
>> http://www.uberSVN.com/
>
>



-- 

uberSVN: Apache Subversion Made Easy
http://www.uberSVN.com/

Re: svn commit: r1342682 - /subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp

Posted by Hyrum K Wright <hy...@wandisco.com>.
Thanks for begin willing to work within the guidelines of the project.
 I understand that sometimes they may seem somewhat arbitrary, but
they've grown out of a decade of experience.  While they may at first
appear to increase friction, they generally work out to improve the
efficiency of the project as a whole.

As for this particular fix, I'll go ahead and cherrypick merge it back
to trunk.  Thanks again for the patches!

-Hyrum

On Fri, May 25, 2012 at 11:39 AM, Vladimir Berezniker
<vm...@hitechman.com> wrote:
> As this change plus another one are beneficial for general JavaHL use, I
> will send them as patches on separate threads.
>
> Thank you for the guidance,
>
> Vladimir
>
>
> On Fri, May 25, 2012 at 12:06 PM, Hyrum K Wright <hy...@wandisco.com>
> wrote:
>>
>> Is this change specific to the branch, or is is beneficial for general
>> JavaHL use?  If the latter, it should be committed to trunk first,
>> then backported to the branch.
>>
>> I realize you don't (yet) have commit privileges to trunk.  The way
>> this would usually work is that you'd post the patch, somebody would
>> either apply it to trunk, or just ask you to apply it, and you'd
>> reference that approval in the commit message.
>>
>> -Hyrum
>>
>> On Fri, May 25, 2012 at 10:19 AM,  <vm...@apache.org> wrote:
>> > Author: vmpn
>> > Date: Fri May 25 15:19:21 2012
>> > New Revision: 1342682
>> >
>> > URL: http://svn.apache.org/viewvc?rev=1342682&view=rev
>> > Log:
>> > JavaHL: Changed return value from the java svn_stream_t read function to
>> > be compatible with the txdelta_next_window function
>> >
>> > [ in subversion/bindings/javahl/native ]
>> >
>> > * InputStream.cpp
>> >  (read): Return 0 instead of -1 as expected by the txdelta_next_window
>> > function
>> >
>> > Modified:
>> >
>> >  subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
>> >
>> > Modified:
>> > subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
>> > URL:
>> > http://svn.apache.org/viewvc/subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp?rev=1342682&r1=1342681&r2=1342682&view=diff
>> >
>> > ==============================================================================
>> > ---
>> > subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
>> > (original)
>> > +++
>> > subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
>> > Fri May 25 15:19:21 2012
>> > @@ -99,6 +99,14 @@ svn_error_t *InputStream::read(void *bat
>> >   if (JNIUtil::isJavaExceptionThrown())
>> >     return SVN_NO_ERROR;
>> >
>> > +  /*
>> > +   * Convert -1 from InputStream.read that means EOF, 0 which is
>> > subversion equivalent
>> > +   */
>> > +  if(jread == -1)
>> > +    {
>> > +      jread = 0;
>> > +    }
>> > +
>> >   // Put the Java byte array into a helper object to retrieve the
>> >   // data bytes.
>> >   JNIByteArray outdata(data, true);
>> > @@ -107,7 +115,7 @@ svn_error_t *InputStream::read(void *bat
>> >
>> >   // Catch when the Java method tells us it read too much data.
>> >   if (jread > (jint) *len)
>> > -    jread = -1;
>> > +    jread = 0;
>> >
>> >   // In the case of success copy the data back to the Subversion
>> >   // buffer.
>> >
>> >
>>
>>
>>
>> --
>>
>> uberSVN: Apache Subversion Made Easy
>> http://www.uberSVN.com/
>
>



-- 

uberSVN: Apache Subversion Made Easy
http://www.uberSVN.com/

Re: svn commit: r1342682 - /subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp

Posted by Vladimir Berezniker <vm...@hitechman.com>.
As this change plus another one are beneficial for general JavaHL use, I
will send them as patches on separate threads.

Thank you for the guidance,

Vladimir

On Fri, May 25, 2012 at 12:06 PM, Hyrum K Wright
<hy...@wandisco.com>wrote:

> Is this change specific to the branch, or is is beneficial for general
> JavaHL use?  If the latter, it should be committed to trunk first,
> then backported to the branch.
>
> I realize you don't (yet) have commit privileges to trunk.  The way
> this would usually work is that you'd post the patch, somebody would
> either apply it to trunk, or just ask you to apply it, and you'd
> reference that approval in the commit message.
>
> -Hyrum
>
> On Fri, May 25, 2012 at 10:19 AM,  <vm...@apache.org> wrote:
> > Author: vmpn
> > Date: Fri May 25 15:19:21 2012
> > New Revision: 1342682
> >
> > URL: http://svn.apache.org/viewvc?rev=1342682&view=rev
> > Log:
> > JavaHL: Changed return value from the java svn_stream_t read function to
> be compatible with the txdelta_next_window function
> >
> > [ in subversion/bindings/javahl/native ]
> >
> > * InputStream.cpp
> >  (read): Return 0 instead of -1 as expected by the txdelta_next_window
> function
> >
> > Modified:
> >
>  subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
> >
> > Modified:
> subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
> > URL:
> http://svn.apache.org/viewvc/subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp?rev=1342682&r1=1342681&r2=1342682&view=diff
> >
> ==============================================================================
> > ---
> subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
> (original)
> > +++
> subversion/branches/javahl-ra/subversion/bindings/javahl/native/InputStream.cpp
> Fri May 25 15:19:21 2012
> > @@ -99,6 +99,14 @@ svn_error_t *InputStream::read(void *bat
> >   if (JNIUtil::isJavaExceptionThrown())
> >     return SVN_NO_ERROR;
> >
> > +  /*
> > +   * Convert -1 from InputStream.read that means EOF, 0 which is
> subversion equivalent
> > +   */
> > +  if(jread == -1)
> > +    {
> > +      jread = 0;
> > +    }
> > +
> >   // Put the Java byte array into a helper object to retrieve the
> >   // data bytes.
> >   JNIByteArray outdata(data, true);
> > @@ -107,7 +115,7 @@ svn_error_t *InputStream::read(void *bat
> >
> >   // Catch when the Java method tells us it read too much data.
> >   if (jread > (jint) *len)
> > -    jread = -1;
> > +    jread = 0;
> >
> >   // In the case of success copy the data back to the Subversion
> >   // buffer.
> >
> >
>
>
>
> --
>
> uberSVN: Apache Subversion Made Easy
> http://www.uberSVN.com/
>