You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@beam.apache.org by "Thomas Groh (JIRA)" <ji...@apache.org> on 2017/10/18 17:07:00 UTC

[jira] [Resolved] (BEAM-3006) Minor fix in PipelineTest.testReplacedNames()

     [ https://issues.apache.org/jira/browse/BEAM-3006?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Thomas Groh resolved BEAM-3006.
-------------------------------
       Resolution: Fixed
    Fix Version/s: Not applicable

> Minor fix in PipelineTest.testReplacedNames()
> ---------------------------------------------
>
>                 Key: BEAM-3006
>                 URL: https://issues.apache.org/jira/browse/BEAM-3006
>             Project: Beam
>          Issue Type: Test
>          Components: sdk-java-core
>            Reporter: Uri Silberstein
>            Assignee: Uri Silberstein
>            Priority: Minor
>             Fix For: Not applicable
>
>
> This method tests the pipeline replace functionality. 
> It does so by replacing a OriginalTransform with ReplacementTransform and then assert that the pipeline contains the ReplacementTransform by assert the transformation name.
> The problem is that both transformations (OriginalTransform and ReplacementTransform) have the same transformation name. So the assert doesn't really checks a thing 
> The offered fix:
> Changing the names to "original_name" and "replacement_name" respectively and then asserting that transformation name is "replacement_name" and not "original_name"



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)