You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Jark Wu (Jira)" <ji...@apache.org> on 2019/12/17 08:07:00 UTC
[jira] [Commented] (FLINK-15291) Rename
WatermarkSepc#getWatermarkExpressionString to getWatermarkExpr
[ https://issues.apache.org/jira/browse/FLINK-15291?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16997972#comment-16997972 ]
Jark Wu commented on FLINK-15291:
---------------------------------
cc [~danny0405], [~ykt836]
> Rename WatermarkSepc#getWatermarkExpressionString to getWatermarkExpr
> ---------------------------------------------------------------------
>
> Key: FLINK-15291
> URL: https://issues.apache.org/jira/browse/FLINK-15291
> Project: Flink
> Issue Type: Improvement
> Components: Table SQL / API
> Reporter: Jark Wu
> Priority: Major
> Fix For: 1.10.0
>
>
> Currently, the expression getter methods in {{org.apache.flink.table.api.WatermarkSpec}} and {{org.apache.flink.table.api.TableColumn}} are not aligned, one is {{getWatermarkExpressionString}}, the other is {{getExpr}}.
> I would suggest to rename
> {{WatermarkSepc#getWatermarkExpressionString}} to {{WatermarkSepc#getWatermarkExpr}}.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)