You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tinkerpop.apache.org by "Guobao Chen (Jira)" <ji...@apache.org> on 2021/03/23 06:08:00 UTC

[jira] [Created] (TINKERPOP-2540) Unexpected count() step result

Guobao Chen created TINKERPOP-2540:
--------------------------------------

             Summary: Unexpected count() step result
                 Key: TINKERPOP-2540
                 URL: https://issues.apache.org/jira/browse/TINKERPOP-2540
             Project: TinkerPop
          Issue Type: Bug
          Components: process
    Affects Versions: 3.4.10
            Reporter: Guobao Chen


After installing latest (tinkerpop version 3.4.10), it's found that running a specific gremlin script with 'count()' step gives unexpected result.

*Steps to reproduce*

1 Install tinkerpop 3.4.10, and connect to this server with gremlin console client

2 create a modern graph with TinkerFactory
{code:java}
gremlin> graph = TinkerFactory.createModern()
 ==>tinkergraph[vertices:6 edges:6]{code}
3 query with following script in the result
{code:java}
gremlin> g.V().hasLabel('person').has('name','testuser1').or().has('name','testuser1').values('name','age').dedup().count()
{code}
*Expected result*

a numeric number showing the count (or 0 if there is no vertices from previous steps before count() step)

*Actual result*
 See a list of vertices:
{code:java}
gremlin> g.V().hasLabel('person').has('name','testuser1').or().has('name','testuser1').values('name','age').dedup().count()
 ==>v[1]
 ==>v[2]
 ==>v[3]
 ==>v[4]
 ==>v[5]
 ==>v[6]{code}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)