You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@crunch.apache.org by Matthias Friedrich <ma...@mafr.de> on 2012/07/28 17:46:09 UTC
Namespace for Crunch modules
Hi,
I noticed some namespace inconsistencies that we might want to clean
up before our first Apache release. Now would be the best time to do
this while the number of affected users is still relatively small.
Module "crunch":
Right now "Crunch" means both the Java framework and the parent
project that includes Scrunch and the other modules. We talked about
crunch-core informally, so maybe we should rename the module and the
artifactId to make it consistent with crunch-examples, crunch-test,
and many other projects that use this naming scheme. If there are
plans to modularize crunch some more (ie. move sub-frameworks like
aggregation or joins to their own modules) we could also change the
Java package namespace to "org.apache.crunch.core".
Module "scrunch":
Maven coordinates are currently "org.apache.crunch:scrunch" but the
Scala packages are in "org.apache.scrunch"; I don't know if we're
allowed to use this namespace. If not, I'd suggest to use
"org.apache.crunch.scrunch" and maybe even change the Maven module
to "crunch-scala" (because "crunch-scrunch" sounds really, really
weird).
Module "examples":
I'd change the module name to "crunch-examples" to match the
artifactId.
While module renaming doesn't affect users, changing artifactIds
forces them to change their POMs, and package renaming leads to
either scripting efforts or mass "Organize Imports".
What do you think?
Regards,
Matthias, who knows he keeps bringing up unpopular topics
Re: Namespace for Crunch modules
Posted by Josh Wills <jo...@gmail.com>.
On Thu, Aug 2, 2012 at 12:43 PM, Matthias Friedrich <ma...@mafr.de> wrote:
> Hi,
>
> answers inlined.
>
> On Saturday, 2012-07-28, Josh Wills wrote:
>> On Sat, Jul 28, 2012 at 8:46 AM, Matthias Friedrich <ma...@mafr.de> wrote:
>
> [ rename crunch module to crunch-core ]
>
>> My model for this is avro-- org.apache.avro.* is the core framework and has
>> the artifactId "avro", whereas the other components are "avro-mapred",
>> "avro-tool", etc. So keeping the core named "crunch" is my preference. I'm
>> not all that worried about further modularization of the core.
>
> OK, fair enough.
>
>>> Module "scrunch":
>
>>> Maven coordinates are currently "org.apache.crunch:scrunch" but the
>>> Scala packages are in "org.apache.scrunch"; I don't know if we're
>>> allowed to use this namespace. If not, I'd suggest to use
>>> "org.apache.crunch.scrunch" and maybe even change the Maven module
>>> to "crunch-scala" (because "crunch-scrunch" sounds really, really
>>> weird).
>
>> Yeah, we should probably do this. It's a pain, but that namespace isn't
>> ours.
>
> OK, so the groupId stays "org.apache.crunch". What about the artifactId?
> Leave it at "scrunch" or change it to "crunch-scala" or "crunch-scrunch"?
crunch-scrunch seems the most consistent, although crunch-scala is
more descriptive. I'm indifferent.
>
> The package names should probably match groupId and artifactId. Change
> the base package to "org.apache.crunch.scrunch"?
Yes, I'm afraid so.
>
>>> Module "examples":
>
>>> I'd change the module name to "crunch-examples" to match the
>>> artifactId.
>
>> +1.
>
> OK.
>
> Once we have consensus on Scrunch's coordinates I'll create a JIRA
> issue for it. We should do this before our first Apache release.
>
> Regards,
> Matthias
Re: Namespace for Crunch modules
Posted by Matthias Friedrich <ma...@mafr.de>.
Hi,
answers inlined.
On Saturday, 2012-07-28, Josh Wills wrote:
> On Sat, Jul 28, 2012 at 8:46 AM, Matthias Friedrich <ma...@mafr.de> wrote:
[ rename crunch module to crunch-core ]
> My model for this is avro-- org.apache.avro.* is the core framework and has
> the artifactId "avro", whereas the other components are "avro-mapred",
> "avro-tool", etc. So keeping the core named "crunch" is my preference. I'm
> not all that worried about further modularization of the core.
OK, fair enough.
>> Module "scrunch":
>> Maven coordinates are currently "org.apache.crunch:scrunch" but the
>> Scala packages are in "org.apache.scrunch"; I don't know if we're
>> allowed to use this namespace. If not, I'd suggest to use
>> "org.apache.crunch.scrunch" and maybe even change the Maven module
>> to "crunch-scala" (because "crunch-scrunch" sounds really, really
>> weird).
> Yeah, we should probably do this. It's a pain, but that namespace isn't
> ours.
OK, so the groupId stays "org.apache.crunch". What about the artifactId?
Leave it at "scrunch" or change it to "crunch-scala" or "crunch-scrunch"?
The package names should probably match groupId and artifactId. Change
the base package to "org.apache.crunch.scrunch"?
>> Module "examples":
>> I'd change the module name to "crunch-examples" to match the
>> artifactId.
> +1.
OK.
Once we have consensus on Scrunch's coordinates I'll create a JIRA
issue for it. We should do this before our first Apache release.
Regards,
Matthias
Re: Namespace for Crunch modules
Posted by Josh Wills <jw...@cloudera.com>.
Inlined.
On Sat, Jul 28, 2012 at 8:46 AM, Matthias Friedrich <ma...@mafr.de> wrote:
> Hi,
>
> I noticed some namespace inconsistencies that we might want to clean
> up before our first Apache release. Now would be the best time to do
> this while the number of affected users is still relatively small.
>
>
> Module "crunch":
>
> Right now "Crunch" means both the Java framework and the parent
> project that includes Scrunch and the other modules. We talked about
> crunch-core informally, so maybe we should rename the module and the
> artifactId to make it consistent with crunch-examples, crunch-test,
> and many other projects that use this naming scheme. If there are
> plans to modularize crunch some more (ie. move sub-frameworks like
> aggregation or joins to their own modules) we could also change the
> Java package namespace to "org.apache.crunch.core".
>
My model for this is avro-- org.apache.avro.* is the core framework and has
the artifactId "avro", whereas the other components are "avro-mapred",
"avro-tool", etc. So keeping the core named "crunch" is my preference. I'm
not all that worried about further modularization of the core.
>
>
> Module "scrunch":
>
> Maven coordinates are currently "org.apache.crunch:scrunch" but the
> Scala packages are in "org.apache.scrunch"; I don't know if we're
> allowed to use this namespace. If not, I'd suggest to use
> "org.apache.crunch.scrunch" and maybe even change the Maven module
> to "crunch-scala" (because "crunch-scrunch" sounds really, really
> weird).
>
Yeah, we should probably do this. It's a pain, but that namespace isn't
ours.
>
>
> Module "examples":
>
> I'd change the module name to "crunch-examples" to match the
> artifactId.
>
+1.
>
>
> While module renaming doesn't affect users, changing artifactIds
> forces them to change their POMs, and package renaming leads to
> either scripting efforts or mass "Organize Imports".
>
> What do you think?
>
> Regards,
> Matthias, who knows he keeps bringing up unpopular topics
>
--
Director of Data Science
Cloudera <http://www.cloudera.com>
Twitter: @josh_wills <http://twitter.com/josh_wills>