You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@pivot.apache.org by "Roger Whitcomb (JIRA)" <ji...@apache.org> on 2014/04/22 01:36:15 UTC
[jira] [Created] (PIVOT-946) Simplify construction of TablePane and
TableView rows/columns
Roger Whitcomb created PIVOT-946:
------------------------------------
Summary: Simplify construction of TablePane and TableView rows/columns
Key: PIVOT-946
URL: https://issues.apache.org/jira/browse/PIVOT-946
Project: Pivot
Issue Type: Improvement
Components: wtk, wtk-terra
Affects Versions: 2.0.3
Environment: All
Reporter: Roger Whitcomb
Assignee: Roger Whitcomb
Priority: Minor
Fix For: 2.1
Add the TablePane or TableView as a possible parameter to the constructors of TablePane.Row, etc. as a convenience, instead of having to make a separate call to "getRows().add(...)". Makes user code simpler and easier to follow (that is, the association between row/column and the enclosing table is easier to see and harder to forget).
--
This message was sent by Atlassian JIRA
(v6.2#6252)