You are viewing a plain text version of this content. The canonical link for it is here.
Posted to mapreduce-issues@hadoop.apache.org by "Jeffrey Naisbitt (JIRA)" <ji...@apache.org> on 2011/07/08 20:53:17 UTC

[jira] [Commented] (MAPREDUCE-2621) TestCapacityScheduler fails with "Queue "q1" does not exist"

    [ https://issues.apache.org/jira/browse/MAPREDUCE-2621?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13062113#comment-13062113 ] 

Jeffrey Naisbitt commented on MAPREDUCE-2621:
---------------------------------------------

Looks good to me, and I verified the tests pass for me.  A minor comment: the new getJobTracker method (in UtilsForTests.java) duplicates almost all of the code in the original getJobTracker method.  It would be more maintainable if we could consolidate the duplicated code so we don't have to make future changes in both places - not critical though.

> TestCapacityScheduler fails with "Queue "q1" does not exist"
> ------------------------------------------------------------
>
>                 Key: MAPREDUCE-2621
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2621
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>    Affects Versions: 0.20.205.0
>         Environment: 0.20.1xx-Secondary 
>            Reporter: Sherry Chen
>            Assignee: Sherry Chen
>            Priority: Minor
>         Attachments: MAPREDUCE-2621.patch
>
>
> {quote}
> Error Message
> Queue "q1" does not exist
> Stacktrace
> java.io.IOException: Queue "q1" does not exist
> 	at org.apache.hadoop.mapred.JobInProgress.<init>(JobInProgress.java:354)
> 	at org.apache.hadoop.mapred.TestCapacityScheduler$FakeJobInProgress.<init>(TestCapacityScheduler.java:172)
> 	at org.apache.hadoop.mapred.TestCapacityScheduler.submitJob(TestCapacityScheduler.java:794)
> 	at org.apache.hadoop.mapred.TestCapacityScheduler.submitJob(TestCapacityScheduler.java:818)
> 	at org.apache.hadoop.mapred.TestCapacityScheduler.submitJobAndInit(TestCapacityScheduler.java:825)
> 	at org.apache.hadoop.mapred.TestCapacityScheduler.testMultiTaskAssignmentInMultipleQueues(TestCapacityScheduler.java:1109)
> {quote}
> When queue name is invalid, an exception is thrown now. 

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira