You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Karl Heinz Marbaise (JIRA)" <ji...@apache.org> on 2015/06/21 09:43:00 UTC

[jira] [Commented] (MWAR-350) Add Skip Parameter to Skip the process

    [ https://issues.apache.org/jira/browse/MWAR-350?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14594986#comment-14594986 ] 

Karl Heinz Marbaise commented on MWAR-350:
------------------------------------------

I have taken a look at the patch. First i would name the property not {{maven.deploy.skip}} i would name it {{maven.war.skip}} otherwise users will mistaken with other plugins apart from that maven-war-plugin does not really do the deployment.
I would suggest to implement the skip like this:
{code:java}
       if ( skip )
        {
            getLog().info( "WAR generation is skipped." );
            return;
        }
{code}
Furthermore it would be nice having an integration tests which shows the intendant behaviour.

> Add Skip Parameter to Skip the process
> --------------------------------------
>
>                 Key: MWAR-350
>                 URL: https://issues.apache.org/jira/browse/MWAR-350
>             Project: Maven WAR Plugin
>          Issue Type: New Feature
>    Affects Versions: 2.6
>         Environment: Maven 3.3.3
> maven-war-plugin 2.6
>            Reporter: Keshan De Silva
>            Priority: Trivial
>             Fix For: 2.7
>
>         Attachments: Maven_War_Skip.patch
>
>
> * It will be usefull if maven-war plugin has a skip configuration as in most of the plugins have.
> {code:xml}
> <groupId>org.apache.maven.plugins</groupId>
> <artifactId>maven-war-plugin</artifactId>
> <version>2.6</version>
> <configuration>
>     <skip>true</skip>
> </configuration>
> {code}
> (I have attached a patch file)
>                



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)