You are viewing a plain text version of this content. The canonical link for it is here.
Posted to mapreduce-issues@hadoop.apache.org by "Arun C Murthy (JIRA)" <ji...@apache.org> on 2011/09/07 01:25:10 UTC

[jira] [Updated] (MAPREDUCE-2864) Renaming of configuration property names in yarn

     [ https://issues.apache.org/jira/browse/MAPREDUCE-2864?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Arun C Murthy updated MAPREDUCE-2864:
-------------------------------------

    Status: Open  (was: Patch Available)

Robert, sorry for coming late into this - the patch has gone stale. :(

I'm concerned we are proliferating too many things here:

YarnConfiguration and MRJobConfig are sufficient I think - trying to differentiate YarnConfig into Admin/User/Internal etc. is an overkill IMO.

I'm ok with YarnConfiguration, but maybe we can do with YarnServerConfig and YarnClientConfig? 

Similarly, we can just do with MRJobConfig for now - MR is going to be a Yarn client, thus we can just stick all configs there?

> Renaming of configuration property names in yarn
> ------------------------------------------------
>
>                 Key: MAPREDUCE-2864
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2864
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: jobhistoryserver, mrv2, nodemanager, resourcemanager
>    Affects Versions: 0.23.0, 0.24.0
>            Reporter: Robert Joseph Evans
>            Assignee: Robert Joseph Evans
>             Fix For: 0.23.0, 0.24.0
>
>         Attachments: MR-2864-v1.patch, MR-2864-v2.patch, MR-2864-v3.patch, MR-2864-v4.patch, update.pl, yarnConfigs.csv
>
>
> Now that YARN has been put in to trunk we should do something similar to MAPREDUCE-849.  We should go back and look at all of the configurations that have been added in and rename them as needed to be consistent and subdivided by component.
> # We should use all lowercase in the config names. e.g., we should use appsmanager instead of appsManager etc.
> # history server config names should be prefixed with mapreduce instead of yarn.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira